How to remove all formatting?
Thread poster: Ines Burrell

Ines Burrell  Identity Verified
United Kingdom
Local time: 01:34
Member (2004)
English to Latvian
+ ...
May 30, 2007

I have a large document that has to be translated with Trados where the segments once they are closed present me with completely corrupt special characters. Earlier this week it was concluded that due to the existing formatting there is nothing to be done but remove formatting or translate with Tag Editor.

The client has agreed that formatting can be removed - but it seems I am not sure how to do that. When I select all text and select "Clear formatting" or "Normal" under "Styles and Formatting", the problem with corrupt characters still persists. Even after I chaged the language of "Clear formatting", the problem still persists. I have saved is as rtf, as plain text - nothing, no improvement. So clearly I am doing something wrong.

Any help will be greatly appreciated!
Ines


 

Steven Capsuto  Identity Verified
United States
Local time: 20:34
Member (2004)
Spanish to English
+ ...
A couple of options May 30, 2007

First off, the formatting problem with Trados sometimes happens if the client created the file using a font that either isn't available on your computer or that, for whatever reason, Trados doesn't like.

Try changing the whole document to TimesNewRoman and see if that solves it. At least that way you'll preserve boldface, italics, underlining, etc.

If the problem persists, here's one solution:

1) Open the source document.

2) Use the "select all" feature in Word to highlight all text. (You may have to go back manually to pick up headers, footers, and text boxes.)

3) Copy.

4) Paste the results into a text-only editor, such as Windows Notepad.

5) Select All in the text-only editor.

6) Paste the results into a new Word document and save the file.

Good luck!


 

Ines Burrell  Identity Verified
United Kingdom
Local time: 01:34
Member (2004)
English to Latvian
+ ...
TOPIC STARTER
You are a star!!! May 30, 2007

Thank you so much! Pasting here, there and everywhere helped. I did not know about this trick, really quite simple but clever. now I can finally get down to the job itself and not the styles.

Thanks again!
Ines

[Edited at 2007-05-30 14:18]


 

Tony M
France
Local time: 02:34
Member
French to English
+ ...
Simple crowbar solution May 30, 2007

Save as... a .TXT file, which will cheerfully get rid of any formatting.


Then Save as... a .DOC file so you can work on it

Quick, easy.. and radical!


 

James McVay  Identity Verified
United States
Local time: 20:34
Russian to English
+ ...
Alternative May 30, 2007

I don't know anything about TRADOS, but if you need to convert the original Word document into plain text, the easiest way is to select "Save as" and then "Plain text (.txt)"

 

Steven Capsuto  Identity Verified
United States
Local time: 20:34
Member (2004)
Spanish to English
+ ...
Also a good option May 30, 2007

Tony M wrote:

Save as... a .TXT file, which will cheerfully get rid of any formatting.

Then Save as... a .DOC file so you can work on it

Quick, easy.. and radical!


That works most of the time. But for some files, there's hidden formatting that even that doesn't get rid of... not sure why. It seems to happen mostly with documents that include foreign alphabets.


 

Tony M
France
Local time: 02:34
Member
French to English
+ ...
Thanks for that helpful info! May 30, 2007

Steven Capsuto wrote:
But for some files, there's hidden formatting that even that doesn't get rid of...


Oh, that's worth knowing! I've never yet encountered a DOC for which it hasn't worked, but then again, I don't have occasion to work with foreign alphabets (luckily for me, by the sound of it!)

I have found that other techniques (like save all and change format) did indeed leave stray formatting behind, which is how I came to discover this particular dodge.


 

Henrik Pipoyan  Identity Verified
Local time: 05:34
Member (2004)
English to Armenian
One more way to remove formatting May 30, 2007

Just select the whole text (Ctrl.+A), than hold down the Ctrl. key and hit the spacebar. All formatting will be cleared and the text will appear in the default formatting of MS Word.

 

Lise Smidth  Identity Verified
Austria
Local time: 02:34
German to Danish
+ ...
Great May 30, 2007

Henrik Pipoyan wrote:

Just select the whole text (Ctrl.+A), than hold down the Ctrl. key and hit the spacebar. All formatting will be cleared and the text will appear in the default formatting of MS Word.


Just tried it out - this is a really useful trick. I will certainly remember thaticon_smile.gif


 

Jerzy Czopik  Identity Verified
Germany
Local time: 02:34
Member (2003)
Polish to German
+ ...
Not true May 30, 2007

Henrik Pipoyan wrote:

Just select the whole text (Ctrl.+A), than hold down the Ctrl. key and hit the spacebar. All formatting will be cleared and the text will appear in the default formatting of MS Word.


What you do with this shortcut is to turn all manuall formatting off. But the text will keep all styles, which are there. This shortcut removes only font!! atributes from paragraphs, nothing more.

Try this: format text as Heading 1, then reformat it manually to Tahoma 10 pt. Go to format atributes and change line spacing and space before and after. Then select this text and press CTRL+SPACEBAR. You will see the font will return to what it was before. But the paragraph changes will remain.

If you want to have the whole document in plain text, follow the advice to save the document as plain text. This will really remove all formatting.

Jerzy


 

Piotr Sawiec  Identity Verified
Local time: 02:34
English to Polish
+ ...
paste special May 30, 2007

what I also do is Ctrl+A, cut (Ctrl+X), paste special/unformatted text (I have a macro for that). It removes all formating and, since I use DejaVu, all embedded codes.

Piotr


 

Henrik Pipoyan  Identity Verified
Local time: 05:34
Member (2004)
English to Armenian
Hi Jerzy May 31, 2007

Yes, I know that it does not remove all formatting. Paragraph settings, columns, tabs, styles, like bullets, headings, etc, and even highlighting are not affected. It only removes the formatting of font, or rather restores the default font attributes, which is usually the key to encoding problems, because an encoding problem is mostly a font problem. Even if the problem is connected with some style, it's still the font assigned to that style, which causes the problem. This shortcut restores the default font attributes for all styles used in the document.

When I have an encoding problem – and I often do – I use this shortcut and it always resolves the problem, at least it has until now. But modern programs are becoming more and more complicated, and who knows, maybe this simple solution will not always be helpful.


 

Jerzy Czopik  Identity Verified
Germany
Local time: 02:34
Member (2003)
Polish to German
+ ...
Encoding problems are which I'm fighting with since I started to translate May 31, 2007

in 1990 - I do Polish, so our problems are similar.
And restoring the default font attributes for the styles is often not enough. There are also language setttings, which influence the behaviour of CAT and many more. even the default font itself may cause problems, when it does not understand the proper encoding.

Jerzy


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to remove all formatting?

Advanced search






CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search