Problems with typographic quotation marks (Word2002/TWB)
Thread poster: Erik Freitag

Erik Freitag  Identity Verified
Germany
Local time: 20:35
Member (2006)
Dutch to German
+ ...
Feb 29, 2008

Dear colleagues,

a proofreader has (correctly) pointed out that quite a lot of the quotation marks (in German texts) in my translations are incorrect. Their position is ok (below at the beginning, up at the end), but sometimes they "curl" the wrong way. This leads me to enquiring about a problem I am having since my first days with Trados and Word:

When I am translating a text from English into German (with MS Word 2002 and Trados Workbench (7.5) on a WinXP OS), Word will not insert the correct quotation marks in the target segment. Instead, it seems to use them as in an English text. My workaround is to write the sentence first, giving Word a chance to recognize the correct language (ie, German). Then I go back to the respective positions in the sentence and insert the quotation marks. This will not always work, however. Sometimes I would even have to press Shift+2 and Backspace a couple of times, and only after four or five tries, Word will use the correct quotation mark. I have even gone as far to copy/paste quotation marks from earlier segments. All this of course seriously affects my workflow.

I suspect that this might have to do with Word's language detection. Ideally, it should know that the target segment is German (or whatever language I would chose in Trados Workbench) by definition. But then again, the reason might some incorrect setting in Trados Workbench or something completely different...

Any help with issue is greatly appreciated!

Thanks a lot,
best regards,
Erik


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 21:35
Member (2006)
English to Russian
+ ...
You haven't provided a sample of what you need Feb 29, 2008

So, it's not clear, what's your problem (despite of so many words). Anyway, I can input such quotation marks as «»„“” straightforward with the English or Russian typographic layout for Windows of Ilya Birman, see: http://ilyabirman.ru/tools/typography-layout/ (if you read Russian). I'm not sure, if there is any analog for German.

Direct link Reply with quote
 

Erik Freitag  Identity Verified
Germany
Local time: 20:35
Member (2006)
Dutch to German
+ ...
TOPIC STARTER
Example Feb 29, 2008

Dear esperantisto,

what I need is:

„“


where the quotation marks are curled correctly (resembling 99 (below) and 66 (above), respectively. In my experience, this needs A LOT of fiddling with Word and Trados. No problems with Word alone, though.

Kind regards,
Erik


Direct link Reply with quote
 
Margreet Logmans  Identity Verified
Netherlands
Local time: 20:35
English to Dutch
+ ...
Language specific? Feb 29, 2008

Hi Erik,

the same is true for Dutch. I haven't found a solution, in fact, I fail to see the logic of what Word is doing to the quotation marks in my texts most of the time....

Since the use of quotation marks in this way seems to be language specific, perhaps you should post this question in the German and/or Dutch forums.

I too would be very interested to know how our colleagues solve this problem.

Have a good weekend,
Margreet


Direct link Reply with quote
 

Maxim Manzhosin  Identity Verified
Russian Federation
Local time: 21:35
Member (2008)
English to Russian
Incorrect Autocorrect? Mar 1, 2008

Check the Tools > Autocorrect options in Word. Particularly the "Replace straight quotes with smart quotes" parameter.

HTH.

Best regards,
Maxim Manzhosin


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:35
Member (2003)
Polish to German
+ ...
You have to tell Word, that you work with German Mar 1, 2008

Automatic language recognition ist the worsest option you can chose.
Please set both all styles in the document and the document itself (by pressing CTRL+A to select the whole text and then assigning the German language to it).
Thgis way your quotation marks will be insterted correctly.
You can also replace all " by " (simply put the quotation mark in search for and replace with fields in the S&R window) in the German text after you finished. This way Word will place typographic quotation marks as necessary.

Regards
Jerzy


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 20:35
Member (2005)
English to Czech
+ ...
What purpose? Mar 1, 2008

I mean, sometimes I need Czech quotation marks, sometimes I do not (within localisation, where the uncurly English-like quotes mark "programmer's signs for text strings" which must not be interfered with, automatic "curling" of quotes in Word is a disaster).

That is why I do not like any "automated" solution: I set all my computers such that Ctrl+F5 is the Czech opening quotation mark and Ctrl+F6 is the closing one. This solution took me some (not very long) time to get used to, but now I am really happy with it.

Antonin


Direct link Reply with quote
 

Philippe Etienne  Identity Verified
Spain
Local time: 20:35
Member
English to French
Undo command in Word 2003 Mar 1, 2008

Antoní­n Otáhal wrote:
I mean, sometimes I need Czech quotation marks, sometimes I do not (within localisation, where the uncurly English-like quotes mark "programmer's signs for text strings" which must not be interfered with, automatic "curling" of quotes in Word is a disaster).
...


When Word is auto-curlying, set your document in target language as specified by Jerzy, then when you want a ", type the quotation mark (which will display the language-specific curled quotation mark) and immediately after click the Undo icon. The resulting quotation mark is a straight plain code-compatible quotation mark.

Philippe


Direct link Reply with quote
 

Erik Freitag  Identity Verified
Germany
Local time: 20:35
Member (2006)
Dutch to German
+ ...
TOPIC STARTER
Thanks Mar 2, 2008

Thanks to all answerers. I am still disappointed that such a basic function needs workarounds and fiddling.
Maybe I didn't make myself very clear, but the problem isn't only that the quotation marks curl the wrong way, but that they even are in wrong positions (both above, when in German it shoudl be below at the beginning and above at the end of a quotation). The problem only occurs in the TWB target segment. When I'm writing a text from scratch without TWB, the quotation marks will always be fine, so I think that must have something to do with language settings. Sometimes, I insert and delete a quotation mark repeatedly, and after doing this five or six times, Word would suddenly insert the correct one! Voodoo?

Jerzy Czopik wrote:

Please set both all styles in the document and the document itself



Jerzy, I am not quite sure what you mean. CTRL+A will select the whole document, and I can assign a language. What do you mean by "set all styles"?



Antoní­n Otáhal wrote:
I set all my computers such that Ctrl+F5 is the Czech opening quotation mark and Ctrl+F6 is the closing one.

Antonin


Sounds like a good idea. How exactly do you do that?


Kind regards,
Erik


Direct link Reply with quote
 
Sine Johansen
Local time: 20:35
English to Swedish
Correct quotation marks for Slovenian? Jan 13, 2009

Hi,
I also have a problem with quotation marks. It is my responsibility to standardize quotation marks for my company, and I also managed to do so, until I ran in to Slovenian. I have not been able to get the translators to agree. They say it is either „...” or „...“.
I need someone who actually speaks the language to decide.
Does anyone on this site have an opinion on the subject?
Kind regards
/Sine


Direct link Reply with quote
 

Tony M  Identity Verified
France
Local time: 20:35
Member
French to English
+ ...
Just a thought... Jan 13, 2009

I have absolutely no knowlegde of Slovenian whatever, but as a former hot-metal typographer, I would say that „ “ [I'm not sure how the last character is going to come out, but it is meant to be a '66'] is possibly more likely, since the raised closing quotes have often been created by using the same piece of type as a comma, simply turned upside down. This pragmatic solution avoided printers' having to cast extra, special characters just for quotes.

By no means an authoritative answer, but very widespread in European typographic history!


Direct link Reply with quote
 

Erik Freitag  Identity Verified
Germany
Local time: 20:35
Member (2006)
Dutch to German
+ ...
TOPIC STARTER
hints Jan 13, 2009

Hi!

I have absolutely no knowledge about the Slovenian language, but these links seem to show that the usage is similar to German:

http://en.wikipedia.org/wiki/Quotation_mark,_non-English_usage
http://en.wikipedia.org/wiki/Slovene_punctuation#Inverted_comma

Best regards,
Erik


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problems with typographic quotation marks (Word2002/TWB)

Advanced search






Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search