Glossaries in Finnish
Thread poster: Viivi

Viivi
Finland
Local time: 12:30
Jul 1, 2010

Hello all!

I have been experimenting with OmegaT, but cannot seem to get glossaries to work.

I have read some threads here, and you seem to recommend changing csv-files into utf8. However, as I work with the Finnish language and need Scandinavian characters, I do not think I can do this.

Is there any way to get English-Finnish and Finnish-English glossaries to work in OmegaT?

Any help is appreciated


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 05:30
Member (2008)
Russian to English
+ ...
Using utf8 should not be a problem Jul 1, 2010

I am not an expert, and others may have more to say. But if you follow the instructions in the user's manual EXACTLY, you should have no problem. Unicode encoding is specifically designed to accommodate all alphabets and character sets. I use German and Russian, and don't have a problem.

Susan


Direct link Reply with quote
 

Viivi
Finland
Local time: 12:30
TOPIC STARTER
Thank you, but I still need some tips. Jul 1, 2010

Thank you, Susan. I started a glossary from scratch in Open Office Writer, and it works now.

However, I have a .xls-spreadsheet with hundreds of terms, and I would like to use that. Is there any way I could easily convert that to an .utf8-file?

According to the User Manual you should use Open Office Writer and choose Text Encoded .txt when saving the glossary, but there is no Text Encoded .txt option in Open Office Calc.

Any tips on how to proceed with my spreadsheet...?


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 05:30
Member (2008)
Russian to English
+ ...
glossary from spreadsheet Jul 2, 2010

Sorry to answer so late. Here's what I do, from a CALC spreadsheet in OpenOffice:

I just select the whole thing (control A), and copy and paste it into a text file with extension .utf8
Assuming you have it set up with maximum 3 columns, tab delimited, it will work out fine.
I can't remember how you instruct it to be tab delimited--I think the program asks you at some point whether you want columns delimited by tabs, quote marks, or whatever.

If you have a problem, ask again.

Good luck,
Susan


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 11:30
Member (2007)
English to French
+ ...
"Save as" in Calc Jul 2, 2010

Viivi wrote:
However, I have a .xls-spreadsheet with hundreds of terms, and I would like to use that. Is there any way I could easily convert that to an .utf8-file?

According to the User Manual you should use Open Office Writer and choose Text Encoded .txt when saving the glossary, but there is no Text Encoded .txt option in Open Office Calc.

Any tips on how to proceed with my spreadsheet...?

Open your .xls file in Calc.
(Dialogue labels are back-translated from French, so the actual names can be different.)
Select "Text/CSV" for the format.
Change the extension to .csv. I.e., if your file was MyGlossary.xls, replace it with MyGlossary.csv.
Or simply check: Automatic file name extension.

Check "Edit filter parameter" at the bottom of the dialog.

When you press OK, you will be asked the Character set.
Select Unicode (UTF-8).
, as the field separator.
" as the text separator.

Press OK.

That's all.

Note: The CSV format is recognised since 2.1.3 and above, so you will need OmegaT last version for that.

Didier


Direct link Reply with quote
 

esperantisto  Identity Verified
Local time: 13:30
Member (2006)
English to Russian
+ ...
Or… Jul 2, 2010

Didier Briel wrote:

, as the field separator.
" as the text separator.


{tab} as field separator and
nothing as text separator (you have to manually make it by pressing Delete in the respective field, there is no selectable option as such).

In this case, you have to manually change the file name extension to .utf8.

BTW, the procedure is pretty much the same both for OOo Calc and MSO Excel.


Direct link Reply with quote
 

Viivi
Finland
Local time: 12:30
TOPIC STARTER
So I need a Beta version of OmegaT Jul 2, 2010

Thank you all for your help!

Basically, if I want to work with a spreadsheet, I need to use a Beta version of OmegaT...?

Otherwise I will constantly have to copy and paste from Open Office Calc to Writer as Susan does.


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 05:30
Member (2008)
Russian to English
+ ...
Good to know! Jul 2, 2010

Didier Briel wrote:

Note: The CSV format is recognised since 2.1.3 and above.



I'm glad you answered, Didier. I didn't realize this change. I think it will help me a lot with a certain problem I'm having in trying to import OmegaT glossaries into memoQ, which a client has asked me to use on a trial basis.

Susan


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 11:30
Member (2007)
English to French
+ ...
Of course not Jul 2, 2010

Viivi wrote:
Basically, if I want to work with a spreadsheet, I need to use a Beta version of OmegaT...?

Otherwise I will constantly have to copy and paste from Open Office Calc to Writer as Susan does.

Of course not.

You can save in tab delimited format, as esperantisto has written.

I was just mentioning the easiest way to do it (because with CSV you don't have to change the extension).

Susan could use Calc, too (instead of copy/pasting).

That said, the beta is as stable as the stable version, it's just less documented.

Didier


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 05:30
Member (2008)
Russian to English
+ ...
A problem: column widths are not being preserved Jul 3, 2010

Didier Briel wrote:

Open your .xls file in Calc.
(Dialogue labels are back-translated from French, so the actual names can be different.)
Select "Text/CSV" for the format.
Change the extension to .csv. I.e., if your file was MyGlossary.xls, replace it with MyGlossary.csv.
Or simply check: Automatic file name extension.

Check "Edit filter parameter" at the bottom of the dialog.

When you press OK, you will be asked the Character set.
Select Unicode (UTF-8).
, as the field separator.
" as the text separator.

Press OK.

That's all.



I used this method successfully for some glossaries, but for others it is causing a problem I cannot seem to surmount. I can't figure out what the differences are between the two types.

My glossaries are already in .utf8 text format.
So, I open them in CALC, save as .ods.
The column widths are okay (or maybe I adjust them a bit, making sure "wrapping" is turned on, which it never is).
Then I save that file as "Text/CSV," and check "Edit filter settings."
I press OK, set UTF-8, with field and text separators as you say.
Where it shows "Standard" columns, the columns display correctly.
There are check boxes for "Save cell content as shown" (already checked) and "fixed column width." I tried it both ways (checking one and then the other).
The file opens, and looks okay.
I close it and reopen it.
Now, the box comes up where you set the encoding and delimiters, but at the bottom, where it shows "Standard" columns, only the first column is shown, at full width. Sometimes it only shows the source language; sometimes it shows the first two columns run together, with no separator.

When I click OK and open the file, all the columns are now as wide as the screen--you can't see more than one at a time. (In some of my trials it was different: the columns were obliterated altogether. I don't know how I proceeded differently in the two cases.)
I change each column width with Format>Column>Width>3in [or whatever width]. I set the wrapping again (since it always gets unchecked somehow), with Format>Cells>Alignment>Wrap.
I save the file.
Same thing. Columns are wrong.

What am I doing wrong?

Thanks,
Susan


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 11:30
Member (2007)
English to French
+ ...
Do not confuse export and spreadsheet formats Jul 3, 2010

Susan Welsh wrote:
Then I save that file as "Text/CSV,"
...
I change each column width with Format>Column>Width>3in [or whatever width]. I set the wrapping again (since it always gets unchecked somehow), with Format>Cells>Alignment>Wrap.
I save the file.
Same thing. Columns are wrong.

What am I doing wrong?

If I understand you correctly, you adjust carefully the width, save in a non-spreadsheet format (.csv), and then expect to have your adjustments preserved.

You're not doing something wrong.

Text/CVS is a text format.
It means that it contains only the text, nothing else (including cell width, etc.).

You can open such a file with VI (or Kedit, or whatever you use), and you will see that it cannot contain your adjustments.

If you want to keep things specific to a spreadsheet, then consider the .ods as the source document, and the .csv (or .utf8) as an export. Only do changes on the .ods, and export each time.

My apologies if I have misunderstood what you write.

Didier


Direct link Reply with quote
 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Glossaries in Finnish

Advanced search






SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search