Pages in topic:   [1 2] >
Can't see an active glossary in omega T
Thread poster: howard carter

howard carter
Local time: 08:51
Spanish to English
Aug 28, 2010

I am new to omega t, and have set up a trial glossary, placed in the project glossary file (with two terms (source tab target tab return). Have tried with plain text and with odf, both with the .utf8 coding. However, nothing appears in the glossary window and there is no recognition of the terms even when these appear in the relevant segment. Please help.

 

esperantisto  Identity Verified
Local time: 09:51
Member (2006)
English to Russian
+ ...
More details needed Aug 28, 2010

Provide more information:
a) which version of OmegaT in which environment you use;
b) in each and every detail, how you produced your glossary.

A propos, ODF documents are not recognized as glossaries.


 

freddy7  Identity Verified
France
Local time: 08:51
English to French
+ ...
.utf8 extension Aug 28, 2010

Make sure the file is saved as "encoded text" in utf8, and change the extension as .utf8. Then put it in the glossaries directory. It should work even w/o restarting OmegaT.

I'm using windows version 2.

Fred.


 

Susan Welsh  Identity Verified
United States
Local time: 02:51
Member (2008)
Russian to English
+ ...
details Aug 28, 2010

1. Are the source words inflected? If so, the glossary entry won't match if is not identical. (The OmegaT-tokenizers plug-in takes care of this beautifully. It is a separate sourceforge download from the OmegaT area, and there's a HowTo on how to set it up properly, which is a bit tricky for such non-experts as myself.

2. Most people (myself included) have found that glossary troubles were caused by the fact that they were somehow not following the instructions in the users' manual EXACTLY. Don't try to wing it, esp. if you are not expert in these matters.


 

esperantisto  Identity Verified
Local time: 09:51
Member (2006)
English to Russian
+ ...
Not necessary for latest builds Aug 28, 2010

freddy7 wrote:

and change the extension as .utf8.


This is not mandatory with the latest builds, UTF-8 encoded glossary files can also have .txt name extension.

[Edited at 2010-08-28 11:57 GMT]


 

esperantisto  Identity Verified
Local time: 09:51
Member (2006)
English to Russian
+ ...
That’s why Aug 28, 2010

Susan Welsh wrote:

2. Most people (myself included) have found that glossary troubles were caused by the fact that they were somehow not following the instructions in the users' manual EXACTLY.


That’s why I requested a verbose description of the actual actions taken.


 

howard carter
Local time: 08:51
Spanish to English
TOPIC STARTER
Thanks, procedure used Aug 28, 2010

esperantisto wrote:

Provide more information:
a) which version of OmegaT in which environment you use;
b) in each and every detail, how you produced your glossary.

A propos, ODF documents are not recognized as glossaries.



Omega t 20504, windows vista
Process followed: I open a text file in openoffice
introduce terms source term followed by tab target language term followed by enter i.e. two columns.
Then follow religiously the process for saving the file in the manual
text document in the glossary folder is openoffice text doc with the .utf8 extension.
I have reloaded the source file checked to make sure there is precise coincidence in terms, but no luck. Thanks, H


 

howard carter
Local time: 08:51
Spanish to English
TOPIC STARTER
procedure: Aug 28, 2010

omega t205 4, windows vista
1 create text document in the project glossary file with openoffice.org
enter terms; source term - tab - target term-return
save file in .txt format, religiously following the instructions in the manual.
The saved file in the glossary folder is text file with a .utf8 extension
Nothing appears in the glossary window even when their is an exact coincidence in terms and after reloading the file. Thanks, H


 

Susan Welsh  Identity Verified
United States
Local time: 02:51
Member (2008)
Russian to English
+ ...
@Asker: You can send me the file if you want Aug 28, 2010

I wrote you off-list, but maybe it went into your spam folder, since you haven't answered. Esperantisto is a million times more qualified to trouble-shoot this than I am, but if you want to send me the file through my profile, I'll see if I can figure out the problem.

 

Samuel Murray  Identity Verified
Netherlands
Local time: 08:51
Member (2006)
English to Afrikaans
+ ...
File extension Aug 28, 2010

howard carter wrote:
Have tried with plain text and with odf, both with the .utf8 coding. However, nothing appears in the glossary window and there is no recognition of the terms even when these appear in the relevant segment.


One of the reasons for this may be that your file extension is .utf8.odt. To see if that is so, use a service like wikisend.com. Go through the motions of uploading the file, but before you actually upload it, check the way it is written in the upload field. Or, upload it, and see how the file name is given in the download link.


 

esperantisto  Identity Verified
Local time: 09:51
Member (2006)
English to Russian
+ ...
Windows schizophreny Aug 29, 2010

There is a really schizophrenic thing about Windows: on the one hand, a file name extension is crucial for Windows (Unix-like system do not have a concept of extension at all), but on the other hands, the default setting is to hide the extensions for known file types. Thus, you may believe that you file is somefile.utf8 (because you named it so), but in reality it is somefile.utf8.txt (because Windows hides .txt from you but keeps it irrespective of your renaming). Check, if this is true.

 

Susan Welsh  Identity Verified
United States
Local time: 02:51
Member (2008)
Russian to English
+ ...
@Howard Aug 29, 2010

Forget what I wrote to you privately, about not having two extensions (blahblah.utf8.txt)--the OmegaT experts who actually know what they're talking about tell me that I was wrong. There seems to be nothing wrong with your glossary, as such.

Here's what one colleague recommends:
-----
Here's my guess what happened:

He's using OmegaT 2.0.5 and he's following the "foolproof" instructions in the OmegaT onscreen help for creating a glossary file in OOo.

He adds a .utf8 extension - correct for his version.

However, he's using a more recent version of OOo that doesn't give the option of not automatically adding the file extension. So, OOo automatically adds .txt. That would be no problem if he were using OmegaT 2.1.4 or later, but he isn't.

He should either download and install 2.1.8, or remove the .txt extension from his glossary.
-----

Hope this helps!

Susan


 

Dragomir Kovacevic  Identity Verified
Italy
Local time: 08:51
Italian to Serbian
+ ...
not more than 3 columns in an OmegaT glossary Aug 30, 2010

Have a look onto your glossary, pasting it complete as it is, into a spreadsheet.
Then hit Ctrl+End in order to see where the end of the glossary content IS, or better said: in case you DO have a 4th column, your END cell will fall into the ending line of the D column.

OmegaT tolerates only 3 columns in its glossary: the 3rd being an explanation, reference, or whatever.

It often occurs that colleagues, pasting a Wordfast glossary, find much more ending tabs, because of the richness of possible information a Wf glossary can hold.

Dragomir

howard carter wrote:

omega t205 4, windows vista
1 create text document in the project glossary file with openoffice.org
enter terms; source term - tab - target term-return
save file in .txt format, religiously following the instructions in the manual.
The saved file in the glossary folder is text file with a .utf8 extension
Nothing appears in the glossary window even when their is an exact coincidence in terms and after reloading the file. Thanks, H


 

Samuel Murray  Identity Verified
Netherlands
Local time: 08:51
Member (2006)
English to Afrikaans
+ ...
Re WF glossary Aug 30, 2010

Dragomir Kovacevic wrote:
It often occurs that colleagues, pasting a Wordfast glossary, find much more ending tabs, because of the richness of possible information a Wf glossary can hold.


Yes. The WF glossary format has always accepted 3 columns, and any subsequent columns were simply ignored and treated as if they were part of the 3rd column. In more modern versions of WF, there are more columns, but WF works whether you have more columns or not. Also, one can use a modern WF glossary with an older version of WF easily, because extraneous columns are simply ignored.

I wasn't aware that more than 3 columns in an OmT glossary would cause OmT to fail. That would be a bit silly, if you ask me.


 

Didier Briel  Identity Verified
France
Local time: 08:51
Member (2007)
English to French
+ ...
Yes, glossaries with more than 3 column work Aug 30, 2010

Samuel Murray wrote:
I wasn't aware that more than 3 columns in an OmT glossary would cause OmT to fail.

OmegaT works indeed as can be expected: the first 3 columns are read, and the rest is ignored.

Didier


 
Pages in topic:   [1 2] >


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Can't see an active glossary in omega T

Advanced search






Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search