OmegaT not underlining glossary terms
Thread poster: elm0505
elm0505
Spain
Local time: 12:19
French to Spanish
+ ...
Jul 6, 2011

Hello everyone

I've recently moved my OmegaT folder and projects to another disc, as I don't trust my PC anymore. So far it works smoothly just as usual, but I have found now that, even if the "Glossary" case shows term concordances, the words are not underlined in blue anymore in the source text, thus I can't insert the concordance in the text either.

And spell checking doesn't work anymore, even after re-installing the dictionaries...

How can I fix this?


Best regards

[Editado a las 2011-07-06 11:19 GMT]


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 06:19
Member (2008)
Russian to English
+ ...
Under "Options" Jul 6, 2011

Options > TransTips > Enable TransTips
Options > Spell checking


Direct link Reply with quote
 
elm0505
Spain
Local time: 12:19
French to Spanish
+ ...
TOPIC STARTER
The 1st one worked Jul 6, 2011

Susan Welsh wrote:

Options > TransTips > Enable TransTips


Thank you so much, I had forgotten that option!

Susan Welsh wrote:
Options > Spell checking




It's already checked, but no results... :-S


Direct link Reply with quote
 
elm0505
Spain
Local time: 12:19
French to Spanish
+ ...
TOPIC STARTER
Found it! Jul 6, 2011

Ok, I have finally found the solution desperately browsing other forums. May my case help others, I'm going to explain it using an example:

Translating from Spanish to French. In order for the spell check to work you need to set the langue project properties regionally too, i.e., I had only selected "ES" AND "FR" but the dictionary I had downloaded was "FR_fr". So this is what I've found out: the project's target language code needs to match 100% with the dictionary's, otherwise it won't work. I changed the project properties to FR_FR as target language and voilà! It's working now.

This may seem obvious for those who are more experienced with Omega T, but in my case, having little (or too much) information, I've been struggling with this issue for some time. So has my colleague at work, who couldn't manage to use the German spell checker.

Excuse my excitement, I feel like having discovered the Holy Grail


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 12:19
Member (2007)
English to French
+ ...
The documentation helps Jul 6, 2011

elm0505 wrote:
So this is what I've found out: the project's target language code needs to match 100% with the dictionary's, otherwise it won't work. I changed the project properties to FR_FR as target language and voilà! It's working now.

This may seem obvious for those who are more experienced with Omega T, but in my case, having little (or too much) information, I've been struggling with this issue for some time. So has my colleague at work, who couldn't manage to use the German spell checker.

Quoting the documentation:

Make sure the language code of target files corresponds to the dictionary's language code: an FR-FR dictionary will not work with an FR target setting. You need to change the setting to FR-FR to have the spell checker recognize the correct dictionary for your target. Look for files with the name, indicating the language used and having extensions aff and dic.


Didier


Direct link Reply with quote
 
elm0505
Spain
Local time: 12:19
French to Spanish
+ ...
TOPIC STARTER
:-) Jul 7, 2011

Quoting the documentation:

Make sure the language code of target files corresponds to the dictionary's language code: an FR-FR dictionary will not work with an FR target setting. You need to change the setting to FR-FR to have the spell checker recognize the correct dictionary for your target. Look for files with the name, indicating the language used and having extensions aff and dic.


Didier

Hi Didier, where is that information? I don't recall having read it before...

[Editado a las 2011-07-07 10:47 GMT]


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 12:19
Member (2007)
English to French
+ ...
Press F1 Jul 7, 2011

elm0505 wrote:

Quoting the documentation:

Make sure the language code of target files corresponds to the dictionary's language code: an FR-FR dictionary will not work with an FR target setting. You need to change the setting to FR-FR to have the spell checker recognize the correct dictionary for your target. Look for files with the name, indicating the language used and having extensions aff and dic.


Didier

Hi Didier, where is that information? I don't recall having read it before...

Pressing F1 opens the documentation.

Click on English, then on 20. Spell checker > 3. Hints.

Didier


Direct link Reply with quote
 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


OmegaT not underlining glossary terms

Advanced search






Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search