Source files in source folder "emptying" themselves
Thread poster: elm0505

elm0505
Spain
Local time: 19:59
French to Spanish
+ ...
Oct 18, 2011

Hi everyone
This is me again, apart from the Google issue I've been experiencing some trouble lately with my source files:

- I copy source text in a *.txt or a *.odt file, I save it.
- Then, turns out that when I import it to OmegaT, it's not recognized by the program.
- So I open the file just to find out that it's blank, no text at all. I think "Perhaps I closed the file before saving changes" even if this possibility is highly unlikely.
- Next, I paste tex
... See more
Hi everyone
This is me again, apart from the Google issue I've been experiencing some trouble lately with my source files:

- I copy source text in a *.txt or a *.odt file, I save it.
- Then, turns out that when I import it to OmegaT, it's not recognized by the program.
- So I open the file just to find out that it's blank, no text at all. I think "Perhaps I closed the file before saving changes" even if this possibility is highly unlikely.
- Next, I paste text again, save and close. Just to make sure I reopen the file, the text is still there.
- Try to import the file again to no avail. I open source and the text has vanished again.

It seems that upon importing the file to OmegaT its content simply disappears.

Does anyone know why is this happening?

[Editado a las 2011-10-18 10:43 GMT]

[Editado a las 2011-10-18 11:28 GMT]
Collapse


 

Samuel Murray  Identity Verified
Netherlands
Local time: 19:59
Member (2006)
English to Afrikaans
+ ...
SITE LOCALIZER
What do you mean by "import"? Oct 18, 2011

elm0505 wrote:
It seems that upon importing the file to OmegaT its content simply disappears.


The "import" function in OmegaT is a lazy man's way of copying the file to the /source/ folder. If you copy the file to the /source/ folder, and then use the "import" function, then OmegaT will overwrite what you've copied with what you "import". You seem to already know how to copy files to the /source/ folder yourself (some users don't know how to do that!), so you don't have to use the "import" function.

Try copying the file (make sure it is not empty) and then press F5 in OmegaT, and don't use the "import" function.

If the file is still not recognised, then maybe OmegaT does not recognise the file extension. Go to Options > File Filters and make sure the file extension listed there is the same as your text file's. You may also want to ensure that the encoding is correct (on the same dialog).

If the file you're copying is still open in the text editor, try closing the text editor first -- some programs lock files when they are open in them so that other programs can't access them.


 

elm0505
Spain
Local time: 19:59
French to Spanish
+ ...
TOPIC STARTER
hi Oct 19, 2011

Samuel Murray wrote:

elm0505 wrote:
It seems that upon importing the file to OmegaT its content simply disappears.


The "import" function in OmegaT is a lazy man's way of copying the file to the /source/ folder. If you copy the file to the /source/ folder, and then use the "import" function, then OmegaT will overwrite what you've copied with what you "import". You seem to already know how to copy files to the /source/ folder yourself (some users don't know how to do that!), so you don't have to use the "import" function.

Try copying the file (make sure it is not empty) and then press F5 in OmegaT, and don't use the "import" function.

If the file is still not recognised, then maybe OmegaT does not recognise the file extension. Go to Options > File Filters and make sure the file extension listed there is the same as your text file's. You may also want to ensure that the encoding is correct (on the same dialog).

If the file you're copying is still open in the text editor, try closing the text editor first -- some programs lock files when they are open in them so that other programs can't access them.


The question is that I have a common source file folder for all the languages pairs, it's much easier than copying the same file in every different "Source" folder. Nevertheless, this is a strange bug because I've been doing like this for months and that didn't happen before.
As for compatibility, I use *.txt and *.odt files, so that should not be the problem.


 

Didier Briel  Identity Verified
France
Local time: 19:59
English to French
+ ...
Having a common source folder doesn't mean you have to use Import files Oct 19, 2011

elm0505 wrote:
The question is that I have a common source file folder for all the languages pairs, it's much easier than copying the same file in every different "Source" folder.

Yes, but that doesn't mean you have to use Import files.
Simply use your operating system to copy files to the source folder, wherever it is located.

Didier


 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Source files in source folder "emptying" themselves

Advanced search






TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search