tag disappears in translated XML document
Thread poster: veratek

veratek
Brazil
Local time: 10:50
French to English
+ ...
Mar 6, 2013

Hi,

OmegaT version 2.5.5 update 3

When I tried translating an XML file with the following code, the tags do not appear as in the translation pane, and the completely disappear in the final translated document.

Is there some setting where I can fix this?

original:

Ce guide comporte toutes les informations sur l'utilisation de
DDD dans un client
Windows ou dans le mode Web.

Omegat text to be translated window:
Ce guide comporte toutes les informations sur l'utilisation de DDD dans un client Windows ou dans le mode Web.

So all I get in the end is:

This guide... text... text... Web mode.

Does anyone know how I can preserve the tags in the translated text?

I also didn't find any specific file filter just for a simple XML file in my options.

Thanks.


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 09:50
Member (2008)
Russian to English
+ ...
More info Mar 6, 2013

Pending reply by a more expert person...

What tags are disappearing? There aren't any in what you've written. Tags are not supposed to appear in the translated text (/target/ folder), just the effect of the tags.

The only XML file I know about is .docx, which OmegaT definitely handles.

In any case, you should upgrade to the latest version of OmegaT, which is 2.6.2.


Direct link Reply with quote
 

veratek
Brazil
Local time: 10:50
French to English
+ ...
TOPIC STARTER
proz form made tags disappear as well! Mar 6, 2013

let's see if this will be visible:

(para)Ce guide comporte toutes les informations sur l'utilisation de
(application)PSD(/application) dans un client
(application)Windows(/application) ou dans le mode Web.

In the place of the greater/smaller signs for tags, I substituted them with parentheses.


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 15:50
Member (2007)
English to French
+ ...
Proz forum issue Mar 6, 2013

Susan Welsh wrote:
What tags are disappearing? There aren't any in what you've written.

That's a ProZ forum issue. Lower and greater than signs disappear when the message is submitted.

But you can still see them when you use "Quote"

I post here the original message, with troublesome characters replaced with { and }.

veratek wrote:
When I tried translating an XML file with the following code, the {application} tags do not appear as {a0} in the translation pane, and the completely disappear in the final translated document.

Is there some setting where I can fix this?

original:

{para}Ce guide comporte toutes les informations sur l'utilisation de
{application}DDD{/application} dans un client
{application}Windows{/application} ou dans le mode Web.{/para}

Omegat text to be translated window:
Ce guide comporte toutes les informations sur l'utilisation de DDD dans un client Windows ou dans le mode Web.

So all I get in the end is:

{para}This guide... text... text... Web mode.{/para}

Does anyone know how I can preserve the {application} tags in the translated text?


Didier


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 15:50
Member (2007)
English to French
+ ...
What filter are you using Mar 6, 2013

veratek wrote:
When I tried translating an XML file with the following code, the {application} tags do not appear as {a0} in the translation pane, and the completely disappear in the final translated document.

Is there some setting where I can fix this?

original:

{para}Ce guide comporte toutes les informations sur l'utilisation de
{application}DDD{/application} dans un client
{application}Windows{/application} ou dans le mode Web.{/para}

Most likely, this is a DocBook file.

Omegat text to be translated window:
Ce guide comporte toutes les informations sur l'utilisation de DDD dans un client Windows ou dans le mode Web.

So all I get in the end is:

{para}This guide... text... text... Web mode.{/para}
Does anyone know how I can preserve the {application} tags in the translated text?

Just to be sure: you have not used Remove Tags, have you?

What filter are you using? In 2.6.2, the file list will give you the name of the filter you are using.

I also didn't find any specific file filter just for a simple XML file in my options.

There is no such thing as a simple XML file. What you are translating is probably a DocBook file.

Didier


Direct link Reply with quote
 

veratek
Brazil
Local time: 10:50
French to English
+ ...
TOPIC STARTER
problem solved! thanks Didier! Mar 6, 2013

This was the problem:

"Just to be sure: you have not used Remove Tags, have you?"

I hadn't specifically set it, but it was checked. So I just unchecked it and now it's fine.

Thanks so much!


Direct link Reply with quote
 

Ronja Addams-Moring  Identity Verified
Finland
Local time: 16:50
Finnish to Swedish
+ ...
Change in OmegaT to Project > Properties > Remove Tags Aug 16, 2013

Tangentially: In case someone else also has gotten confused, "Remove Tags" is no more under "Tools" in OmegaT.


Instead, "Remove Tags" is now a project property feature, so if you need this feature please use:

Project > Properties > Remove Tags
or
Ctrl E and check Remove Tags.


It is much harder to use accidentally, which is a plus, but also somewhat harder to find.


Direct link Reply with quote
 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


tag disappears in translated XML document

Advanced search






Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search