Little weird issue on the target line
Thread poster: Piergiorgio Mancini

Piergiorgio Mancini
Italy
Local time: 07:38
English to Italian
+ ...
May 15, 2015

Hi everyone,

I got a wierd issue updating to the latest version of OmegaT (3.1.9)

When I translate inputting a target text, the line get underlined in blue, which stands for a syntax error.

It drives me crazy just seeing that, but what really let me jump from the chair is that no typing error get reported with red underline:

On purpose I wrote "spicology" instead of "psciology" and jumped to the next segment and no error has been red-underlined.


Everthing was fine before updating. I also checked the settings and all is ok the way I always work.

Any suggestions on the case?
Have you guys any settings recommendation to fix that?

Cheers you all,

Have a nice day


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 01:38
Member (2008)
Russian to English
+ ...
language ID? May 15, 2015

As far as I know, this has to do with your spellcheck dictionary, which has to match the ID of your target language. I suggest you check your project properties (ctrl+E). Also make sure your spellchecking is set up right. Options>Spell Checking>automatically check spelling of text. You could also try it with a different document, one that was fine in the past, to make sure there's not something wrong with the way you set up this particular project.

Direct link Reply with quote
 

Piergiorgio Mancini
Italy
Local time: 07:38
English to Italian
+ ...
TOPIC STARTER
Maybe is Dictionaries Installation Issue? May 15, 2015

Hi Susan,

Thanks for your reply. I just double checked the porperties and the spellcheck and everything is fine.

But now I got a doubt. Is that possible that the dictionaries that I installed crush with each other?

I have installed English Dictionaries (US, GB and AU) and the Italian one. Now what I see is that the Italian dictionary is the last in this list. May this be the error?

I am also rembering that the latest jobs where from Italian to English and not like this case English - Italian.

I think you got to the point but still can't figure out how to solve it. Shall I delete the English Dictionaries?


Direct link Reply with quote
 

Susan Welsh  Identity Verified
United States
Local time: 01:38
Member (2008)
Russian to English
+ ...
No May 15, 2015

Don't delete the English dictionaries. I'm sure that's not the problem.
Wait for somebody to reply who is more knowledgeable than I am, or for faster response, post to the Yahoo list:
https://groups.yahoo.com/neo/groups/OmegaT/info


Direct link Reply with quote
 

Piergiorgio Mancini
Italy
Local time: 07:38
English to Italian
+ ...
TOPIC STARTER
no dictionaries issue May 15, 2015

I just tried to delete the dictionaries from the dictionary folder (after backing up) and resulted not to be that the issue.

What I can see so far is that this syntax error get generated randomly for both the languages.

I just looked at the bugs fixed informations about the latest update and it seems they have changed something into the programming structure.

Opened a ticket on the Yahoo! support group, but I think we can just wait for the next update to fix that.


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 07:38
Member (2007)
English to French
+ ...
Blue error are LanguageTool May 15, 2015

Piergiorgio Mancini wrote:
I got a wierd issue updating to the latest version of OmegaT (3.1.9)

When I translate inputting a target text, the line get underlined in blue, which stands for a syntax error.

Not necessarily a syntax error, but something reported by LanguageTool:
https://www.languagetool.org/

To get the details of the error, you have to hover with the mouse cursor over the blue line.


It drives me crazy just seeing that, but what really let me jump from the chair is that no typing error get reported with red underline:

On purpose I wrote "spicology" instead of "psciology" and jumped to the next segment and no error has been red-underlined.


Everthing was fine before updating.

What was the previous version?

Any suggestions on the case?
Have you guys any settings recommendation to fix that?

As far as spell checking goes, following the procedure step by step (double or triple checking everything if needed) always work.

Didier


Direct link Reply with quote
 

Piergiorgio Mancini
Italy
Local time: 07:38
English to Italian
+ ...
TOPIC STARTER
None of these are the case May 15, 2015

I do know about the hovering to view the bug, it saves me a lot of time usually, but in this case doesn't work at all.

This is a real bug as it also underline the first word of the sentence which is "Questo" (this) written perfectly with no upper case error and so forth.

On a segment of 10-15 words none is good according to the spellcheck but for what I can see is spotless.

I am just wasting the whole day in pursuing this error. I have gone over the triple check by many times.

The previous version of the 3.1.9 is the 3.1.8 of course.

I really do not know what's wrong with this issue. I am checking every ten minutes all the settings going for exclusion but nothing gives an hint.


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 09:38
Member (2006)
English to Russian
+ ...
Have you… May 15, 2015

…made steps as per Susan’s advise? For starters, does your project target language ID match the dictionary language ID? What are those?

Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 07:38
Member (2007)
English to French
+ ...
Support is on going on the Yahoo support group May 15, 2015

Piergiorgio Mancini wrote:

I do know about the hovering to view the bug, it saves me a lot of time usually, but in this case doesn't work at all.

This is a real bug as it also underline the first word of the sentence which is "Questo" (this) written perfectly with no upper case error and so forth.

On a segment of 10-15 words none is good according to the spellcheck but for what I can see is spotless.

I am just wasting the whole day in pursuing this error. I have gone over the triple check by many times.

The previous version of the 3.1.9 is the 3.1.8 of course.

I really do not know what's wrong with this issue. I am checking every ten minutes all the settings going for exclusion but nothing gives an hint.

As support as started on the Yahoo support group, it's better to comment there.

Didier


Direct link Reply with quote
 

Piergiorgio Mancini
Italy
Local time: 07:38
English to Italian
+ ...
TOPIC STARTER
segmenting bug May 15, 2015

I think I found out the issue.

The problem is that the segmentation has given too often long sentences and it represents an issue for the spellcheck even though the target language is Italian which has no problems with very long phrases.

I'll try to set the segmentation differently the way I can fix that.

Acknowledged it may be that the issue, it still looks too wierd generating such error with no explanation.


Just for the completeness, I found a beta version: 3.4 which seems to be the very latest.


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 07:38
Member (2007)
English to French
+ ...
Spell checking or language checking? May 15, 2015

Piergiorgio Mancini wrote:

I think I found out the issue.

The problem is that the segmentation has given too often long sentences and it represents an issue for the spellcheck even though the target language is Italian which has no problems with very long phrases.

If the underline is blue, it is not related to spell checking, only to language checking.
Or are you saying the spell checking (in red) is not working because sentences are too long?

I'll try to set the segmentation differently the way I can fix that.

Acknowledged it may be that the issue, it still looks too wierd generating such error with no explanation.

The appropriate location to check that in details is the Yahoo user group, but you have not responded there.

Just for the completeness, I found a beta version: 3.4 which seems to be the very latest.

It is.

Didier


Direct link Reply with quote
 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Little weird issue on the target line

Advanced search






WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search