Problem with OmegaT machine translation
Thread poster: ldongder

ldongder
Singapore
Oct 18, 2015

I use microsoft machine translater in OMEGAT 3.1.9_3 version.

After I created a project, and imported the source files (a .txt file) , the result of the machine translation is in a mess.

Editor window has the following text (I want to translate into Chinese)

G o o g l e T r a n s l a t e A P I p r i c i n g i s b a s e d o n u s a g e .

This is the result of the machine translation:

我 n 公司 e s e s s p e l l p o w e r b y + 4 w h e n S u m m o n E l e m e n t l s p e l l 我 s c s t


So I think it is problem of the spacing of the source file.

After I create a new .txt file at the same directory with same words:'G o o g l e T r a n s l a t e A P I p r i c i n g i s b a s e d o n u s a g e . the translation result for this txt file is successful.

And the only difference between the original source file (.txt file) and the .txt file I created is the file size, but there is no reason for this difference. And this size difference should be the main reason for translation failure.

Who can give a solution?

Thanks so much.

'


 

Susan Welsh  Identity Verified
United States
Local time: 21:07
Member (2008)
Russian to English
+ ...
Google or Microsoft Oct 18, 2015

You write that you use Microsoft MT, but you're getting an error message about Google Translate. Maybe you clicked the wrong MT engine in OmegaT > Options > Machine Translation.

 

Samuel Murray  Identity Verified
Netherlands
Local time: 03:07
Member (2006)
English to Afrikaans
+ ...
Try a different source text encoding Oct 18, 2015

ldongder wrote:
Editor window has the following text:
G o o g l e T r a n s l a t e A P I p r i c i n g i s b a s e d o n u s a g e .


Could it be that your file is in UTF16 and OmegaT thinks it is in UTF8, or vice versa?

In OmegaT, go to Options > File Filters > Text > Edit, and change the source file encoding for the "TXT" file extension to something else, e.g. UTF-16LE, and reload the project to see if that fixes the spacing problem.


 

Didier Briel  Identity Verified
France
Local time: 03:07
Member (2007)
English to French
+ ...
Latest version can detect encoding automatically Oct 18, 2015

Samuel Murray wrote:

ldongder wrote:
Editor window has the following text:
G o o g l e T r a n s l a t e A P I p r i c i n g i s b a s e d o n u s a g e .


Could it be that your file is in UTF16 and OmegaT thinks it is in UTF8, or vice versa?

Yes, probably.

In OmegaT, go to Options > File Filters > Text > Edit, and change the source file encoding for the "TXT" file extension to something else, e.g. UTF-16LE, and reload the project to see if that fixes the spacing problem.

Or switch to the latest version (currently 3.5.2 update 1). Since 3.4, OmegaT can detect the encoding of the source text automatically.

Didier


 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Problem with OmegaT machine translation

Advanced search






PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search