Automatic translation not working despite inserting keys
Thread poster: PetuPatukka
PetuPatukka
Finland
Sep 2, 2016

I'm a new OmegaT user and I've been trying to make the automatic translation work with Microsoft Translate and Google Translate. I've gone through all the hurdles of obtaining the API key (for google translate) and Microsoft Translate client_id and client_secret. I have inserted them in the OmegaT.l4J file and I have also given my credit card details to both. I have activated Google translate in the GoogleAPIs. I've restarted OmegaT. Still I get the message

No se dispone de la ID de cliente en Microsoft Translator o del secreto de cliente. Consulte las instrucciones en el manual de OmegaT.


Clave de la Api de Google no está disponible. Consulte las instrucciones en el manual de OmegaT.


I use OmegaT in Spanish but basically it means that the system cannot make the two "things" talk to each other.

Also in GoogleAPI I tried browser key and server key, neither of them works.

I don't know anymore what to try.

Any ideas?


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 00:03
Member (2007)
English to French
+ ...
Make sure you use the right configuration file Sep 2, 2016

PetuPatukka wrote:
I'm a new OmegaT user and I've been trying to make the automatic translation work with Microsoft Translate and Google Translate. I've gone through all the hurdles of obtaining the API key (for google translate) and Microsoft Translate client_id and client_secret. I have inserted them in the OmegaT.l4J file and I have also given my credit card details to both. I have activated Google translate in the GoogleAPIs. I've restarted OmegaT. Still I get the message

No se dispone de la ID de cliente en Microsoft Translator o del secreto de cliente. Consulte las instrucciones en el manual de OmegaT.


Clave de la Api de Google no está disponible. Consulte las instrucciones en el manual de OmegaT.


I use OmegaT in Spanish but basically it means that the system cannot make the two "things" talk to each other.

Also in GoogleAPI I tried browser key and server key, neither of them works.

I don't know anymore what to try.

Any ideas?

First, make sure you are editing the right configuration file at the right location. For instance, in OmegaT.l4J.ini, change the user language to English:
-Duser.language=en

After that, when you launch OmegaT, is the user interface in English?

Didier


Direct link Reply with quote
 
esperantisto  Identity Verified
Local time: 02:03
Member (2006)
English to Russian
+ ...
Command line Sep 2, 2016

Alternatively, try launching OmegaT from the command line fetching required credentials. If this works, then it’s quite probable that you edit a wrong file.

Direct link Reply with quote
 
PetuPatukka
Finland
TOPIC STARTER
Changing language worked Sep 2, 2016

Thanks for the quick advice. Changing language worked, I could repeat the change easily from Spanish to English and vice versa, so obviously, I'm editing the right file.

I didn't manage to do the command line thing very well. I got all the way to the "command promt window" (black background) but when I got to the command java -jar OmegaT.jar , it didn't recognize the command. At this stage, I was already sweating as things started going beyond my IT skills...

What should I try next?


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 00:03
Member (2006)
English to Afrikaans
+ ...
@Petu Sep 2, 2016

PetuPatukka wrote:
No se dispone de la ID de cliente en Microsoft Translator o del secreto de cliente. Consulte las instrucciones en el manual de OmegaT.
I use OmegaT in Spanish but basically it means that the system cannot make the two "things" talk to each other.


In the in L4J file, remove the "#" before the "-" in the lines with the Google ID and the two Microsoft IDs.


Direct link Reply with quote
 
Slubgob
Poland
my problem Aug 23

Hi, I have a problem with google translation, the comment looks like this:

Google Api key not available. See OmegaT manual for instructions.


My Source Language Tokenizr: is English, target is Polish but it looks like this language is not available in OmegaT. Have you got an idea how can I add The Polish language?


Direct link Reply with quote
 

Didier Briel  Identity Verified
France
Local time: 00:03
Member (2007)
English to French
+ ...
It's not a tokenizer issue, you have to supply Google API key Aug 23

Slubgob wrote:
Hi, I have a problem with google translation, the comment looks like this:

Google Api key not available. See OmegaT manual for instructions.


My Source Language Tokenizr: is English, target is Polish but it looks like this language is not available in OmegaT. Have you got an idea how can I add The Polish language?

Your issue with Google Translate is not related to the tokenizer.

To use Google Translate in OmegaT, you have to supply an API key. See
http://omegat.sourceforge.net/manual-standard/en/chapter.machine.translate.html#introduction

Didier


Direct link Reply with quote
 


There is no moderator assigned specifically to this forum.
To report site rules violations or get help, please contact site staff »


Automatic translation not working despite inserting keys

Advanced search






memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search