Not all TUs upload when importing (Trados 7)
Thread poster: libby965

libby965
United States
Local time: 10:58
Spanish to English
+ ...
Jul 1, 2008

Hi there,

Need some help trying understanding why not all tu's importing in new TM.

I exported original tm (584 TUs). But when I import that .txt file into new empty tm, only 570 are imported. I've tried choosing different options both for export of original and import but always only get 570.

Does anyone know why this may be happening? Thanks in advance! Libby


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 11:58
English to French
+ ...
How did you create that TM? Jul 1, 2008

I think it depends on what was in that TM, that is, how you created it.

For example, if you work with TagEditor, there are not only words in the segments but also tags. Depending on your settings, two segments that contain exactly the same text but different tags can results in one TU in the TM - but with different settings, they can also result in several TUs.

When you import the TM into a blank TM, it may be that several different TUs containing the same text but different tags are imported as only one TU (merged), which is OK because this will most likely result in 98% or 96% matches, which will still show up as you translate. This may explain why you import less TUs than there is in the original TM.

If you provide us with more information on how you created the original TM, what your general Workbench settings are as you perform the import operation and what import settings you use, we may be better equipped to anser your question.

All the best!


Direct link Reply with quote
 

libby965
United States
Local time: 10:58
Spanish to English
+ ...
TOPIC STARTER
Additional info re settings Jul 1, 2008

Hi Viktoria,

Thanks for offering to help! Here are some additional details:

The original TM was created using Winalign and Word documents. When importing, I've tried a few different settings, tried both small and large import file. Under existing units, I tried leave unchanged, merge and overwrite.

When I did the merge option, it still only added 570 out of 584, but said 6 units were updated even though this was the only tm being added.

It may be a tag issue like you've suggested. Is there a way for me to test it?

Thanks again for your ideas and help! Libby


Viktoria Gimbe wrote:

I think it depends on what was in that TM, that is, how you created it.

For example, if you work with TagEditor, there are not only words in the segments but also tags. Depending on your settings, two segments that contain exactly the same text but different tags can results in one TU in the TM - but with different settings, they can also result in several TUs.

When you import the TM into a blank TM, it may be that several different TUs containing the same text but different tags are imported as only one TU (merged), which is OK because this will most likely result in 98% or 96% matches, which will still show up as you translate. This may explain why you import less TUs than there is in the original TM.

If you provide us with more information on how you created the original TM, what your general Workbench settings are as you perform the import operation and what import settings you use, we may be better equipped to anser your question.

All the best!


Direct link Reply with quote
 
S_Angel  Identity Verified
Italy
Local time: 17:58
German to Italian
+ ...
Multiple translations Jul 1, 2008

Another possible cause: if multiple translations are allowed in the original TM but not in the new one, the number of imported TUs would be lower.
Is this the case?


Direct link Reply with quote
 

Steven Capsuto  Identity Verified
United States
Local time: 11:58
Spanish to English
+ ...
WinAlign imports Jul 2, 2008

By default, Workbench applies a percentage penalty to segments created with WinAlign. In other words, during import, if the source text matches a segment that was already in your TM, Workbench will keep the older segment and ignore the one you're importing.

If you go into the settings for the TM, you can disable the alignment penalty and then, in theory, the import should accept all of the aligned segments.

Good luck!

[Edited at 2008-07-02 01:30]


Direct link Reply with quote
 

tectranslate ITS GmbH
Local time: 17:58
German
+ ...
Penalty??? Jul 2, 2008

Steven Capsuto wrote:

By default, Workbench applies a percentage penalty to segments created with WinAlign. In other words, during import, if the source text matches a segment that was already in your TM, Workbench will keep the older segment and ignore the one you're importing.

If you go into the settings for the TM, you can disable the alignment penalty and then, in theory, the import should accept all of the aligned segments.

Good luck!

[Edited at 2008-07-02 01:30]

That is not true, Steven.

The alignment penalty has absolutely no bearing on this (and it shouldn't). Aligned translation units are imported regardless of penalties - I just tried with an example TM.

Considering that this forum is a source for future reference, it would be nice if everybody here could either state facts or clearly label their assumptions and speculation as such. We had several postings in this forum recently that contained speculation stated as fact. That is confusing and misleading and we should all try to cut down on that, imho.

Thanks,
Benjamin

P.S.: I think the "multiple translations" setting is the most likely culprit here.


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Are you using Attribute or Text fields? Jul 2, 2008

Another reason could be the Attributes or Text fields.

Depending on your settings, TRADOS can create duplicate translation unit with the same source text and the same target text but different attribute or text fields.

Perhaps this "duplicated" translation units are being merged or overwritten as you import them into the new TM.

You can easily convert an exported TXT file to a table in Excel with Ando's tools (http://atools.dotsrc.org/)

You can convert your two TMs to Excel tables, sort them alphabetically and locate the missing segments.

Good luck!

Daniel


Direct link Reply with quote
 

libby965
United States
Local time: 10:58
Spanish to English
+ ...
TOPIC STARTER
thanks to everyone Jul 7, 2008

Hi there,

As I do not have multiple tms permitted on either tm, assuming must be something to do with attributes, etc. I'm going to try out the andytool idea and see if I can isolate where I went wrong!

Thanks to everyone who offered ideas/input!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Not all TUs upload when importing (Trados 7)

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search