Trados & Word - insufficient RAM
Thread poster: sophie_jane
sophie_jane
Local time: 01:06
German to English
Sep 9, 2008

I translate documents using Trados and when translating using Word, an error message reading "insufficient RAM" appears. I have checked my harddrive space etc. and I have enough space on the drive I am using.
Does anyone know the reason for this message, if it's a problem, how I can solve it etc.?
A colleague suggested it might be because Trados saves segments in a temporary file, which could be what is taking up all the space.

Any help is greatly appreciated!


Direct link Reply with quote
 

Angela Dickson  Identity Verified
United Kingdom
Local time: 00:06
French to English
+ ...
RAM is not disk space Sep 9, 2008

RAM is not the same thing as hard drive space. In a nutshell, your PC needs hard drive space to store stuff, and RAM for tasks that it does 'on the fly'. You need more RAM.

To find out how much you have, right-click on 'My Computer' and then click 'Properties'. The amount of RAM for me (Windows XP SP2) is displayed on the bottom right under the General tab.

[Edited at 2008-09-09 13:56]


Direct link Reply with quote
 
Jim Tucker  Identity Verified
United States
Hungarian to English
+ ...
RAM is cheap Sep 9, 2008

...and if you have a desktop, it's particularly cheap and easy to find. You need to open up the case, though. Ask any 16-year-old to show you - they know!

If you have a laptop, you need to order RAM specifically designed for your machine. This is usually best done online - or you could just take the laptop to a computer store that carries the right stuff (an authorized dealer for your brand is a sure solution, though not necessarily the cheapest) and have them put it in. It's like plugging in a lego block.

Angela is right: RAM is so-called *memory*, while a hard drive is *storage*. Can be confusing.

In the meantime, you can free up some RAM by closing other programs, particularly browsers, which often "leak" memory and end up using several hundred K.

[Edited at 2008-09-09 11:37]


Direct link Reply with quote
 
sophie_jane
Local time: 01:06
German to English
TOPIC STARTER
Trados - RAM Sep 9, 2008

I am actually based in Germany and use a German version of Word, so the error message which popped up was in German. I translated it and took it to mean RAM.
I looked on the German version of this forum and someone else has had the exact same problem. Apparently it is to do with if you have a large document to translate which also possibly has pictures and then the temporary files created by opening and closing segments is too much for Word to cope with.
No one really came up with a good solution, apart from suggesting translating in RTF and then pre-translating the document in Word or to regularly save and close Word during the translation. None of these really seemed like a good solution to me though.

I have 2 GB of RAM and would have thought that this is sufficient, perhaps not though?


Direct link Reply with quote
 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 01:06
Member (2005)
English to Spanish
+ ...
Word's fault really Sep 9, 2008

sophie_jane wrote:
I have 2 GB of RAM and would have thought that this is sufficient, perhaps not though?


Yes, this is more than enough. We have used Trados with Word on 512 MB machines for a long time. We now have 4 GB in most machines, but 2 GB is really enough.

However, it is true that, as some other colleagues said, if you are working on large files the only solution is to close Word every now and then (every hour or so). The problem is basically that Word keeps track of all the changes you do in Word (and Trados does a lot of changes every time you translate a segment), and this gradually consumes more and more memory.

The only way to overcome we have seen is to save your document and close Word, then reopen the document and continue working. This cleans up Word's Undo memory and will free your memory for more work with Trados.


Direct link Reply with quote
 

Fernando Toledo  Identity Verified
Germany
Local time: 01:06
German to Spanish
Easier Sep 9, 2008

Tomás Cano Binder wrote:

The problem is basically that Word keeps track of all the changes you do in Word (and Trados does a lot of changes every time you translate a segment), and this gradually consumes more and more memory.

The only way to overcome we have seen is to save your document and close Word, then reopen the document and continue working. This cleans up Word's Undo memory and will free your memory for more work with Trados.


Just "Save as..." and save it with the same name, so the old one will be delete.

Also, it is important to make some adjustments in the options, for example, "Image placeholder" ON ( http://wordprocessing.about.com/cs/quicktips/qt/Picplace.htm ).

And, better... do not use Word. Make it in TagEditor.

Regards

fernando
www.lenguatik.com


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Check the Trados KB Sep 9, 2008

Hi,

It might just be that the document had too many bookmarks.

You could just delete them (check with customer first) or prepare them with the bookmark handler macro.

See this article from the Trados Knowlege Base in case it helps.

http://talisma.sdl.com/utility/downloadArticle.aspx?aid=1734

Daniel


Direct link Reply with quote
 
sophie_jane
Local time: 01:06
German to English
TOPIC STARTER
Bookmarks Sep 10, 2008

Hi dgmaga,
I ddidn't have any bookmarks in my document. It was a simple Word document of 56 pages with a few cross references in it.
I think this message must just be due to the temporary word files created by trados opening and closing segments.
Will try saving it more often and see what happens!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados & Word - insufficient RAM

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search