MultiTerm 2007 not working without Server connection
Thread poster: Takashi Koto (X)

Takashi Koto (X)
English to Japanese
Oct 25, 2008

I just reinstalled MultiTerm 2007 on Windows XP Japanese after I installed Service Pack 3 today (10/24/2008). MT 2007 won't create/open any termbase anymore. The error message says "Please make sure that MultiTerm Server is installed on the machine you are trying to conncet to. Class not registered." It was working fine with Windows XP JP with SP 2 last week. Does "Service Pack 3" cause this problem? I can not uninstall SP3. Please advise.

 

Grzegorz Gryc  Identity Verified
Local time: 01:56
French to Polish
+ ...
Local vs server termbase... Oct 25, 2008

hirusagari wrote:

I just reinstalled MultiTerm 2007 on Windows XP Japanese after I installed Service Pack 3 today (10/24/2008).

Why you reinstalled MT?

MT 2007 won't create/open any termbase anymore. The error message says "Please make sure that MultiTerm Server is installed on the machine you are trying to conncet to. Class not registered."

Huh.
An interesting message.
You're sure you select a [b]local[\b] termbase?

Otherwise,you have 2 possible weak points:
- Java, downgrade to the version provided wiht MT2007 (i.e. uninstall all the Java stuff newer than 1.5.0.10 (plain vanilla MT 2007) or 1.5.0.12 (MT 2007 SP1)
- .Net Framework 2.0, the MT setup program may behave erratically when .Net are patched, the standard procedure is to uninstal MT, "unpatch" or uninstall .Net but in fact, it's a wishfully thinking, it may work or not, the MT install procedures are a crap, when you have a problem like this, it's better to start to pray.

It was working fine with Windows XP JP with SP 2 last week. Does "Service Pack 3" cause this problem? I can not uninstall SP3. Please advise.

No, normally MT2007 works fine with XP SP3.

Cheers
GG


[Edited at 2008-10-25 09:09]


 

Peter Linton  Identity Verified
Local time: 00:56
Swedish to English
+ ...
MSXML Oct 25, 2008

I had a very similar problem a few weeks ago, and the answer, suggested by SDL, was that my Microsoft MSXML had somehow become corrupted. Trados makes extensive use of XML routines in this Microsoft software.

They advise removing MSXML (using Control Panel, Add or Remove Programs), then download MSXML (free) from the Microsoft website and reinstall MSXML. Solved my problem.


 

Takashi Koto (X)
English to Japanese
TOPIC STARTER
I gave up Oct 25, 2008

My XP was almost instantly corrupted by a trojan Total Secure 2009. I tried to restore it in vain. So I reinstalled XP and all other stuff. Fortunately my data was okay.

I uninstalled MT 2007, .NET 2 and replced MSXML. I installed MT 2007 with its .NET 2. I still received the error "Please make sure...."

I uninstalled .NET 2, Java 2 and MT 2007. I installed MT 2007 with its .NET 2 and Java 2. The problem remained.

I installed .NET 3.5 SP1 including all versions and Language Pack (Japanese). It did not work.

I uninstalled iTune, Quick Time and Office XP, MT 2007 and Trados Workbench (I was desperate). I installed MT 2007. It stil does not work. Probably the only solution is start over from scratch and delete all other programs and then install MT 2007. I am not sure if it's worth.

Thank you for your advice!


 

Pascal Tatibouet  Identity Verified
France
Local time: 01:56
English to French
Reinstall MSXML File Dec 22, 2008

Peter Linton wrote:

I had a very similar problem a few weeks ago, and the answer, suggested by SDL, was that my Microsoft MSXML had somehow become corrupted. Trados makes extensive use of XML routines in this Microsoft software.

They advise removing MSXML (using Control Panel, Add or Remove Programs), then download MSXML (free) from the Microsoft website and reinstall MSXML. Solved my problem.



Hi,
I've had similar problem with Multiterm (+ another with TagEditor) for the past few days. So I tried what Peter said, ie deleted the MSXML files + reinstall new file from the Microsoft web Site (the difficulty was to choose which file as there were 4 options available, but I picked on the 1st at random). And both problems have gone, ie MT is now accessing the databases and TagEditor Preview is working
Thanks for your help
Pascal Tatibouet


 

Tom Van Cleempoel  Identity Verified
Belgium
Local time: 01:56
English to Dutch
+ ...
Thanks Sep 25, 2010

Two years later and this topic is still saving lives .... reinstalled msxml and got MT + MS Word to work again after a very long evening.

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

MultiTerm 2007 not working without Server connection

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search