French accented characters turning Chinese
Thread poster: Colin Smith

Colin Smith  Identity Verified
France
Local time: 22:30
French to English
Jan 13, 2009

Windows XP/Trados 7 Freelance/Microsoft Word

In a relatively small but annoying percentage of Word documents I find that part or all of the French text undergoes some kind of transformation when I open a segment to translate it: all the characters with accents (é, à etc) turn into Chinese characters. Sometimes this continues for just a few sentences or paragraphs, sometimes the whole document.

For my own TM this is not a problem as I have learnt to read this new franco-chinese language! But customers who ask for the TM back are not happy! Any suggestions?

Thanks

Colin


Direct link Reply with quote
 
Nicolas Coyer  Identity Verified
Colombia
Local time: 16:30
Spanish to French
+ ...
Been there Jan 13, 2009

Hi Colin,


Here the solution given by the TRADOS KB: Export your TM and delete all the info about the fonts except for:


[RTF Preamble]

[FontTable]

{\fonttbl

{\f1 \fmodern\fprq1 \fcharset0 Courier New;}

{\f2 \fswiss\fprq2 \fcharset0 Arial;}

[StyleSheet]

{\stylesheet

{\St \s0 {\StN Normal}}

{\St \cs1 {\StB \v\f1\fs24\sub\cf12 }{\StN tw4winMark}}

{\St \cs2 {\StB \cf4\fs40\f1 }{\StN tw4winError}}

{\St \cs3 {\StB \f1\cf11\lang1024 }{\StN tw4winPopup}}

{\St \cs4 {\StB \f1\cf10\lang1024 }{\StN tw4winJump}}

{\St \cs5 {\StB \f1\cf15\lang1024 }{\StN tw4winExternal}}

{\St \cs6 {\StB \f1\cf6\lang1024 }{\StN tw4winInternal}}

{\St \cs7 {\StB \cf2 }{\StN tw4winTerm}}

{\St \cs8 {\StB \f1\cf13\lang1024 }{\StN DO_NOT_TRANSLATE}}

[/RTF Preamble]

and then create a brand new TM and import the modified file in it.
(Note: I had to replace the chevrons around some tags by brackets so the tags would not be considered as html and made invisible, eg "RTF Preamble")

Good luck,
Nicolas


[Modifié le 2009-01-13 15:00 GMT]


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Add Japanese, Chienes and Korean to the Microsoft Office Language Tools Jan 13, 2009

Colin Smith wrote:

Windows XP/Trados 7 Freelance/Microsoft Word

In a relatively small but annoying percentage of Word documents I find that part or all of the French text undergoes some kind of transformation when I open a segment to translate it: all the characters with accents (é, à etc) turn into Chinese characters. Sometimes this continues for just a few sentences or paragraphs, sometimes the whole document.

For my own TM this is not a problem as I have learnt to read this new franco-chinese language! But customers who ask for the TM back are not happy! Any suggestions?

Thanks

Colin


I have some times this problem and the solution on our side is to add Japanese, Chinese (Traditional), Chinese (Simplified) and Korean to the list of enabled languages through the Microsoft Office Language Settings.

You can find these settings from the Start menu -> Microsoft Office -> Microsoft Office Tools -> Microsoft Office Language settings.

I have seen this problem arising when the original document as drafted in a PC with an Asian operating system or in PC where any of the Asian languages were enabled when the document was created.

Enabling the Asian languages on the PC through the Office Language Settings in the PC where you are doing the translation seems to solve the problem.

For some reason, this very peculiar problem only affects Trados, so it is very difficult to explain the authors of the document why this is a problem.

Daniel


Direct link Reply with quote
 

Colin Smith  Identity Verified
France
Local time: 22:30
French to English
TOPIC STARTER
Chinese... Jan 14, 2009

Thanks Daniel - that would make sense. I have done as you suggested and only time will tell as to whether it happens again!

Colin


Direct link Reply with quote
 

Jacques DP  Identity Verified
Switzerland
Local time: 22:30
Member (2003)
English to French
Nicolas' fix works Jan 31, 2011

This is just to say that I had this precise problem, and Nicolas' fix is correct and works. I would just rephrase it in the following way, so that people don't feel too much afraid of corrupting the file.

In the txt export file, you should delete all font lines except:

{\f1 \fmodern\fprq1 \fcharset0 Courier New;}
{\f2 \fswiss\fprq2 \fcharset0 Arial;}

And all stylesheet lines except:

{\St \s0 {\StN Normal}}
{\St \cs1 {\StB \v\f1\fs24\sub\cf12 }{\StN tw4winMark}}
{\St \cs2 {\StB \cf4\fs40\f1 }{\StN tw4winError}}
{\St \cs3 {\StB \f1\cf11\lang1024 }{\StN tw4winPopup}}
{\St \cs4 {\StB \f1\cf10\lang1024 }{\StN tw4winJump}}
{\St \cs5 {\StB \f1\cf15\lang1024 }{\StN tw4winExternal}}
{\St \cs6 {\StB \f1\cf6\lang1024 }{\StN tw4winInternal}}
{\St \cs7 {\StB \cf2 }{\StN tw4winTerm}}
{\St \cs8 {\StB \f1\cf13\lang1024 }{\StN DO_NOT_TRANSLATE}}

For your information, the general structure of the txt export file is:

<RTF Preamble\>
<FontTable\>

font lines...

<StyleSheet\>

stylesheet lines...

</RTF Preamble\>

[Edited at 2011-01-31 17:09 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

French accented characters turning Chinese

Advanced search







Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search