Can't open .sgm files in TagEditor
Thread poster: Oleksandr Studenyak

Oleksandr Studenyak
Czech Republic
Local time: 18:15
English to Ukrainian
+ ...
Jan 19, 2009

I'm working on Framemaker (version 7.1) localization project and need to translate .sgm files. But every time when I'm trying to open any .sgm file in TagEditor (version 8.0), I'm receiving an error "The parameter is incorrect". I checked those .sgm files and realized that each file contains ID tag (i.e. something like "FileID"), which has no closing tag. If closing tag is added or ID tag is removed from file, then I'm able to open the in the TagEditor.
So I'm wondering if there are any way to disable tag checking in TagEditor? Or maybe somebody could give some advice how to solve this problem.

Thanks,
Alex


Direct link Reply with quote
 

tectranslate ITS GmbH
Local time: 18:15
German
+ ...
The solution seems obvious... Jan 19, 2009

Why don't you just (temporarily) remove the File ID tag before you start translating and re-add it later?

Direct link Reply with quote
 

Oleksandr Studenyak
Czech Republic
Local time: 18:15
English to Ukrainian
+ ...
TOPIC STARTER
Too many files Jan 19, 2009

This could be decision, but there are more then 200 files... And ID tags are different for some files, so it's too big job to be done manually. If I won't find any other decision I create some script to extract ID tags and put them back after translation is done. But I thought that Trados should have some standard way to translate this kind of files.

Direct link Reply with quote
 

Wojciech Froelich  Identity Verified
Poland
Local time: 18:15
English to Polish
Got INI? Jan 19, 2009

Oleksandr Studenyak wrote:

I'm working on Framemaker (version 7.1) localization project and need to translate .sgm files. But every time when I'm trying to open any .sgm file in TagEditor (version 8.0), I'm receiving an error "The parameter is incorrect". I checked those .sgm files and realized that each file contains ID tag (i.e. something like "FileID"), which has no closing tag. If closing tag is added or ID tag is removed from file, then I'm able to open the in the TagEditor.
So I'm wondering if there are any way to disable tag checking in TagEditor? Or maybe somebody could give some advice how to solve this problem.

Thanks,
Alex


Have you received INI file? I guess correct INI file should handle the files.

Wojtek


Direct link Reply with quote
 

Oleksandr Studenyak
Czech Republic
Local time: 18:15
English to Ukrainian
+ ...
TOPIC STARTER
DTD, not INI Jan 19, 2009

I received DTD file and converted it to INI. So, yes, wrong INI file can be the source of problem. Do you know how should be marked such tags in INI file? (I mean tags without closing tags).

Thanks,
Alex

Wojciech Froelich wrote:

Have you received INI file? I guess correct INI file should handle the files.

Wojtek


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 18:15
English to Dutch
+ ...
adding the tag Jan 19, 2009

Oleksandr Studenyak wrote:
So I'm wondering...


how about adding the tag as a non translatable placeholder to the html.ini?

You should be able to do this: TagSettingsManager: select html.ini/properties/add

I’m wondering myself; but it’s what I’d try.

Does this tag have an end slash? < /> ? It should have, I think, for it to work.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Can't open .sgm files in TagEditor

Advanced search







BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search