Problems with Cyrillic characters with Word/Trados
Thread poster: Ivo Haarmann

Ivo Haarmann
Germany
Local time: 23:58
English to German
Jan 20, 2009

Hi,
I'm proofreading a Russain translation in Word with Trados Translator's Workbench.
Every time when I close a segment the cyrillic characters are corrupt and the Russian text is displayed in strange characters.
Does anybody have the same problem? Do you have an idea how to solve this?
I work with Trados 8.2 and Word 2002.
Thanks a lot!
Corina


Direct link Reply with quote
 

Edith Goebel  Identity Verified
Local time: 23:58
German to Danish
+ ...
change Default input language Jan 20, 2009

Hello Corina,

Perhaps it helps to change "Default input language"

Start -> Control Panel -> Regional and Language Options
Click the "Languages" tab and click "Details..."
Change the "Default input language" to Russian.

Good luck!

Edith


Direct link Reply with quote
 

Ivo Haarmann
Germany
Local time: 23:58
English to German
TOPIC STARTER
No, that doesn't help... Jan 20, 2009

Any other ideas?

Direct link Reply with quote
 
Janneke Hopman
Netherlands
Local time: 23:58
English to Dutch
Same problem here, Unicode font doesn't help Jan 23, 2009

I have the same problem (Trados 8.2 and Word 2003), and want to add that it seems to be an encoding problem in Trados (But I'm definitely not an expert, so please correct me if I'm wrong). When I try converting the whole text to a unicode encoded font (Arial Unicode MS) at first it seems like the problem is solved, but then it turns out that the TU's in the TM are saved in a corrupted state. So the next time you open them they are loaded as garbage chars.

There are different mentionings of this problem on this forum, but I couldn't find the solution to it, is this a problem in the encoding of the source text, the font, or a problem in Workbench or in Word? It seems strange that while this problem occurs in some cases, in most cases everything goes well.

If it is a problem in Trados, is there a way to change the Trados settings so it recognises character encoding correctly, automatically or manually?

I find this encoding matter to be very tough to really understand, and this makes it difficult to think of solutions myself. Do people have any tips on how to grasp the basics of encoding and the widespread problem of garbage chars? I like to think a lot of people have this problem, and am interested to know how people usually go about tackling them.


Direct link Reply with quote
 

Antoní­n Otáhal
Local time: 23:58
Member (2005)
English to Czech
+ ...
SC UniPad Jan 23, 2009

As for repairing charsets in text files, SC UniPad http://www.unipad.org/main/ comes handy - it can convert the encoding. Using it, you can repair a Trados TM in its txt export.

Regarding the reasons for the wrong codepages, it is hard to say without details. Perhaps styles (if it is the Workbench +Word combination)?

Antonin


Direct link Reply with quote
 
Janneke Hopman
Netherlands
Local time: 23:58
English to Dutch
no easy way out? Jan 23, 2009

Dear Antonin,

Thanks for your suggestion! I will try this application. But rather than fixing a TM afterwards I would like to be able to actually solve this annoying problem once and for all.

The styles could very well be the problem because this seems to be the difference between documents that have no problem and the ones that get corrupted. The problem is that if I delete all styles form the unclean file the translator sends me, all tags lose their styles too, and I need those to clean the document and update the TM...

Is there a possibility to make Workbench pick the right codepage even in combination with styles? Trados is supposed to work with Word, right? My opinion is that it should also work with styles then, as they are part of Word.

Thanks for your advice.

Janneke


Direct link Reply with quote
 

Aleksandrs Vališevskis
Local time: 00:58
Italian to Latvian
+ ...
Control Panel -> Regional and Lang. Options -> Advanced -> Russian Jul 23, 2009

Hello!

you need to set a language "for non-Unicode programs" to Russian, you can find it here:

Control Panel -> Regional and Language Options -> Advanced -> Russian

It's not a very convenient solution, as you have to restart your computer each time to change this setting, but usually it helps.

It's a long-time and well-known problem with Trados, I'm surprised they haven't solved it yet. The Trados just doesn't use Unicode and 256 characters is way too little for the big world.

Alex


Direct link Reply with quote
 

Kalinka Hristova  Identity Verified
Bulgaria
Local time: 00:58
Member (2007)
English to Bulgarian
+ ...

MODERATOR
Change the font Jul 25, 2009

I know it is now July and that you have posted the question six months ago, but hope that this posting could help other colleagues, too.

I have encountered the same problem with Bulgarian. In the TM the text actually remains in normal Bulgarian (Russian), just the letters in the .doc file appear in a strange way. So, change the font. Something like Arial or Times New Roman should work. I know that this means that after finishing the job, you'll need to change it once again and sometimes it is quite time-consuming, but it works.

Best,

Kalinka


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problems with Cyrillic characters with Word/Trados

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search