C++ Visual Library Runtime Error when installing Trados 2007
Thread poster: Michal Glowacki

Michal Glowacki  Identity Verified
Local time: 18:16
Member (2010)
English to Polish
+ ...
Mar 16, 2009


I have a laptop with windows XP which resists to Trados 2007. The problem arises when I am trying to instal Trados and at one time the dreadful pop up says:

Microsoft Visual C++ Runtime Library
Program: C:\Program Files\SDL Internationa\T2007\tw4win.exe
This application has requested the Runtime to terminate it in an unusual way. Please contact the application's support team for more information.


synergy closes and windows shows a message that the program has to be closed with no reason whatsoever.

When starting TagEditor:
Two error messages:
1. FLEX library initialization failed.

2. The "Word Spelling CHecker" plug-in was not loaded.

The problem is that the runtime error shows both when installing and uninstalling the program. Also, there was a Trados 7 on this computer which use to run smoothly. Then after reinstalation for the 2007 package, this error occured and then installing the previous one had the same effect.

Another: I run the program on windows vista on another computer and everything is ok, no problems whatsoever.

Could someone please help?

I tried installing and uninstalling several times, once with everything off (I mean I used msconfig to turn almost all the processess off and I did not help).


Michal Glowacki  Identity Verified
Local time: 18:16
Member (2010)
English to Polish
+ ...
C++ Visual Library Runtime Error when installing Trados 2007 Mar 18, 2009

please heeeeeeeeeeeeeeeeeeeeeeelp!


Roberto Alberdi  Identity Verified
Local time: 18:16
English to Spanish
Similar problem: no spellchecker > repair installations > Licensing not working Feb 24, 2010

Hi Michal,

I suffer from a very similar problem on my laptop. I use Trados 2007 FL SP2 and Windows Office 2007 on Windows Vista Home Premium. The problem started with Word spellchecker and Word 2.0 spellchecker refusing to work. The plugins just did nothing: I wrote any gibberish in TagEditor and the spellchecker did not detect the mistake. So I went to the Windows Control Panel and repaired the Office 2007 installation, .Net Framework 3.51 installation and Trados 2007 SP2 installation. Then I started TagEditor and Voila, "Flex library initialization failed". Then another pop up window: "the license for TagEditor could not be found locally or on the license server". Finally, TagEditor starts in demo mode. I go to the license manager and I get the same information as Murray here http://esl.proz.com/forum/sdl_trados_support/152531-is_my_trados_activated_or_in_trial_mode.html, so I understand Trados is correctly activated, but it starts n demo mode. I successfully returned the license and activated it again with the activation code, but to no avail. Any ideas about what to do next?


Denys Dömin  Identity Verified
Local time: 19:16
Member (2012)
German to Ukrainian
+ ...
Same problem. A workaround seems to be found Oct 12, 2011

I've had the same problem (quite a strange one, I would say, as the configuration of my system was the same as on other PCs, where I've installed Trados 2007 (build 863), and I've successfully done it several times). I still don't know the reason. After the installation Workbench seemed to work as usual, but closed with two error messages (the first the same as the one displayed during the installation, the second of "unknown software exception" type). But according to my colleagues' advice I've done the following:

1) Uninstalled Trados 2007, Multiterm 2007 and Visual C++

2) Installed SDL Multiterm 2007 first of all

3) Installed Trados 2007 (ignoring the Visual C++ error message)

(after that I was already able to start and use Trados as usual, and closing Workbench I had only one error message. Obvious progressicon_smile.gif)

(in the Workbench's Term Recognition Settings I've unchecked the box "Run terminology recognition in the background")

4) Installed SDL Multiterm 2009.

No more error messages when closing Workbench. All seems to work OK.
(The box "Run terminology recognition in the background" is now checked again)


Alexander Levchenko  Identity Verified
Local time: 19:16
English to Russian
Do you have COMODO installed? Apr 3, 2012

Dennis DIOMIN wrote:

After the installation Workbench seemed to work as usual, but closed with two error messages

I had the same issue and I found out that it was due to a conflict with COMODO. I had to uninstall COMODO completely to solve the problem.

Post removed: This post was hidden by a moderator or staff member because it was not in line with site rule

To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

C++ Visual Library Runtime Error when installing Trados 2007

Advanced search

SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features, ensures new

More info »

  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search