Unwanted bold text in Trados with Word
Thread poster: Annika Hedqvist

Annika Hedqvist  Identity Verified
Sweden
Local time: 03:59
Member (2008)
English to Swedish
+ ...
Apr 24, 2009

I'm having the following problem: In some documents, when opening a new segment, some of the text in and around the segment gets turned into bold text. This is not a disaster, I can just change it back manually, but when it happens time after time it starts to get annoying.

I've found on the Trados Customer Portal that it can have something to do with your language settings. I had support for Greek in both Word and the language settings in the status tray (bottom right corner of the screen). I removed that, restarted Word (but not the entire computer, though), but it still doesn't seem to help.

The Trados Customer Portal ( http://talisma.sdl.com/display/2n/index.aspx?c=&cpc=&cid=&cat=&catURL=&r=0.844204604625702 ) also suggests that the document itself can be wrongly formatted, but I'm not sure I fully understand what "define a style" means and how you're supposed to fix a poorly defined document. But it seems to be just as time consuming as manually changing the bold text back when it appears, though.

Is there any other way of fixing this problem?

And if Trados are aware of the problem, why don't they do something about it instead of just telling us all to deactivate our language settings? It's not a very user friendly program...


Direct link Reply with quote
 
Claudio Porcellana  Identity Verified
Italy
Unwanted bold text in Trados with Word Apr 24, 2009

Hi Annika

if the document is wrongly formatted, you can try the "Clean Up" option before translating
Tools/Clean Up then Options/Translation Memory Options, Tools tag and finally, Strip unused fonts and Strip unused styles

another way is to save a .doc file in .rtf and then the .rtf file in .doc again
or to use the copy-paste option with an intermediate passage in Notepad
but sometimes, if you remove fonts/styles, you can kill some important layout element ...
so in these situation, you must do some manual (and very boring) work

furthermore, were you heard that SDL is a friendly software ... ;-D

[Modificato alle 2009-04-24 16:01 GMT]


Direct link Reply with quote
 

Sergei Leshchinsky  Identity Verified
Ukraine
Local time: 04:59
Member (2008)
English to Russian
+ ...
To strip Apr 24, 2009

the formatting to the sufficient minimum, I always open DOC file in WordPad, insert any character, then remove it (it is to make the program know the file has been modified to activate the save function) and save it (also to DOC).

Attention: frames may be lost or get converted into text (and inserted somewhere).


Direct link Reply with quote
 

David Earl  Identity Verified
United States
Local time: 19:59
Member (2007)
German to English
Styles Apr 24, 2009

Hi Annika,

Styles are preset combinations of formatting information. "Normal", for example, is a style which says the font is Times New Roman at 12 points and left justified. If I want to change that and add bold formatting to the Normal style then I create a new style, give it the name "NormalBold", check the Bold checkbox on the Font dialog and store the style combination.

The style for a given paragraph seems to be stored with the paragraph mark (¶) at the end of the paragraph.

However, that is not the only way to change formatting information. It can also be changed "in-line" with the text and that is what causes the problems for Trados. If I have a couple of words in sentence in bold, I don't use a style for that. Instead, I do something like:

A sentence with a <bold on>few words in bold<bold off>.¶Normal

Trados cannot anticipate that in-line formatting and doesn't know wear to put it in the translation unit. I think that is understandable. The problem you are describing sounds like the original author did something like this:

<bold off>An entire paragraph of text.<bold on>¶NormalBold

The default style for that paragraph is NormalBold, right? Trados rightly assumes that the NormalBold style should be applied to the entire translation unit and then it is up to you to turn bold off, because Trados cannot understand that this in-line change should be applied to the whole sentence.

One of the agencies that I work with has customers (several), who think the default font should be Arial instead of Times New Roman. Do they create a new style, NormalArial, which would be the best approach? No. They use Normal and reset the font to Arial. Drives me a little nuts sometimes, but...that's why we get "the big bucks", right? (Actually, I cheated. I created another DOT for that agency and use it instead. The primary change in that DOT is that the Normal style is set to use Arial as the default font.)

If you want to, need to, learn more about styles, I would recommend playing with the Styles menu option under the Format menu. That option will open a dialog named "Style" and there is a "New" button on that dialog, which opens another dialog. The "New Style" dialog has a button labeled "Format", which hides all of the various formatting options that can be combined to create a style combination. The ability to combine those options and save them in pre-set combinations is, for me, the difference between text editor and word processing software. It takes time to learn, but saves time when you know how it works.

Sorry that there isn't much help for your problem.


Direct link Reply with quote
 

Annika Hedqvist  Identity Verified
Sweden
Local time: 03:59
Member (2008)
English to Swedish
+ ...
TOPIC STARTER
Thanks Apr 24, 2009

Hi and thanks for your answers!

I tried cleaning up, saving in rtf and saving as doc in WordPad but nothing seemed to really do much. And it sounds like stripping the document of styles just gives me other problems, anyhow, so then I can just as well manually change all the bold text when it appears.

David, thanks for your very informative answer. I will look around at the styles settings in Word when I have more time for it. Learning about styles seems useful in general. I'm bound to run into documents of the types you were talking about.

I've actually had a similar problem with a document where the text didn't change when I opened a segment, but the tags did. They got three times as big. I can't remember if they also changed into a different font. It didn't really matter, but looked pretty ridiculous.

And isn't this the ultimate product idea when you're dominant on the market: Keep the program as difficult and messy as possible and then charge people for classes to learn how to use it...


Direct link Reply with quote
 
Claudio Porcellana  Identity Verified
Italy
Unwanted bold text in Trados with Word Apr 24, 2009

Hi Annika

I forgot to say that sometimes, using Tageditor you can avoid all these layout/font issues


Claudio


Direct link Reply with quote
 

paulredstone  Identity Verified
Sweden
Local time: 03:59
Swedish to English
Styles Sep 30, 2009

I've just been struggling with the same problem, which started halfway through a document. I solved it by selecting a non-bold word at the beginning of the document. I then right-clicked and selected 'styles', then 'update normal to match selection'. No more bold!

//Paul


Direct link Reply with quote
 

Annika Hedqvist  Identity Verified
Sweden
Local time: 03:59
Member (2008)
English to Swedish
+ ...
TOPIC STARTER
What about wanted bold text? Sep 30, 2009

Sounds great if it's working. In fact, it sounds too easy...
What happens to text that was supposed to be bold? Could it mess up other formatting?


Direct link Reply with quote
 

paulredstone  Identity Verified
Sweden
Local time: 03:59
Swedish to English
To boldly go... Sep 30, 2009

Hard to believe it could be that simple! But I've checked in other parts of the document, and text that's supposed to be bold is still automatically formatted as bold when opened. Everything seems to be as it should. Perhaps that's worrying in itself. Maybe I've entered some kind of alternative reality where Trados and Microsoft Word are easier to work out than string theory

//P


Direct link Reply with quote
 
xxxStrastran
France
Local time: 03:59
French to English
+ ...
Same problem for me Nov 26, 2009

Hi everyone

I have the same problem with a Word file, except with mine every single sentence and segment is converted to bold text!

I've tried all of the suggestions mentioned above and found no solution.

Interestingly, when I tried Claudio's suggestion (Tools/Clean Up then Options/Translation Memory Options, Tools tag and finally, Strip unused fonts and Strip unused styles), the entire original document was converted to bold text.

I am using TagEditor as a workaround but would rather find a solution as I use voice recognition software, which is much more efficient in Word.

Thanks in advance!

Patrick


Direct link Reply with quote
 

Stuart Robertson  Identity Verified
United Kingdom
Local time: 02:59
Dutch to English
+ ...
still no effective workaround? Jun 9, 2010


I have the same problem with a Word file, except with mine every single sentence and segment is converted to bold text!

I've tried all of the suggestions mentioned above and found no solution.

Interestingly, when I tried Claudio's suggestion (Tools/Clean Up then Options/Translation Memory Options, Tools tag and finally, Strip unused fonts and Strip unused styles), the entire original document was converted to bold text.


I have been having exactly this same problem. Even worse, I have spent ages converting each segment back to normal, only to clean the document and open it and find out it's all back in bold!!!

Don't suppose anyone has ever found a workaround?


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 03:59
English to Czech
+ ...
Work in TagEditor Jun 9, 2010

TagEditor is the solution, as already suggested by other posters.

Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 03:59
French to Polish
+ ...
External tools... Jun 9, 2010

Stanislav Pokorny wrote:

TagEditor is the solution, as already suggested by other posters.


Seconded.
The bilingual DOC/RTF simply doesn't work for trickier files.

If your customers really insist on bilingual DOC/RTF, presegment and use an external editor.
For approx. 10 years, I've been using DV3/DVX and I rarely had formatting problems.
Now, many other programs will do better than Trados, e.g. memoQ.

Cheers
GG


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Unwanted bold text in Trados with Word

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search