SDLX 2007 Freelance Version - SDL Edit Run Time Error - Help!
Thread poster: Annett Hieber

Annett Hieber  Identity Verified
Germany
Local time: 19:26
English to German
May 30, 2009

I have been working for several days at a translation and only today a technical problem arised that drives me nuts: after some time working a message pops up saying "run time error occurs in SDL Edit" and the application has to be closed.

As I have an urgent assignment to complete tomorrow, I would appreciate any helping advice about what to do to solve this!!!!

Thank you all in advance.

Annett

[Edited at 2009-05-30 20:02 GMT]


 

Eugene Gulak  Identity Verified
Ukraine
Local time: 20:26
Member (2007)
English to Russian
+ ...
It sometimes happens May 30, 2009

when the mouse cursor is in a particular segment of the file. If this is the case, try placing the cursor in some other segment and go on with your translation.

If that doesn't work, open your itd file in TagEditor and finish your translation there. It is not a very convenient solution if you prefer to work in SDLX, but it might do the trick (especially if the work is urgent). Just open TagEditor, select File - Open and browse for your itd file (make sure to select All Documents in File Types field).

You may also want to use your SDLX TM in TagEditor. Open SDL Maintain module, load your working TM and export it to TMX format. In Trados Workbench create a new TM and import the TMX file.

Good luck!


 

Annett Hieber  Identity Verified
Germany
Local time: 19:26
English to German
TOPIC STARTER
Thank you - question May 31, 2009

Eugene Gulak wrote:

when the mouse cursor is in a particular segment of the file. If this is the case, try placing the cursor in some other segment and go on with your translation.

If that doesn't work, open your itd file in TagEditor and finish your translation there. It is not a very convenient solution if you prefer to work in SDLX, but it might do the trick (especially if the work is urgent). Just open TagEditor, select File - Open and browse for your itd file (make sure to select All Documents in File Types field).

You may also want to use your SDLX TM in TagEditor. Open SDL Maintain module, load your working TM and export it to TMX format. In Trados Workbench create a new TM and import the TMX file.

Good luck!


Dear Eugene,
Thank you for your advice. You are right, that happens only in a few (however too many!) segments. I translate the segment and when I will confirm it, the error message appears and SDL Edit closes down without saving this segment.

I continued with translating, and when it happens again, I only safe the segment without confirming it. However, I cannot send the file to my client with unconfirmed segments. And he/she also wants it as SDLX file. So my question: do you think I can - after completing the translation - open it in TagEditor as you suggested, confirm there the segments which are left to be confirmed, and then import it back into SDLX?

I would be very glad, if you (or anyone else!) can give me further advice!

Thank you in advance!
Annett


 

Eugene Gulak  Identity Verified
Ukraine
Local time: 20:26
Member (2007)
English to Russian
+ ...
Confirmation Jun 1, 2009

Dear Annett,

You cannot confirm SDLX translations in TagEditor in SDLX sense (confirmed translations are displayed in cyan). However, if you can go on with your translations in SDLX without confirming them, just do it whenever it is possible (the obvious disadvantage is that your unconfirmed translations will not appear in the TM) and, after you have finished translating the file, select from the menu Edit - Confirm/Unconfirm - Confirm Untranslated. When the prompt appears "Do you want to update the translation memory with newly confirmed segments?" answer "Yes", and all the segments will be sent to your TM. Everything will look confirmed (cyan).

If there are segments into which you cannot insert translations (SDL Edit closes down when you put the cursor into the segment), fill in these segments with translations in TagEditor, reopen the file in SDL Edit, select Edit - Confirm/Unconfirm - Confirm Untranslated and - voilà!icon_smile.gif

I noticed this weird behavior in SDLX 2007. Probably, some segments are not handled properly when being imported. In SDLX 2006 everything seemed to be OK.

Good luck!


 

Annett Hieber  Identity Verified
Germany
Local time: 19:26
English to German
TOPIC STARTER
Thank you very much for your help! Jun 1, 2009

Eugene Gulak wrote:

Dear Annett,

You cannot confirm SDLX translations in TagEditor in SDLX sense (confirmed translations are displayed in cyan). However, if you can go on with your translations in SDLX without confirming them, just do it whenever it is possible (the obvious disadvantage is that your unconfirmed translations will not appear in the TM) and, after you have finished translating the file, select from the menu Edit - Confirm/Unconfirm - Confirm Untranslated. When the prompt appears "Do you want to update the translation memory with newly confirmed segments?" answer "Yes", and all the segments will be sent to your TM. Everything will look confirmed (cyan).

If there are segments into which you cannot insert translations (SDL Edit closes down when you put the cursor into the segment), fill in these segments with translations in TagEditor, reopen the file in SDL Edit, select Edit - Confirm/Unconfirm - Confirm Untranslated and - voilà!icon_smile.gif

I noticed this weird behavior in SDLX 2007. Probably, some segments are not handled properly when being imported. In SDLX 2006 everything seemed to be OK.

Good luck!


Dear Eugene,

That was exactly my problem (the confirming and then updating the TM). I was able to finish my translation as described with several segments translated but not confirmed and will go on as you advised.

Thank you for your time and the good advice!

Have a nice day!
Annett


 

Eugene Gulak  Identity Verified
Ukraine
Local time: 20:26
Member (2007)
English to Russian
+ ...
Confirming SDLX segments in TagEditor Jun 1, 2009

Eugene Gulak wrote:

You cannot confirm SDLX translations in TagEditor in SDLX sense (confirmed translations are displayed in cyan).


I have to admit that I was totally wrong here. You CAN confirm/unconfirm SDLX segments in TagEditor. Just click the icon "Confirmed" in SDLX toolbar in TagEditor (View - Toolbars - SDLX) or press Ctrl + Enter which toggles confirmed/unconfirmed status of the segment.

Well, you never know... Live and learn!icon_smile.gif


 

Friderike Butler  Identity Verified
United States
Local time: 13:26
German to English
+ ...
It may be an option setting that is tripping you up Jun 2, 2009

I know you are past your deadline. This is for future reference.

I have run into the situation that the confirmation of certain TUs would crash my system and not only did I have to restart it, it also lost the confirmations of the last several TUs that I was working on since the last automatic system safe.

Apparently that is a known bug with SDLX and it only occurs for some documents when your Auto Match feature is turned on. Go to Options and unclich the Auto Match feature and you won't have the problem anymore. Of course you loose your automated date and number conversions which can be a problem in some texts, but at least you have the option to decide which is the lesser evil. Crashes or unmatched dates and numbers...

Would be interested to hear if that workaround applies in your case.

Ike


 

Annett Hieber  Identity Verified
Germany
Local time: 19:26
English to German
TOPIC STARTER
I am learning and learning Jun 2, 2009

Hi Friderike,

Thank you for this advice. I have followed Eugene's advice and it worked for the document which I delivered yesterday. However, I will immediately do as you said,
I've got a new document waiting.

I will keep you posted!

Annett


 

Annett Hieber  Identity Verified
Germany
Local time: 19:26
English to German
TOPIC STARTER
It worked! It's miraculous! Jun 5, 2009

Hi Friderike,

As promised I am writing back to give you feedback on your
suggestion! I did unclick the function's button and, believe
it or not, it worked! I just finished my text, which was not
a short one, and nothing happened, no error message.

So, thank you once more and I wish you a nice weekend!

Annett


 

Friderike Butler  Identity Verified
United States
Local time: 13:26
German to English
+ ...
:-) - Glad the fix worked for you Jun 5, 2009

Glad I was able to help.

That was a tip from SDLX support through my PMSA, which at the time seemed to be a lot of money to spend, but it has proven to be a lifesaver in so many instances that it was worth the investment. I find that at least the US customer support for SDLX is excellent - very knowledgable and accessible.

Enjoy your weekend!


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDLX 2007 Freelance Version - SDL Edit Run Time Error - Help!

Advanced search







SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features, ensures new

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search