Studio 2009/Multiterm search slowing translation
Thread poster: Tapsa

Tapsa
Local time: 00:50
English to Finnish
Jun 11, 2009

I actually like Studio 2009, but it has some clitches

Previously, the Multiterm search took place in the background (in Workbench). Now, in Studio 2009, it doesn't, which means, in some paragraphs (depending on word count and hits in termbases), a delay of ab. 10 or more seconds before you can start to translate or do something else (and NO, I'm NOT going to turn the term search off). Over the time, this might slow down the translation process considerably, if termbases are used heavily.

Also, the "red lines" indicating termbase hits do not give you the hit when clicked like previously - they seem to be only for cosmetic reason (or to indicate which terms are missing in the termbase). It's time consuming to scroll the hit window back and forth with tens of hits.







[Edited at 2009-06-11 14:56 GMT]

[Edited at 2009-06-11 14:59 GMT]


Direct link Reply with quote
 

kimjasper  Identity Verified
Denmark
Local time: 23:50
Member (2006)
English to Danish
+ ...
Reorganize Jun 11, 2009

Did you try to reorganize the termbase? I am not sure the migration to the new format actually reorganises the termbase as well. FYI I have had benefits from reorganizing imported TMs right after importing them as well.
Kim


Direct link Reply with quote
 

Tapsa
Local time: 00:50
English to Finnish
TOPIC STARTER
Yes, I did Jun 11, 2009

Yes, it is reorganized and so on and so on... The problem is in programming: now the termbase search does NOT happen in the background like previously. In small paragraphs and termbases you don't notice it! but I have a termbase of ab. 100 000 terms that have 1-50 translations each (yes, it goes like this if you buld it like in language-to-language word book)

kimjasper wrote:

Did you try to reorganize the termbase? I am not sure the migration to the new format actually reorganises the termbase as well. FYI I have had benefits from reorganizing imported TMs right after importing them as well.
Kim


Direct link Reply with quote
 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 00:50
Member (2006)
English to Turkish
+ ...
It is not so useful Jun 11, 2009

There is a problem with the design.
First line: term 1
Second line: translation 1
Third line: term 2
Fourth line: translation 2
...

I wonder why a term and its translation are not displayed in the same row.

I recommend programmers of Multiterm to have a look at Deja Vu X's AutoSearch window.


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 23:50
Member (2002)
German to English
+ ...
I cannot get my largest termbase to work at all with Studio Jun 11, 2009

All the terms are in that termbase, but not a single term from it is recognised. The termbase as a whole is simply not recognised. It is my big legal termbase. I have done plenty of reorganising. At first I took over the termbase, and subsequently I tried creating a new termbase in Studio 2009 and then importing the terms. However, absolutely nothing works. Terms from my much smaller termbases are recognised. However, I was doing a legal translation today and was very irritated by not having any term recognition of my legal termbase. The English equivalents of long German legal terms are even longer, and I have always been used to popping them in, rather than typing them out laboriously in full every time. The only way I can copy them instead of typing them now is to have Multiterm open as well, and to keep going to my legal termbase open there, opening up individual entries, and copying the contents to paste. However, it is a long process to access those entries in the first place, because the list of terms does not show up if I enter the term in the box at the top, and the list, for finally accessing the term, will only show up if I enter one letter at a time in the box at the top and work down the list very gradually, giving it plenty of time to refresh after each letter.

Apart from that, I think my computer is not powerful enough for Studio 2009, even though it is only one year old and I have 3 GB RAM.

---


I defragged my computer with PC Pitstop Disk MD only yesterday, and this evening I find Studio 2009 in 3,366 fragments! Maybe that is part of the explanation.

[Edited at 2009-06-11 20:09 GMT]


Direct link Reply with quote
 

David Turner  Identity Verified
Local time: 23:50
French to English
+ ...
Why don't you stop torturing yourselves... Jun 12, 2009

... and go for a decent tool like MemoQ or Deja Vu ?

David


Direct link Reply with quote
 

julienwp
France
Local time: 23:50
English to French
David, why don't you stop posting in SDL forum... Jun 12, 2009

... and go to MemoQ/DV forum?

This is the kind of comment people don't need here. Exactly like Windows vs. Linux... It always leads to pointless debates.

Anyway, here is my workaround (this is why people post here - to get relevant answers/guidance):

@Tapsa:
Use a higher setting in term recognition option (eg. 90-95%). Default value (75%) gets too much results sometimes...

Hope this helps.


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 23:50
French to Polish
+ ...
Flame wars... data base optimization... Jun 12, 2009

JulienP wrote:

... and go to MemoQ/DV forum?

This is the kind of comment people don't need here. Exactly like Windows vs. Linux... It always leads to pointless debates.

But we have a mission from Godicon_smile.gif

Anyway, here is my workaround (this is why people post here - to get relevant answers/guidance):

@Tapsa:
Use a higher setting in term recognition option (eg. 90-95%). Default value (75%) gets too much results sometimes...

For heavily inflected source languages like Polish, a valor like 90-95% is simply absurd.
I often put something like 60-65% or even less.
I suppose it's the same for Finnish (as source), so your suggestion seems to point to an error in some MT algorithms (generally, they're really good but they're not optimized at all).

Try to put your termbase(s) on some different(s) physical hard disk(s).
It should help, I hope (I didn't test MT 2009 on huge termbases).

BTW.
DVX is not perfect but it's more predictable, you can easily use some standard DB access optimization methods as aboveicon_smile.gif

Cheers
GG


Direct link Reply with quote
 

David Turner  Identity Verified
Local time: 23:50
French to English
+ ...
I'd say it's actually quite sound advice. Jun 14, 2009

JulienP wrote:
This is the kind of comment people don't need here.

Anyway, it's not up to you to say who can post where.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009/Multiterm search slowing translation

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search