Trados Toolbar missing in Word
Thread poster: Anett Lindner

Anett Lindner
English to German
Jun 18, 2009


I know this question has already been posted several times and I have tried all the suggestions provided so far.

I use Office XP and Trados 2007 Suite (and so far never encountered any problem).
Yesterday I had to deal with a complexly formatted Word file. When trying to edit one of the many footnotes with Trados, Word crashed. Afterwards the toolbar (by this I mean the buttons for opening, closing segments etc. ) have disappeared. As an option in the menu Trados is still available. But when I try to add the buttons in Word, the entry for TW4Win has disappeard from the dropdown list for adding toolbars.

So far I have:

- checked under addins that is available and it is
- copied the from the SDL folder to the Startup folder for Word
- uninstalled Word and Trados, done a restart and cleaned the registry thoroughly, restarted again and installed all programmes again

To no avail. Is there anything that I can still do to rectify this problem?



Direct link Reply with quote

Doroteja  Identity Verified
Local time: 15:56
English to Latvian
+ ...
Trados Toolbar Jun 18, 2009

Maybe you can try the following: Tools-Templates and Add-INS and check
Good luck!

Direct link Reply with quote

Anett Lindner
English to German
TOPIC STARTER Jun 18, 2009

Hi Doroteja,

thanks but I have already verified that and is checked unter Templates and Addins.



Direct link Reply with quote

Jim Shanks
United Kingdom
Local time: 13:56
Dutch to English
Have you tried this? Jun 18, 2009

I find that registering TRADOS again sometimes resolves problems. Click Register SDL TRADOS 2007 in your Trados folder in the start menu.

Probably won't work, but certainly worth a try.

Direct link Reply with quote

SDL Community  Identity Verified
United Kingdom
Local time: 14:56
Try this... Jun 18, 2009

Hello Anett,

We have an article within the SDL knowledge base which should fix this issue. Please read the following article and follow the instructions provided:

I hope this helps.

Many Thanks,

Gareth Powell
SDL Support Team

Direct link Reply with quote

Jorge Aguilar Juarez  Identity Verified
Local time: 00:56
German to Spanish
busy busy Jun 18, 2009

"After translating footnotes in Word all toolbars disappear from Microsoft Word

You have just finished translating the footnotes from a Word 2000, Word 2002 (also known as Word XP) or Word 2003 document in the footnote document window. When you return to the main document window, all Word toolbars and the menu bar disappear. Keyboard shortcuts for menus and menu commands don't work either. Restarting Word does not restore the toolbars.
In Word 97, 2000, 2002 (XP) and 2003, Translator's Workbench opens a new document window for the translation of footnotes. Word automatically starts a new program instance for any new document windows, and transfers all toolbars and the menu bar into the currently active instance. When you close the footnote document window by clicking Set/Close Next Open/Get, or by pressing [Alt]+[0], this second instance is closed and the toolbars are transferred back to the main document window.

However, if you close the footnote document window by clicking the close (x) button on the Word title bar, the toolbars will not be transferred back to the main document window. Workbench prevents you from closing the footnote window in this incorrect fashion. An error message will be displayed in the status bar, and you cannot close the window. However, if you disable in the footnote window, Word will allow you to close the window. In the main document window, the toolbars will no longer be visible.

Likewise, if you press [Alt]+[0] while the target segment is still empty, Workbench will display the error message You have to close footnote segment before continuing with main segment. After this error message, you can close the footnote document using the Close button. Again, in the main document window, the toolbars will no longer be visible. If you have opened a footnote by mistake and do not want to translate it, make sure to use Restore Source first, and then press [Alt]+[0] to return to the main document window.

Since the incorrect Word view settings have been written to the registry, you have to edit a particular registry entry as follows to correct the problem:

Close Word 2000, 2002 (XP) or 2003.
From the Start menu, select Run.
Type regedit into the Run box, and click OK.
Open the following key:
Word 2000: HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data.
Word 2002 (Word XP): HKEY_CURRENT_USER\Software\Microsoft\Office\10.0\Word\Data.
Word 2003: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Data.
Highlight the Data key, and press [Del].
Confirm that you want to delete the key.
Close the registry.
Launch Word again. The toolbars and menu bar are reset to their default options.
In Word 2002 (Word XP) and Word 2003, you can prevent this problem from happening by forcing Word to display all documents (including the footnote document) in the same application window.

Follow these steps:

From the Tools menu in Word, choose Options. The Options dialog box opens.
On the View tab, deselect the Windows in Taskbar check box. Word will now show all document windows inside one Word application window, thereby preventing the problems described in this article."


Direct link Reply with quote

Anett Lindner
English to German
Removed entry to the registry Jun 19, 2009

Hi again,

I deleted the entry to the registry you specified and the toolbar in Word was reset (and is displayed now in different order) However, still there are no Trados buttons. And this is really draining for me, as I mostly work with a notebook and cannot use the shortcuts therefore.

So is there another solution to the problem?

When reading the postings I learned that several of the respondents also still had to deal with this problem after reinstallation. So my question is: Is there anybody who finally, even after unsuccessful reinstallation, found a solution to the toolbar problem?



Direct link Reply with quote

Mark Haasen B.Tr
Local time: 14:56
English to Dutch
Running macro Jun 24, 2009

Hi Anett,

When you right-click an empty spot on the toolbar area, you see a list of toolbars. This list should contain the "TW4Win" item. If it is not checked, this might explain your problem. Check it and see what happens.

Otherwise, I know for a fact (from experience) that, when the Trados menu has disappeared, you can reset it by running the Add macro through Tools > Macro > Macros in Word. Maybe the macro works for the toolbar too. I cannot verify it, since the programming code is locked.

I've never encountered the toolbar issue you mentioned.

Kind regards,
Mark Haasen

Direct link Reply with quote

Emma Hradecka  Identity Verified
Czech Republic
Local time: 14:56
English to Czech
+ ...
Editing registry helped Oct 31, 2009

I had the same problem as Anett and just wanted to say that editing the registry helped, to hearten those who are still looking for a solution.

Direct link Reply with quote

To report site rules violations or get help, contact a site moderator:

You can also contact site staff by submitting a support request »

Trados Toolbar missing in Word

Advanced search

Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »

  • All of
  • Term search
  • Jobs
  • Forums
  • Multiple search