Pages in topic:   [1 2] >
Studio Error - Attempted to read or write protected memory
Thread poster: Claudia Alvis

Claudia Alvis  Identity Verified
Peru
Local time: 06:06
Member
Spanish
+ ...
Jul 17, 2009

After reformatting my computer, I get this error: Attempted to read or write protected memory. From what I've read, it seems like a system-related problem than a Studio problem, I haven't seen it reported yet. My computer has the basic settings now since I just formated it: Vista SP2, UAC deactivated. I've already emailed someone from SDL and he suggested to run Multiterm as an Administrator, but that didn't make any difference.

This is the the error: Screenshot

This is part of my emailed to SDL:

I get an Error - Attempted to read or write protected memory, similar to what's described here in Article # 2617 in Talisma. The difference is that I don't have terms with Asian characters and I couldn't use that fix since my Home Premium Vista doesn't have that option. I just format my computer and I'm using SP2, which is what I was using in my previous setting, so I don't understand.

The problem happens every time I try to add or edit a new term. I thought it was related to my termbases, I just copied the folder to an external drive and pasted back to the new system, but I created a new termbase and the problem happened again. After the error window pops up, I can't close it or close Multiterm unless I use Windows Task Manager.


Has anybody experienced anything similar or has any light on what might be causing the problem? Also, is there a way to manually add terms to the Multiterm 2009 termbases? I mean, using an external application to modify the termbases with new terms? Something like Access or notepad.

Thanks.

Claudia


Direct link Reply with quote
 

Mena SAE-CHAN
Local time: 19:06
English to Chinese
+ ...
Hope it helps! Oct 23, 2009

Have you solved the issue? If not, you may try the solutions suggested on this website:

http://kb.sagesoftwareonline.com/cgi-bin/sagesoftwareonline.cfg/php/enduser/std_adp.php?p_faqid=24256&p_created=1237400135&p_topview=1


Direct link Reply with quote
 

Anil Gidwani  Identity Verified
India
Local time: 16:36
German to English
+ ...
I'm getting this error too Dec 2, 2009

Hi Claudia,

Were you able to resolve this issue? I'm getting this error too. Unfortunately, Mena's tips did not lead to a solution in my case.


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 13:06
French to Polish
+ ...
Bug Dec 2, 2009

Claudia Alvis wrote:

After reformatting my computer, I get this error: Attempted to read or write protected memory. From what I've read, it seems like a system-related problem than a Studio problem, I haven't seen it reported yet. My computer has the basic settings now since I just formated it: Vista SP2, UAC deactivated. I've already emailed someone from SDL and he suggested to run Multiterm as an Administrator,

LOL.
It means "we have no idea how it works and we can't make it work correctly without administratives rights"...

but that didn't make any difference.

Obviously, it's a bug.
It seems a buffer overflow occurs somewhere in the software.

[...]

This is part of my emailed to SDL:

I get an Error - Attempted to read or write protected memory, similar to what's described here in Article # 2617 in Talisma. The difference is that I don't have terms with Asian characters and I couldn't use that fix since my Home Premium Vista doesn't have that option.

The Asian languages support is installed by default in Windows Vista/7 so your system is already "fixed".
The talisma article is incomplete.

Has anybody experienced anything similar or has any light on what might be causing the problem? Also, is there a way to manually add terms to the Multiterm 2009 termbases? I mean, using an external application to modify the termbases with new terms? Something like Access or notepad.

IMHO you should use MT Convert in order to add terms but it's only a palliative.
For editing, you can use Access but you should be [b]very[b] careful.

Cheers
GG


Direct link Reply with quote
 

Anil Gidwani  Identity Verified
India
Local time: 16:36
German to English
+ ...
Error occurs in the Prepare stage as well Dec 2, 2009

I am unable to start any translation whatsoever after creating a new project and adding a translatable file.

The "Prepare" stage fails with this mysterious error.

Meanwhile, it's good old Trados 2007 for me.


Direct link Reply with quote
 

Claudia Alvis  Identity Verified
Peru
Local time: 06:06
Member
Spanish
+ ...
TOPIC STARTER
It was a system problem Dec 2, 2009

Anil Gidwani wrote:

Hi Claudia,

Were you able to resolve this issue? I'm getting this error too. Unfortunately, Mena's tips did not lead to a solution in my case.



Hi Anil,

I checked my emails to SDL in order to see what the problem was, and it was indeed a system problem. I had a faulty installation. Did you just install any Windows update? If you did, you might want to restore your system to a previous setting. I had to reinstall my system and never saw that problem again.

[Edited at 2009-12-02 17:35 GMT]


Direct link Reply with quote
 

Mena SAE-CHAN
Local time: 19:06
English to Chinese
+ ...
Solved Jan 9, 2010

Restoring the system does solve the problem permanently.

Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 13:06
English to German
+ ...
Error and Crash when entering terms Nov 29, 2010

I am bringing up this thread again, because I seem to have a similar problem lately (with SP3 and all the latest patches).

In my case the error

"Attempted to read or write protected memory. This is often an indication that other memory is corrupt"

appears when trying to enter or edit terms in Studio Termbase Viewer. Studio immediately crashes and if I did not think of pressings Ctrl S, I have to pre-translate the file from the memory.

I have the suspicion, that the error occurs after heavy Multiterm file exports/imports or Studio TM exports/imports... anything with a lot of entries that seem to require a lot of resources, but I am not sure.

Does anyone have an idea how to avoid this nasty Studio crash?


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:06
English
Java issue Dec 2, 2010

Susanne Rieg wrote:

I am bringing up this thread again, because I seem to have a similar problem lately (with SP3 and all the latest patches).

In my case the error

"Attempted to read or write protected memory. This is often an indication that other memory is corrupt"

appears when trying to enter or edit terms in Studio Termbase Viewer. Studio immediately crashes and if I did not think of pressings Ctrl S, I have to pre-translate the file from the memory.

I have the suspicion, that the error occurs after heavy Multiterm file exports/imports or Studio TM exports/imports... anything with a lot of entries that seem to require a lot of resources, but I am not sure.

Does anyone have an idea how to avoid this nasty Studio crash?


Dear Susanne

What is the latest Java version you are using/ you have installed?

Kind regards
Richard


Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 13:06
English to German
+ ...
Java Issue Dec 5, 2010

Sorry for my late response, Richard, my latest installed Java version is 1.6.0_20 and I have "Use next generation Java-Plug-In" activated (the Studio/Multiterm link will not work without it). My other installed Java Versions are: 1.5.0_10 for Suite as well as 1.6.0_13 plus 1.6.0_14. I could probably deinstall the later two?

Sanne


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 13:06
English
Maybe a helpful workaround... Dec 6, 2010

Susanne Rieg wrote:

Sorry for my late response, Richard, my latest installed Java version is 1.6.0_20 and I have "Use next generation Java-Plug-In" activated (the Studio/Multiterm link will not work without it). My other installed Java Versions are: 1.5.0_10 for Suite as well as 1.6.0_13 plus 1.6.0_14. I could probably deinstall the later two?

Sanne


Dear Susanne

You can try the following:

Close all SDL applications.

1. Go to C:\Program Files\Java\jre6\lib
(if you have a 64bit machine go to C:\Program Files (x86)\Java\jre6\lib )

2. Rename the deploy.jar for example to deploy.jar_OLD
3. Download the deploy.jar from here:
ftp://support_downloads:rE4jocZ@ftp-de.sdl.com/Richard/Proz/deploy.jar
4. Save/Download it directly to the location C:\Program Files\Java\jre6\lib
5. Try again now the add/edit terms through SDL Trados Studio 2009.

Cheers
Richard

[Edited at 2010-12-06 09:07 GMT]

[Edited at 2010-12-06 09:08 GMT]


Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 13:06
English to German
+ ...
Java issue Dec 6, 2010

Thanks Richard! I will report back, if this helps...

Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 13:06
English to German
+ ...
Not sure, if it solves the problem, Dec 6, 2010

as I now get a Java Security Warning Box every time I try to enter a term:

"The Application requires an earlier Java-Version. Do you want to continue?"


PS: I have de-installed Java 1.6 Update 20 to get rid of the error message and will report, if this makes a difference.

[Bearbeitet am 2010-12-07 08:44 GMT]


Direct link Reply with quote
 

jimshanks
Local time: 12:06
Dutch to English
Linked to Multiterm? Dec 6, 2010

I encountered this problem tonight trying to save a segment in Studio 2009 SP3. The segment after the offending segment saved correctly. Checking the detail of the error (why did I not save it?) I saw that Multiterm was mentioned. Closing the three termbases in the project resolved the problem.

Now I have reopened the three termbases but cannot reproduce the problem!

I am not sure if this will help anyone, but it is provided for what it is worth.

[Edited at 2010-12-06 20:37 GMT]


Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 13:06
English to German
+ ...
Seems to work Dec 10, 2010

SDL Support wrote:

1. Go to C:\Program Files\Java\jre6\lib
(if you have a 64bit machine go to C:\Program Files (x86)\Java\jre6\lib )
2. Rename the deploy.jar for example to deploy.jar_OLD
3. Download the deploy.jar from here:
ftp://support_downloads:rE4jocZ@ftp-de.sdl.com/Richard/Proz/deploy.jar
4. Save/Download it directly to the location C:\Program Files\Java\jre6\lib
5. Try again now the add/edit terms through SDL Trados Studio 2009.




Hi Richard, after three days of continuous Studio use I think I can safely report that this seems to have made my Multiterm-Studio connection considerably more reliable....

So far the error has not reappeared.

Thanks, again!


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio Error - Attempted to read or write protected memory

Advanced search







SDL Trados Studio 2017 only €415 / $495
Get the cheapest prices for SDL Trados Studio 2017 on ProZ.com

Join this translator’s group buy brought to you by ProZ.com and buy SDL Trados Studio 2017 Freelance for only €415 / $495 / £325 / ¥60,000 You will also receive FREE access to our getting started eLearning program!

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search