Supporting HTML files in Trados Studio
Thread poster: Pattranslations
Pattranslations  Identity Verified
France
Local time: 14:40
Sep 15, 2009

Hello,

I'm new to Trados Studio and when I followed a Webinar from SDL on the Studio version, I understood that the HTML tags were no longer visible in Studio, which is much better than viewing them all, like in Tag Editor.

Now here is my problem:
I created a project with 4 files to be translated, among which a file with an HTML extension. The point is that Studio considered there are only 3 files to be translated and that the HTML file is for reference only. I checked in the Help file for information and looked at Tools > Options settings regarding the HTML filter, but I could not find which settings could help me solve this issue.

Then, I tried to open the HTML file with MS Word, using the Unicode-UTF8 encoding, and I saved it as .htm. The point is that all HTML tags now show in this file, which can be added to the project and opened in Studio for translation.

But then, where is the advantage Studio is supposed to offer as to not showing the tags? I feel like I'm using Tag Editor to this extent...

Thanks in advance if you can help me with this.


Direct link Reply with quote
 

Carmen Moreton
Spain
Local time: 14:40
French to Spanish
+ ...
Try changing the status file Sep 16, 2009

In the File tab you will find your HTML file. Right click with your mouse and select the "Change file usage" (sorry if translation is not exact, my SDL Trados is in Spanish). Select translatable.
Right click again on the file name and select Batch tasks, then click in Prepare option.
You will get your translatable file at the end of the process.
Hope this helps!

CMG


Direct link Reply with quote
 
PMz
Please don't use Word Sep 16, 2009

Pattranslations wrote:

Hello,

I'm new to Trados Studio and when I followed a Webinar from SDL on the Studio version, I understood that the HTML tags were no longer visible in Studio, which is much better than viewing them all, like in Tag Editor.

Now here is my problem:
I created a project with 4 files to be translated, among which a file with an HTML extension. The point is that Studio considered there are only 3 files to be translated and that the HTML file is for reference only. I checked in the Help file for information and looked at Tools > Options settings regarding the HTML filter, but I could not find which settings could help me solve this issue.

Then, I tried to open the HTML file with MS Word, using the Unicode-UTF8 encoding, and I saved it as .htm. The point is that all HTML tags now show in this file, which can be added to the project and opened in Studio for translation.

But then, where is the advantage Studio is supposed to offer as to not showing the tags? I feel like I'm using Tag Editor to this extent...

Thanks in advance if you can help me with this.



Using Word to open the HTML files is bad practice - so please never do this (and please don't start off topic discussion how nice Word can handle HTML - at least not in SDL Trados related discussions ).
Anyway - can you open the problematic HTML in Notepad and check if the first line starts with the XML declaration (something like this):
?xml version="1.0" encoding="UTF-8"?

If yes, delete this line, save and try to open in Studio again.

Hope this helps

[Edited at 2009-09-17 07:20 GMT]

[Edited at 2009-09-17 07:20 GMT]

[Edited at 2009-09-17 07:20 GMT]

[Edited at 2009-09-17 07:20 GMT]


Direct link Reply with quote
 
Pattranslations  Identity Verified
France
Local time: 14:40
TOPIC STARTER
"Change file use" option grayed Sep 17, 2009

Carmen Moret�n wrote:

In the File tab you will find your HTML file. Right click with your mouse and select the "Change file usage" (sorry if translation is not exact, my SDL Trados is in Spanish). Select translatable.
Right click again on the file name and select Batch tasks, then click in Prepare option.
You will get your translatable file at the end of the process.
Hope this helps!

CMG


Hi Carmen,

Thanks for your answer. I tried your procedure but the "Change file use" option is grayed for the HTML file, as for all the other files I added to the project... I looked into the Tools > Options window for options that I could change, but did not find anything dealing with the translatable possibility for the file...
If you have any clue on this, I would appreciate

Thanks anyway for trying to help.


Direct link Reply with quote
 
Pattranslations  Identity Verified
France
Local time: 14:40
TOPIC STARTER
PMz's suggestion worked! Sep 17, 2009

Hello PMz,
Thank you for your suggestion about removing the xml info in Notepad. It worked!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Supporting HTML files in Trados Studio

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search