"Could not obtain lock" message with Translator's Workbench 8.3
Thread poster: Birgit Hofmann

Birgit Hofmann  Identity Verified
Germany
Local time: 07:16
English to German
Sep 17, 2009

When trying to save a TU, there frequently (but not always!) appears the message "Trying to obtain lock..." and a countdown in the Workbench Status Line. After the countdown has reached 0, the message "Could not obtain lock" is displayed.
In this case, I can only close but not save the current TU. It happens randomly, sometimes I can open the very same unit half an hour later and it works. Thanks for your help!
P.S. I'm working with SDL Trados 2007 and Word 2007, but the same happens when using Tag Editor.


 

Sandra Milosavljevic-Rothe  Identity Verified
Serbia
Local time: 07:16
German to Serbian
+ ...
The same problem Dec 25, 2010

I have the same problem with one of my TMs. Have you solved it in the meantime?

 

Walter Blaser  Identity Verified
Switzerland
Local time: 07:16
French to German
+ ...
Are you sharing acccess to the TM? Dec 25, 2010

Could it be that you are accessing the TM at the same time as another user? Or that you have two copies of Workbench open?

Close TE and Workbench, start up Workbench again and open your TM in exclusive mode and see f he problem comes up again.

Walter


 

Birgit Hofmann  Identity Verified
Germany
Local time: 07:16
English to German
TOPIC STARTER
Maybe a problem of "floating licences"? Jan 1, 2011

Walter Blaser wrote:

Could it be that you are accessing the TM at the same time as another user? Or that you have two copies of Workbench open?

Close TE and Workbench, start up Workbench again and open your TM in exclusive mode and see f he problem comes up again.

Walter


We are 3 translators and use an SDL "Team" version, which includes 5 floating licences. I use the TM software both in a network environment and, if I work at my home office, as a local (exclusive) copy (then the licence is transferred via VPN). Unfortunately, the problem occurs in both cases, and very randomly.

I suspect that this is a performance problem. If it occurs, I use "close segment" and open the next segment and enter the missing segments later by performing a clean-up step...So far, I haven't found another solution.


 

Birgit Hofmann  Identity Verified
Germany
Local time: 07:16
English to German
TOPIC STARTER
No solution yet Jan 1, 2011

Sandra Milosavljevic-Rothe wrote:

I have the same problem with one of my TMs. Have you solved it in the meantime?

Hello Sandra, unfortunately no - maybe Walter has another idea?


 

Tomás Cano Binder, BA, CT  Identity Verified
Spain
Local time: 07:16
Member (2005)
English to Spanish
+ ...
Corrupt indexes? Jan 1, 2011

If you are sure that you are the only person opening the memory, have you tried to reorganise the memories (File > Reorganise; memory must be open in exclusive mode)? I wonder whether some index in the memory could be corrupt after a long time with no reorganisation.

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"Could not obtain lock" message with Translator's Workbench 8.3

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
SDL Trados Studio 2019 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2019 has evolved to bring translators a brand new experience. Designed with user experience at its core, Studio 2019 transforms how new users get up and running, helps experienced users make the most of the powerful features, ensures new

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search