Filter TM by date
Thread poster: Emma Goldsmith

Emma Goldsmith  Identity Verified
Spain
Local time: 18:00
Member (2010)
Spanish to English
Dec 3, 2009

In Studio 2009, is it possible to filter a TM by date?

I've just realised that I've done a short piece of work using the wrong TM. (No wonder there were no matches!) I can update the one it should have been by importing my SDLXLIFF file into it, but I don't know how to get rid of the segments that have gone into the wrong TM by mistake.

Thanks in advance.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 18:00
Member (2010)
Spanish to English
TOPIC STARTER
Solution for: filter TM by date Dec 7, 2009

Paul Filkin at SDL very kindly provided me with the steps for carrying out this TM maintenance process for filtering a TM by date. I thought I would share it on the post here in case anyone else needs to know how to do it.

These are the instructions:

Create a backup first..!

1. Go to the TM maintenance view and create a filter to pick out the dates you added the units.
2. Add the Condition: Created on >= "2/12/09 15:00:00"
3. Save this new filter.
4. Now rightclick on your TM and select “Batch delete”
5. Select the new filter to delete all segments created on and after [date]
6. ”Finish”.

Be careful as the delete will apply without a chance to be sure once you select “Finish”, so this is why you should work with a backup.


So thanks Paul for the help!


Direct link Reply with quote
 

Jeff Slenker  Identity Verified
Local time: 11:00
Member (2005)
Japanese to English
Simple Question - Filters Jan 3, 2013

I want to add a filter in order to delete some translation units that were created on a certain date. I am on the TM tab and select "Add Filter". Nothing happens. No options for adding the filter... nothing. Any ideas?

Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 18:00
Member (2010)
Spanish to English
TOPIC STARTER
How to use filters in Studio TMs Jan 3, 2013

genkijeff wrote:

I am on the TM tab and select "Add Filter". Nothing happens. No options for adding the filter... nothing. Any ideas?


***First, make a copy of your TM.***
Then, try following the instructions for adding a filter in this blog article that I wrote a couple of months ago:
http://signsandsymptomsoftranslation.com/2012/10/23/ecdc/
Go to the section on "Field values in Studio TMs"

I think you're just not clicking on the "Add" button after "Add filter", but if it's not as simple as that, the step-by-step instructions are in the blog article.

HTH,
Emma


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Filter TM by date

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search