TMX export and import roundtrip in Trados 2007 won't work
Thread poster: Samuel Murray

Samuel Murray  Identity Verified
Netherlands
Local time: 10:43
Member (2006)
English to Afrikaans
+ ...
Dec 4, 2009

G'day everyone

I'm trying to figure out how to import a TMX file into Trados 2007. What I did was to take an existing Trados TM, then export it to TMX, then create a new Trados TM, and import the TMX. Trados says all of the TUs in the TMX are invalid. I have made no changes to the TMX between exporting it and trying to import it (I haven't even opened it in another program such as a text editor).

When I export the TMX, Workbench gives me this message: "Export finished successfully. 620 of 620 TUs exported."

Here's the message that Workbench gives me after importing: "Import finished successfully. 620 TUs read in 0 seconds: 0 updated, 0 added, 620 invalid."

The language codes are EN-GB for source and EN-ZA for target. I've checked and the old and new Trados TMs both have these language codes.

I've tried it with TMX 1.4 and with TMX 1.4b. I've tried the "small" and the "big" import options. I've tried setting conflicts to "Merge" and "Overwrite" (although this shouldn't matter because the new Trados TM is empty before I start importing the TMX).

Does anyone have any idea what might be wrong here? What am I missing? Surely Trados should be able to import a TMX file that it itself had exported not 30 seconds previously.

Thanks
Samuel

==

Added: I also tried opening the TMX in a Unicode-aware text editor and change the user-ID of each TU to something else, in case it conflicts with my Workbench installation's user-ID, but that doesn't help either. I always get the same error message from Workbench that the TUs are all invalid.

==

Added: I've discovered that I can export to Trados TXT (WB 8.0 version) and import it again, so I've decided to use TXT instead of TMX as my interchange format. But I still don't know why Trados won't import its own TMX file.



[Edited at 2009-12-04 11:09 GMT]


Direct link Reply with quote
 

Marinus Vesseur  Identity Verified
Canada
Local time: 01:43
English to Dutch
+ ...
Search and Replace the language settings Dec 4, 2009

Hi Samuel

The language settings are usually the issue. You may have to edit the TMX file and through Search and Replace replace the (EN-GB) with (EN-ZA). Could well be that there is a setting that forces Workbench to swallow a different sub-language, but I don't know where it is, so S&R method may be the easiest. Good luck!

Just read your post again and noticed you had already checked the language settings. If you first make backup copies of the TMs (always a good idea: I've lost several TMs whilst importing) you can then experiment with the Merge, Overwrite, etc settings.

[Edited at 2009-12-04 08:34 GMT]


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 10:43
Member (2006)
English to Afrikaans
+ ...
TOPIC STARTER
But can I change the TM's languages later? Dec 4, 2009

Marinus Vesseur wrote:
The language settings are usually the issue. You may have to edit the TMX file and through Search and Replace replace the (EN-GB) with (EN-ZA). Could well be that there is a setting that forces Workbench to swallow a different sub-language, but I don't know where it is, so S&R method may be the easiest. Good luck!


The client wants me to deliver a TM with the language codes EN-GB for source and EN-ZA for target. Can I create a TM with other language codes, and then later (in Workbench) change all the TUs' language codes to something else?


Direct link Reply with quote
 

Marinus Vesseur  Identity Verified
Canada
Local time: 01:43
English to Dutch
+ ...
You can edit the TMX files later.. Dec 4, 2009

..and simply 'correct' the language settings according to the client's wishes. That usually works fine. There isn't an awful lot of information in the segments and it's relatively easy to see what's what. Just fiddle around a little and test it that way.

Regards, Marinus



Samuel Murray wrote:

Marinus Vesseur wrote:
The language settings are usually the issue. You may have to edit the TMX file and through Search and Replace replace the (EN-GB) with (EN-ZA). Could well be that there is a setting that forces Workbench to swallow a different sub-language, but I don't know where it is, so S&R method may be the easiest. Good luck!


The client wants me to deliver a TM with the language codes EN-GB for source and EN-ZA for target. Can I create a TM with other language codes, and then later (in Workbench) change all the TUs' language codes to something else?


Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 10:43
Member (2006)
English to Afrikaans
+ ...
TOPIC STARTER
Editing the TMX isn't useful Dec 4, 2009

Marinus Vesseur wrote:
You can edit the TMX files later ... and simply 'correct' the language settings according to the client's wishes.


We seem to be missing each other here.

My Trados TM is source=EN-GB and target=EN-ZA. If I export this thing to TMX, and change the language codes, then I have to change the language codes back before I import it, surely?

Editing the TMX files to change the language codes will not change the language codes of the Trados TM. I need to deliver a Trados TM to the client, not a TMX file.

So my question in the previous post (as a reply to your previous post) is whether I can take a Trados TM with source=AB-CD and target=EF-GH and change the language codes to source=EN-GB and target=EN-ZA later? Obviously this change has to be done in Trados, because you can't edit a Trados TM in a text editor.


Direct link Reply with quote
 

Luisa Ramos, CT  Identity Verified
United States
Local time: 04:43
Member (2004)
English to Spanish
Is sublanguage making the Synergy package import fail? Apr 7, 2010

I work out of two locations. I have two TRADOS licenses.

Yesterday, I received a Synergy package. The TM languages are Source: EN-US, Target: ES-US. The package import at location 1 fails. The version of TRADOS Feelance Suite 2007 there does not have that ES-US (Spanish United States) sublanguage.

I asked the PM to send me the individual files and to export the TM to a txt, which I then tried to import into a new TM but got the message "TUs invalid".

At location 2, however, I was able to import the package, and translate, so I figure that the import problem at location 1 is caused by that location's version missing the appropriate sublanguage.

Although not exactly the same problem, you wanted to change sublanguages. I figured that is something I should try to see whether I can work at both locations. Did you manage to solve your problem and do you think a similar remedy could work for me?

Lastly, I hate Synergy.


Direct link Reply with quote
 

FarkasAndras
Local time: 10:43
English to Hungarian
+ ...
Try editing the language codes Apr 7, 2010

Samuel Murray wrote:

Marinus Vesseur wrote:
You can edit the TMX files later ... and simply 'correct' the language settings according to the client's wishes.


We seem to be missing each other here.

My Trados TM is source=EN-GB and target=EN-ZA. If I export this thing to TMX, and change the language codes, then I have to change the language codes back before I import it, surely?

Editing the TMX files to change the language codes will not change the language codes of the Trados TM. I need to deliver a Trados TM to the client, not a TMX file.

So my question in the previous post (as a reply to your previous post) is whether I can take a Trados TM with source=AB-CD and target=EF-GH and change the language codes to source=EN-GB and target=EN-ZA later? Obviously this change has to be done in Trados, because you can't edit a Trados TM in a text editor.


Even if it's not a proper solution, or not the one you were looking for, it could help diagnose the problem. It seems possible to me that Trados in confused by the two EN languages, so just change one EN-ZA to FR-FR to see if the TMX will import properly that way.
BTW I vaguely recall some setting regarding sublanguages in TWB... perhaps you need to apply a different setting when you create the blank TM for the import to work.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TMX export and import roundtrip in Trados 2007 won't work

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search