Pages in topic:   [1 2] >
Client on Trados 2007 and translator on Studio 2009 : compatibility ?
Thread poster: Catherine Boissée

Catherine Boissée  Identity Verified
France
Local time: 00:04
Member (2009)
English to French
+ ...
Dec 16, 2009

Dear colleagues,

I'm a "newbie in Trados", I recently purchased Trados 2009 Freelance and I've been working with it quite easily so far.

My current client is working on Trados 2007, so I upgraded the provided TM and went through the job with success. At the end of the job, in order to deliver a TTX file as required, I saved the target file as a Tradostag document (shift +F12) and delivered it to my client.

My client first told me that the format was Ok, but it seems that some translation units can not be opened and that it is impossible to update the TM.

Can you tell me what's wrong ? Is this "incompatibility" real or did I miss something ? Is there a possibility to avoid this ?

My client advises me to work with Trados 2007, but it seems so complicated to me (I'm afraid of these numerous applications Workbench, Tageditor, Winalign, ...). If someone could help me !!!

Thank you in advance,

Catherine


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:04
Member (2003)
Polish to German
+ ...
Provided you do not have to deliver Word bilingual files Dec 16, 2009

you will have no problems when cooperating with a customer with Trados 2007.
Usualy they will not even notice that you work with Studio.
This is at least my case, since the first Beta release early in April this year. Only the first very early Beta had some problems with that, but I never heard from my customer about any problems since.


Direct link Reply with quote
 

Catherine Boissée  Identity Verified
France
Local time: 00:04
Member (2009)
English to French
+ ...
TOPIC STARTER
@ Jerzy : Is there anything else to do that I missed ? Dec 16, 2009

Is the process I used and mentionned above correct and complete ?

thank you...

Catherine


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:04
Member (2003)
Polish to German
+ ...
You did everything right Dec 16, 2009

And I do not know why they can't use certain segments.
Maybe if you tell me what was the source format for the ttx file we will find more out?

In order to be sure everything goes like with Trados 2007 please do the following:
when you receive the TTX from the customer create an empty TM in Workbench (Trados 2007). It of course has to have the proper language pair.
Now in Workbench go to tools, chose "Translate", mark the "Segment unknown sentences" checkbox, add the ttx file(s) from the customer and translate them. Of course there will be nothing translated, as the TM is empty. But the segmentation will be exactly as it would be with T2007.
Now open the ttx file(s) in Studio (or create a project for them).
The TTX will be semi-pretranslated and you will see the source text also on the right side in Studio, where you usualy have empty spaces for translation. You can easily delete those texts - in Studio go to Translation and chose Delete draft segments (or similar, I work with German GUI).
This way everything should really work.
Otherwise let your customer describe the problem more precisely and let me take a look on the file.


Direct link Reply with quote
 

ViktoriaG  Identity Verified
Canada
Local time: 18:04
English to French
+ ...
This is exactly why I am not using Studio yet Dec 16, 2009

None of my clients use Studio 2009 - they are mostly using 2007 or even older versions. Since Studio is not backward compatible with 2007, I am very reluctant in using it. Funny thing is, translators seem to be very eager to use Studio whereas agencies don't seem overly enthusiastic about it.

I think that in your case, it is best to advise your clients that you are using Studio and that you cannot deliver backward compatible files for the time being. A good method to work for the moment would be to agree on delivering target files only and asking the client to align the source and target files using WinAlign if they really need that translation memory. In a sense, your part of the contract is to produce the translation and not to provide the memory. The agency can easily extract the memory through alignment. If the agency feels you are a useful translator to them, I don't think they would mind compensating for this.

However, I also recommend you learn to use Trados 2007 in the mean time. I know it seems intimidating, but that is only a first impression. Basically, Workbench and TagEditor together are the equivalent of the Studio interface. It is worth it, because I don't expect agencies to switch over to Studio so soon. It may take years before they adopt it, so it can't hurt to be competent in the use of the 2007 suite.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:04
Member (2003)
Polish to German
+ ...
@Victoria: this is not true Dec 16, 2009

I am using Studio on various TTX files coming from variuos customers with no problem at all. The only incompatibility I have is not to be able to deliver bilingual Word files, but this does not bother me much, TBH.
For all other purposes Studio is as good as Trados 2007. If files are prepared with T2007 as TTX, I can translate them with Studio.
And I am not just writing this to do SDL a favour, but this is how I do work since several months. I did not productive touch T2007 since summer this year, for sure. If I used T2007, then to prepare files or just vor some very very small tasks.
There is only one big exception: as I use T-Window for Clipboard on one project, I have to use T2007 for this. But this is a very special project.


Direct link Reply with quote
 

Gillian Searl  Identity Verified
United Kingdom
Local time: 23:04
Member (2004)
German to English
I'm doing the same - create a TTX and work in Studio - create TTX Dec 17, 2009

I have had some people complain the update doesn't work. One reduced my invoice because they said they had to a lot of work on their side. But they didn't provide a full explanation so I can't completely follow what was wrong. I'd like to know if anyone has real proof that this sometimes doesn't work.
Gillian


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:04
Member (2003)
Polish to German
+ ...
In case it should not work Dec 17, 2009

you still can export the TM, import it in Trados Workbench and reprocess the files.
But I really would be glad to have some proven complaints. As for now I do not have a single one.
When I started to use the first Beta of Studio, we had an xml-job and this was indeed not working. But now I have again had xml and html jobs, and all worked as it should.
InDesign worked too, so what is NOT working?
And before someone reduces my price I simply reprocess the data.


Direct link Reply with quote
 

Catherine Boissée  Identity Verified
France
Local time: 00:04
Member (2009)
English to French
+ ...
TOPIC STARTER
I wonder if it isn't a segmentation problem... Dec 17, 2009

After questionning my client, it seems that some segments in the delivered document contain "several TU", but I checked my sdlxliff document and these "TU" appear in the same segment too.

My conclusion (please tell me if I'm wrong, once again I'm a newbie) is that :

* either the TTX document from my client has a "wrong" segmentation
* or the settings for the (default) segmentation rules in my application are not convenient, are wrong...


If so, what can I do now to change it and set a rule that create a new segment after each break (it is not the case) ?


Thank you again for your precious help !!!

Catherine


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 00:04
English
TTX Compatibility Mode Dec 17, 2009

Hi,

Before getting into these types of complications it may be worth making sure you have the ttx compatability mode set to disable smart pairing. You can find this under the FileTypes in Tool-Options for TRADOStag and then under Compatibility.

By disabling this option you will ensure that the ttx retains the same opening and closing tags that Workbench would apply and Studio will not try to add missing tags as a matter of course.

Try opening a ttx afresh with this setting, translate, and then save back as ttx and see whether this improves the situation. If not, then we would be happy to look at this particulart file in more detail.

Regards

Paul


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:04
Member (2003)
Polish to German
+ ...
Use presegmentation in Trados 2007 Dec 17, 2009

Beside the tipp by Paul, which is indeed very important, however Studio has this setting correct by default, you can presegment the TTX via the "Translate" function in Workbench (as described above) to keep the segmentation exactly as it was in T2007.
When upgrading TM you can also import the segmentation rules from T2007 in T2009. To do so, before you click "Finish" to upgrade the TM, go to the tab "Language ressources" and chose "Updated language ressources" (the name might be slightly different, I can't check at the moment) instead of the default option.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 00:04
English
Better advice from Jerzy Dec 17, 2009

Thanks Jerzy, on rereading the original post I think your advioce here is probably closer to the problem being experienced.

You are also close enough to what it says ... "Upgraded Language Resources"

Thanks

Paul


Direct link Reply with quote
 

Gillian Searl  Identity Verified
United Kingdom
Local time: 23:04
Member (2004)
German to English
Run that by me again Dec 17, 2009

I normally get a Word file from a customer. They say "deliver unclean" so I open and save as TTX. Close TagEditor. Open Studio and translate there. When I am done I create the target TTX and deliver. I have noticed the multiple segments in the TTX file but never worried about it.
Can you give me the steps I need to take to ensure the TTX is fully compatible. Thanks
Gillian


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 00:04
Member (2010)
Spanish to English
pre-segmenting in Workbench Dec 17, 2009

Hi Jerzy,
I was interested to read your recommendation for pre-segmenting to ensure compatibility.
I thought that by opening a doc in Tag Editor and saving it as a ttx I was already segmenting it, and that later when I open it in Studio no new segmenting would be done.
So that's not the case?

One other question. When I tried your recommendation this afternoon (pre-segmenting in Workbench using "translate"), and then opened the ttx in Studio using "open document" (not project), Studio skipped the window where I get to choose the TM I want. So then I had to go to project settings > TM > and change the TM to the one I wanted to use.
Why don't I get the chance to choose my TM any more?

So your tip to avoid problems with compatibility now involves extra clicking through Workbench, and extra clicking through Studio (to get the right TM), not to mention the issue of having to open Tag Editor in the first place to create my TTX.

Why oh why can't we just create a ttx in Studio for all our clients who have not yet updated to Studio....
http://ideas.sdltrados.com/ideas/detail.asp?i=2243


Direct link Reply with quote
 

Ralf Lemster  Identity Verified
Germany
Local time: 00:04
English to German
+ ...
TM selection - change your own setting Dec 18, 2009

Hi Emma,

One other question. When I tried your recommendation this afternoon (pre-segmenting in Workbench using "translate"), and then opened the ttx in Studio using "open document" (not project), Studio skipped the window where I get to choose the TM I want. So then I had to go to project settings > TM > and change the TM to the one I wanted to use.
Why don't I get the chance to choose my TM any more?

Looks like you may have checked the option "No longer show this dialogue box if the language pair settings are known for this document" on the "Open document" window. (Note that I'm using the German GUI, so the wording might differ slightly.)

No idea right now where to reset this, I'm afraid.

Best regards,
Ralf


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Client on Trados 2007 and translator on Studio 2009 : compatibility ?

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search