SmartHeap Library MEM_BAD_POINTER
Thread poster: David Evans
David Evans  Identity Verified
Spain
Local time: 01:48
Catalan to English
+ ...
Dec 22, 2009

I run Trados 6.5 freelance and Windows XP. For a few days now every time I open Trados (I'm only using Workbench) I get a message saying MEM_BAD_POINTER, which is a SmartHeap Library problem. If I click on 'Cancel' I get the message: Microsoft Visual C++ Runtime Error. If I click on 'Accept' the programme opens and seems to run normally (it cleans files OK etc.). I have seen references to this problem from a few years back but they don't help me. The oriental languages box in regional settings is unticked and always has been. I haven't installed or reinstalled any programmes. Any suggestions? Thanks in advance.

David Evans


Direct link Reply with quote
 

Michael Moskowitz  Identity Verified
Local time: 19:48
Member (2004)
Russian to English
+ ...
Same symptom Jan 11, 2010

I am seeing exactly the same think on the same version of Trados. Have you or anyone come up with an explanation/resolution?

Direct link Reply with quote
 
David Evans  Identity Verified
Spain
Local time: 01:48
Catalan to English
+ ...
TOPIC STARTER
nothing yet... Jan 11, 2010

Hello Michael,

I haven't received any suggestions yet. I haven't had time to investigate myself either but I have carried on working normally since my post. Despite getting the message every time I open Trados it hasn't affected the functioning of the programme, although I can't help thinking that it will at some point...

I will let you know if I find a solution myself.

David


Direct link Reply with quote
 

Alexandra Speirs  Identity Verified
Local time: 01:48
Italian to English
+ ...
any solution yet? Jul 2, 2010

did anyone find a solution yet?
I just got this today when I tried to clean up a file.

Same version of Trados too.


Direct link Reply with quote
 
David Evans  Identity Verified
Spain
Local time: 01:48
Catalan to English
+ ...
TOPIC STARTER
No solution Jul 2, 2010

No, no solution. As you can see I've had this problem since last December. It doesn't seem to affect the programme once you click on accept but it is annoying.

Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 01:48
French to Polish
+ ...
Win XP SP2 Jul 2, 2010

David Evans wrote:

No, no solution. As you can see I've had this problem since last December. It doesn't seem to affect the programme once you click on accept but it is annoying.


This is a problem related to the MicroQuill SmartHeap libraries which became somehow incompatible with Win XP after SP2, especially with Asian fonts are installed.
In theory, it should have been fixed by SP3 but strange things may happen.

The problem doesn't occur in newer Trados versions, AFAIK although I suppose in some cases it may occur when Multiterm 5 is used.

In fact, it's just an annoyance.
The solution is upgrade or downgrade, as you like

Cheers
GG


Direct link Reply with quote
 
Daniel García
English to Spanish
+ ...
Are you using Windows XP SP3 or SP2? Jul 4, 2010

Hi, David,

Maybe you have tried this but, as you don't mention it, I will just put it here:

http://support.microsoft.com/default.aspx?scid=kb;en-us;910466

It is a patch from Microsoft which should address this problem.

Which version of Windows are you using? Windows XP SP2 or SP3?

Daniel


Direct link Reply with quote
 
David Evans  Identity Verified
Spain
Local time: 01:48
Catalan to English
+ ...
TOPIC STARTER
not sure about this patch Jul 5, 2010

Thanks Daniel,

I have seen this patch but it says the following:

"This problem occurs if the Install files for East Asian languages check box is selected in the Regional and Language Options Control Panel item."

"Apply this hotfix only to systems that are experiencing this specific problem."

I have never had the East Asian languages check box selected so I don't want to risk installing the patch.

When the problem started I was using XP SP2 but I have recently installed SP3 because I think that from July 13 SP2 is no longer supported. The problem persists.

Because it doesn't seem to affect Trados I don't want to get into reinstalling programmes or restoring the system.

David


Direct link Reply with quote
 

Anneken
Local time: 01:48
French to Dutch
+ ...
Same problem Nov 5, 2012

Dear all,

I have exactly the same problem since this morning, although SP3 has been installed and neither of the Asian languages boxes were ticked. The only difference is that in my case, Trados does not want to start at all, so I have a BIG problem...
Has anyone found a solution for this in the meantime?
Thank you for your response!
Kind regards,

Ann


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SmartHeap Library MEM_BAD_POINTER

Advanced search







Across v6.3
Translation Toolkit and Sales Potential under One Roof

Apart from features that enable you to translate more efficiently, the new Across Translator Edition v6.3 comprises your crossMarket membership. The new online network for Across users assists you in exploring new sales potential and generating revenue.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search