Term recognition in Trados Studio 09
Thread poster: Swedish Fish
Swedish Fish
Local time: 03:57
English to Swedish
+ ...
Dec 29, 2009

Hello all!

I'm just getting started in Trados Studio and need some help. In Déjà Vu, when you have created a new term base and start adding new word pairs you will immediately start getting suggestions on terms as they re-appear in the text. I have started a term base and added a number of word pairs, but no suggestions pop upp when a word appears later on in the text. Am I doing something wrong?

Thanks in advance!


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 03:57
Member (2003)
Polish to German
+ ...
Check your view settings Dec 29, 2009

In Studio the term appears in term recognition immediately after inserting it into the termbase. You can see it in the term recognition window and it is also marked as a recognized term by a red line above it in your translation memory view of current segment.
If the red lines appear, you however still do not see any terms, most probably you simply switched to the termbase search view window instead of terminology recognition window.
Provided your window layout of Studio is near to the default one, check which tab is clicked in the termrecognition window in the right above corner of Studio screen. The "Terminology recognition" tab should be active, as otherwise you will not see any recognized term (but the term recognition still does work).


Direct link Reply with quote
 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 05:57
Member (2006)
English to Turkish
+ ...
Reorganisation Dec 29, 2009

You may need to reorganise the termbase in MultiTerm.
Also check the indexes in Studio. Actually there are many settings in Studio related to Term Recognition.

If it doesn't work, you may try DVX build 316.


Direct link Reply with quote
 

Jean-Pierre Artigau
Canada
Local time: 21:57
English to French
+ ...
Open termbase Dec 29, 2009

You should also make sure your term base is open. In the Term Recognition window (not Term Search! In the upper right corner of your screen), click on the icon that looks like a pile of coins (Project Termbase Setting), this opens the Project Settings window. Under Language Pairs, All Language pairs click Termbases. This shows you your Term Bases (you may have several). Check the ones you want to open.

Direct link Reply with quote
 
Swedish Fish
Local time: 03:57
English to Swedish
+ ...
TOPIC STARTER
The answer was only too obvious! Dec 30, 2009

Thanks everyone! I had made the very silly mistake of not clicking on the "save" icon when I added word pairs to the term base... It works perfectly now...

Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 03:57
English to German
+ ...
Term Recognition issue ... Feb 4, 2010

I have this strange variation of the term recognition problem:

In my case Studio only recognizes terms I enter (“on the fly”) from within the project I work with.

What I have done is this: I have migrated SDLX TMs and TBs (Suite 2007) into Sudio 2009 and Multiterm 2009. All the Multiterm Termbases are fine, all terms have imported, all indexes are correct. The languages and sublanguages in the project and the indexes are identical; there are no visible differences in the entry structure between legacy terms and the ones I enter in Studio.
I then tried other import formats such as Excel or Tab Delimited, same effect! Can’t get term recognition to “see” imported terms even though they immediately show up if I switch to the term bank search window and search for them there.

Any suggestions?

Susanne

[Bearbeitet am 2010-02-04 17:35 GMT]

[Bearbeitet am 2010-02-04 18:16 GMT]


Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 03:57
English to German
+ ...
Further tests Feb 5, 2010

I spent some time yesterday evening experimenting with Multiterm to find a solution to this problem. So far I have not found one. Here are my findings though. Can anyone from SDL on this forum please comment:

1) Term Recognition in Studio DOES WORK in these scenarios:
A) If I open a legacy Multiterm 2007 (.mdb) termbase. However, If I understand the process correctly, these will always remain .mdb and cannot be directly converted to .sdltb.
B) If I create a new Multiterm 2009 termbase and input terms from either within Mutiterm or from the Editor in Studio.

2) Term Recognition in Studio DOES NOT WORK for any legacy material IMPORTED by first converting them in Mutiterm Convert to XML. So, any terms I add in Multiterm or Studio will show up in term recognition, any terms imported into Multiterm will not. In the extremely simple bilingual glossaries I tested I cannot see any difference between the two types of entries.

I also tried the mixed scenario, i.e. creating a new termbase, entering terms manually in Multiterm (which do show up in term recognition) and then importing a list via Convert. Again, only those terms I entered manually show up.

Let me add, that the actual import process of all my legacy termbases (mainly SDLX) worked perfectly and all terms where imported and do show up in Multiterm, ONLY I cannot get term recognition to find them....

So my question is: is there some kind of flag created in Multiterm Convert that sort of filters out imported terms so that they don’t show in term recognition?

Also, why could SDL not have found a simpler, direct solution for importing lists of terms (Excel, CSV) into Multiterm (as in SDLX and DejVu etc.) rather than having to go through Multiterm Convert?

BTW, I tried suggestions made in a previous thread (http://deu.proz.com/forum/sdl_trados_support/136987-studio_2009_term_recognition_not_working-page2.html)
and I also did a complete reinstallation (as per SDL FAQ article 2724, except that I have a brand new computer and that this is the first SDL version installed on this computer, so no old program traces in the registry etc.) - but I think this is only for cases where term recognition does not work at all.

Just for the record, my installation is: Windows 7, Studio 2009 SP1, with patches KB2913-03 and KB3016 applied.

Susanne


Direct link Reply with quote
 

Susanne Rieg  Identity Verified
Local time: 03:57
English to German
+ ...
Workaround solution found Feb 5, 2010

Here is the solution found after a lot of tinkering. I remember having read that an SDL support person had suggested something on those lines to someone else on this forum:


What seem to happen is, that the indexes Mutiterm 2009 generates for IMPORT data are empty and Studio cannot handle them. I deleted all .mdf and .mtf files and opened the Termbases in Studio. Studio then automatically regenerated the correct indexes. Don’t try doing this in Multiterm, though, it will generate a cryptic exception.

Also, the indexes for the Multiterm legacy (2007) termbases must be generated in Studio. Indexed generated by Multiterm may or may not work, I had both cases. Plus, I had indexes that worked in Studio yesterday and no longer worked today, so I had to regenerate them in Studio by deleting all .mdf and .mtf files.

Susanne

[Bearbeitet am 2010-02-05 19:26 GMT]


Direct link Reply with quote
 
kimjasper  Identity Verified
Denmark
Local time: 03:57
Member (2006)
English to Danish
+ ...
Run LaunchStudio.bat as administrator May 5, 2010

LaunchStudio.bat did not work for me either when just clicking on it but if I right-click on the file and select "Run as administrator" it does indeed work. If you have user account administration switched on (which is common), then you are probably not authorized to update the registry correctly, unless you select the run as administrator option.

Direct link Reply with quote
 

Tejinder Soodan  Identity Verified
India
Local time: 08:27
Member (2006)
English to Panjabi
+ ...
It worked Jun 5, 2010

Susanne Rieg wrote:

Here is the solution found after a lot of tinkering. I remember having read that an SDL support person had suggested something on those lines to someone else on this forum:


What seem to happen is, that the indexes Mutiterm 2009 generates for IMPORT data are empty and Studio cannot handle them. I deleted all .mdf and .mtf files and opened the Termbases in Studio. Studio then automatically regenerated the correct indexes. Don’t try doing this in Multiterm, though, it will generate a cryptic exception.

Also, the indexes for the Multiterm legacy (2007) termbases must be generated in Studio. Indexed generated by Multiterm may or may not work, I had both cases. Plus, I had indexes that worked in Studio yesterday and no longer worked today, so I had to regenerate them in Studio by deleting all .mdf and .mtf files.

Susanne

[Bearbeitet am 2010-02-05 19:26 GMT]


Thanks Susanne,

I was having the same problem for a long time. Term recognition was able to find terms added from within the studio but it was not showing the terms imported from an xml file.

After deleting the .mdf and .mtf files, and reopening the Termbase in Studio, term recognition is working perfectly.

Tejinder


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Term recognition in Trados Studio 09

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search