Error - Attempted to read or write protected momory
Thread poster: Gene Oh

Gene Oh  Identity Verified
New Zealand
Local time: 02:46
Member (2008)
English to Korean
Jan 13, 2010

I am using SDL Studio 2009 SP1. In Editor view, I am using AutoSuggest (as well as ternbase) functionality. When I begin typing a certain word in the translation segment, the suggestions available are displayed. I double-click the suggestion. The suggestion is inserted into the current segment. Then, the problem arises. Whenever I start typing the next translation character, it always displays an error: "Attempted to read or write protected memory". Anybody can help me with this problem?

Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 14:46
English to Dutch
+ ...
Tab or Enter Jan 13, 2010

Gene Oh wrote:
I double-click the suggestion.

What if you simply used Tab or Enter? Everybody else does, I imagine.

What if -imagining further- double clicking an item in a dropdown list gives your computer the idea that it should open that item (or its 'parent', the AutoSuggest dictionary or termbase) so that, when you type the following character, it consequently believes you are trying to add that character to the dictionary or termbase, which is Forbidden? What can it do then but display an error message reading "Attempted to read or write protected memory"?

It all seems perfectly human to me.


Direct link Reply with quote
 

Gene Oh  Identity Verified
New Zealand
Local time: 02:46
Member (2008)
English to Korean
TOPIC STARTER
What if you simply used Tab or Enter? Jan 13, 2010

Many thanks for your answer.
Based on your advice, I did use Tab or Enter, but with no joy. The same error happens. Interesting is that when I type the following character in English, it does not show the same error message. Has it to do with Korean characters I am typing in the translation segment?


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 14:46
English to Dutch
+ ...
grief Jan 13, 2010

Gene Oh wrote:
no joy

Totally nonplussed: in the help it does indeed say double-click the suggestion, and this is utterly ridiculous…

I use Enter.

But for now, while you may be sitting outside in the blazing summer morning and I'm about to call it a day: you did add/activate the AS license, did you? It would have been nice if you hadn't. Problem would possibly have been solved.

As far as translating single byte into double is concerned: I'm even more clueless there.

Tomorrow and time allowing I'll have another look at where Tab and Enter exactly come in. Clicking is a subhuman practice to which no one should be reduced; double clicking is twice that.


Direct link Reply with quote
 

Gene Oh  Identity Verified
New Zealand
Local time: 02:46
Member (2008)
English to Korean
TOPIC STARTER
Totally nonplussed Jan 13, 2010

You are a nice person. Though I do not know how to solve my problem, I am glad to know that we have a wonderful person like you in this world who is willing to help somebody with a problem. I think I will have to give up using AutoSuggest functionality in Korean. Anyhow, many thanks for your replies. The weather here is simply gorgeous. It is in the middle of beautiful summer. Should you visit New Zealand, please come after Christmas, perhaps in January, when the weather is truly beautiful. I have translated www.newzealand.com. Please visit the site and you will have many beautiful photos.

Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 14:46
English
A little more information Jan 14, 2010

Gene Oh wrote:

I am using SDL Studio 2009 SP1. In Editor view, I am using AutoSuggest (as well as ternbase) functionality. When I begin typing a certain word in the translation segment, the suggestions available are displayed. I double-click the suggestion. The suggestion is inserted into the current segment. Then, the problem arises. Whenever I start typing the next translation character, it always displays an error: "Attempted to read or write protected memory". Anybody can help me with this problem?


Hi Gene Oh et al,

The error message indicates that some external legacy (C++) component is called and causes the error (i.e. it's not AutoSuggest, as that's native .Net). Does the same still happen if you disable the spell checker and/or the termbase?

This type of error was common prior to SP1 and we thought we had resolved this but it looks as though we may need to take another look. I would be interested to see if anyone else is still experiencing this, but in the meantime let me know if this occurs when you disable the spellchecker and/or the termbase and I can arrange for you to be contacted by a support engineer to collect more information and see whether we can find a resolution.

Regards

Paul


Direct link Reply with quote
 

Gene Oh  Identity Verified
New Zealand
Local time: 02:46
Member (2008)
English to Korean
TOPIC STARTER
A little more information Jan 14, 2010

Many, many thanks for your kind response, Paul. I appreciate your pro-active attitude.

I disabled both Termbase (ie: termbase not added) and Spell checker (ie: ToolsOptions - Editor-Spelling- all options unselected) functionalities as per your instruction. Then I tried to use Autosuggest functionality selecting only AutoSuggest providers (ie: I have unchecked Termbases and Auto text and selected only AutoSuggest dictionaries). But I have the same error message on my two computers, the specs of which are as follows.

1) Desktop PC (OS: Vista Home Premium English Version, Software: MSOffice 2007, Input language system on Regional & Language Option: MS Office IME2007) and,
2) Netbook PC (OS: Windows XP English Version, Software: MSOffice 2003, Input language system: Korean Input System IME2002)


Direct link Reply with quote
 

Gene Oh  Identity Verified
New Zealand
Local time: 02:46
Member (2008)
English to Korean
TOPIC STARTER
I found the solution Feb 1, 2010

Copy the source text into the target segment first, then overwrite your translation.
Then AutoSuggest works beautifully without showing the error mentioned.

[Edited at 2010-02-01 22:31 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Error - Attempted to read or write protected momory

Advanced search







TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »
PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search