SDL Trados 2007 filter: non-translatable styles for Word 2007
Thread poster: AndreaMeier
Jan 15, 2010

Hello,

in Trados 2007 SP2, the filter settings offer the possibility to enter non-translatable styles for Word 2000-2003, however this is not possible for Word 2007.

We want to translate a Word 2007 document in the TagEditor and have some self-defined styles that are not to be translated, how do I exclude them from translation in the TagEditor?

Thanks in advance for your help!

Andrea


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 03:25
Member (2003)
Polish to German
+ ...
The easiest way: Jan 15, 2010

Make the styles so, that the text is formatted as "hidden".
Then it will be excluded from translation in Tageditor without any additional actions necessary.

Ups, that will not work for Word 2007 - but if you could save this document as Word 2003, then it will work.

[Edited at 2010-01-15 11:55 GMT]


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 03:25
English to Dutch
+ ...
always some other Jan 15, 2010

or even slightly easier way:
enter the style(s) in TWB (863)/ File / Setup / Non-translatable Text.

Strangely, in the Filter settings you'll find both the TwinExternal and TwinInternal styles; it's only here that you'll find the DO_NOT_TRANSLATE style.

Edited to add:

If your style is named e.g. CustomStyle you may need* to enter
in CustomStyle

*looking at the actual dialog; by analogy




[Edited at 2010-01-15 12:50 GMT]


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 03:25
Member (2003)
Polish to German
+ ...
This work just for *character* styles Jan 15, 2010

but from my experience will *not* work for paragraph styles.
That is why I use the method with hiding text.
You can hide any text with any formatting - then it will not be translatable in Tageditor, but the complete formatting is not being lost.
If you use styles (tw4win.internal for example) you have to recreate the formatting of the original document afterwards. With hiding text you just unhide it and you're done.


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 03:25
English to Dutch
+ ...
fine but Jan 15, 2010

Jerzy Czopik wrote:
... but from my experience will *not* work for paragraph styles.

I'm not trying to outshine you, Jerzy, but both TwinExternal as TwinInternal (as I call them, affectionately) are character styles - not paragraph styles - just have a look.


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 03:25
English to Dutch
+ ...
no changes Jan 15, 2010

Jerzy Czopik wrote:
... you have to recreate the formatting of the original document afterwards. With hiding text you just unhide it and you're done.

By my suggestion no formatting whatsoever is being altered nor even hidden.


Direct link Reply with quote
 
PMz
Use Studio 2009 Jan 15, 2010

AndreaMeier wrote:

Hello,

in Trados 2007 SP2, the filter settings offer the possibility to enter non-translatable styles for Word 2000-2003, however this is not possible for Word 2007.

We want to translate a Word 2007 document in the TagEditor and have some self-defined styles that are not to be translated, how do I exclude them from translation in the TagEditor?

Thanks in advance for your help!

Andrea


Hi,
this functionality works perfectly in Studio 2009 - so maybe worth to try.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 03:25
Member (2003)
Polish to German
+ ...
Try to apply tw4win.* to any text Jan 15, 2010

and then remove the formatting - only in case the style and local formatting do match, the formatting will be restored. But if - as in nealry all cases - the formatting has been adapted locally, the formatting will be altered.
But anyway - you are of course right. Please don't think I wanted to discredit your information anyhow. This is not the case, I just reported from my experience.


Direct link Reply with quote
 
Stefan de Boeck  Identity Verified
Belgium
Local time: 03:25
English to Dutch
+ ...
not Teddie Jan 15, 2010

Stefan de Boeck wrote:
By my suggestion no formatting whatsoever is being altered nor even hidden.

Indeed. It appears that, when taken to the test, my theory is utter rubbish; in TagEditor it doesn't even work for doc.

For crying out loud.

Does in Word though (TWB, Word2007, docx) but not without the protected content being accompanied by a comment "Removed" (drops in target beautifully all the same).

If you absolutely need to use TagEditor (haven't used the thing for actual translation in years) follow Jerzy.
If you want to improve your workflow, get Studio (PMz is right).

Or simply use Word.

(The style - e.g. CustomStyle - can be entered as is; no
in

required)


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDL Trados 2007 filter: non-translatable styles for Word 2007

Advanced search







Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search