Setting Trados target language in Word
Thread poster: Jerr
Apr 6, 2010

The Trados source/target languages are marked correctly in Translator's Workbench, but in Microsoft Word I have to mark the correct language for every single sentence. Word just uses the source language for the target text. How should I go about dealing with this?

Many thanks in advance!


Direct link Reply with quote
 

Peter Linton  Identity Verified
Local time: 04:13
Member (2002)
Swedish to English
+ ...
Does it matter? Apr 6, 2010

I agree with you that Word just uses the source language for the target text. But in my experience it does not matter at that stage. The target language you type in is displayed correctly.

But I agree that the finished translation should be in the target language. So when I have finished translating I :
- switch off the hidden text (Tools, Options, uncheck Hidden and All)
- highlight the whole target document (Ctrl-A)
- switch to target language (Tools, Language, Set Language, select your target language.)

Now if you run the Spellchecker it will use the target language you have set.

Perhaps someone else has a better solution.


Direct link Reply with quote
 
Jerr
TOPIC STARTER
AutoCorrect Apr 6, 2010

My spellchecker is set to automatically correct typos as I type, which is quite useful when the language is set correctly. I guess I'll just have to disable it. Still, thank you - I thought I might just be missing something obvious!

Direct link Reply with quote
 

Henry Schroeder  Identity Verified
United States
Local time: 23:13
Member (2002)
German to English
+ ...
Is there really no solution to this? Oct 4, 2010

I am also thoroughly sick of this problem and would be extremely grateful for knowledge of the resolution!!!

Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 05:13
French to German
+ ...
Switch to the new generation of SW Oct 4, 2010

Henry Schroeder wrote:

I am also thoroughly sick of this problem and would be extremely grateful for knowledge of the resolution!!!


In this case, why don't you switch to Studio? This is only one of the problems that make you sick which you won't have anymore.

Walter


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 05:13
French to Polish
+ ...
Workaround... a curious design... Oct 4, 2010

Peter Linton wrote:

I agree with you that Word just uses the source language for the target text. But in my experience it does not matter at that stage. The target language you type in is displayed correctly.

But I agree that the finished translation should be in the target language. So when I have finished translating I :
- switch off the hidden text (Tools, Options, uncheck Hidden and All)
- highlight the whole target document (Ctrl-A)
- switch to target language (Tools, Language, Set Language, select your target language.)

Now if you run the Spellchecker it will use the target language you have set.

Perhaps someone else has a better solution.


It's not a clean solution but you can also apply the language before you start to translate.
It works well only for small documents 'cause the spellchecker stops to display the suggestions when too many "errors" are spotted.

BTW, the correct source language is set automatically when you close the segment, at least in the builds I remember.
When you reopen the segment, the target language is OK.
IMO it's an error in the design, the language should be applied automatically for every new segment when opened.

Cheers
GG


Direct link Reply with quote
 

Henry Schroeder  Identity Verified
United States
Local time: 23:13
Member (2002)
German to English
+ ...
Thanks but I still can't believe it Oct 4, 2010

The problem is not as much the inability to identify the language as it is the autocorrect feature. Every time you time "for the" in a text being translated from German to English, Trados automatically takes the "t" in "the" and attaches it to the end of "for" to create the German word "fort". Imagine how often you type "for the" in a text!!!

I did just successfully manage to remove the auto-correction feature (which didn't work the last time, but I'm no expert with MS Word). What I don't understand is how Trados is set to translate from German to English (in my case), but doesn't have English as the language in the target segment. Or does MS Word override it?

Anyway thanks for the ideas!


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 05:13
French to German
+ ...
Did you activate automatic language recognition? Oct 4, 2010

Henry Schroeder wrote:

The problem is not as much the inability to identify the language as it is the autocorrect feature. Every time you time "for the" in a text being translated from German to English, Trados automatically takes the "t" in "the" and attaches it to the end of "for" to create the German word "fort". Imagine how often you type "for the" in a text!!!


This usually happens only if you checked the option in Word to automatically recognize the language. If you disable this, it takes the correct language. It is a Word problem though and not an SDL problem.

Walter


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Setting Trados target language in Word

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search