Trados 2007 - how to filter out or ignore specific part of each line
Thread poster: Tomas Mosler, DipTrans IoLET MCIL MITI

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
Apr 9, 2010

Hello, I have a text full of single lines like:

valuecode.title=Enter code
valuecode.text=Enter code here

What and how do I change in the Trados 2007 (Workbench / TagEditor 8) settings so I'm prompted to process only the part after "=" (ie. "enter code"), while the first part stays untouched; or where I could get some BFU instructions on this?

Thank you!


Direct link Reply with quote
 

Laura Bissio CT  Identity Verified
Uruguay
Local time: 05:00
Member (2008)
English to Spanish
+ ...
change segmentation Apr 9, 2010

Hi,
I presume you can change segmentation rules to include '=' as a segmentation mark.
So you can confirm the first segments unchanged and edit the others.
Good luck!


Direct link Reply with quote
 

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
TOPIC STARTER
no Apr 9, 2010

Well I tried to do this change under Segmentation rules (I inserted =), but it still opens the whole line.

Direct link Reply with quote
 

Laura Bissio CT  Identity Verified
Uruguay
Local time: 05:00
Member (2008)
English to Spanish
+ ...
check whitespaces Apr 9, 2010

maybe you have trailing whitespaces or leading characters specified in the segmentation rule and the text doesn't have any after the '=', otherwise it should work.

Direct link Reply with quote
 

István Hirsch  Identity Verified
Local time: 09:00
English to Hungarian
Conversion before translation Apr 9, 2010

Copy/paste the source text into an empty Excel file, then select Data/Text to Table („=” is the separator), translate column B with Tageditor, and copy/paste back the translation into the Excel table.

Direct link Reply with quote
 

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
TOPIC STARTER
thanks Apr 9, 2010

Thanks István,

but after I'd finish the translation of the line/cell after =, how do I merge it back together with the first part (and have =, which disappears when used as separator, in place)?

Thank you!


Direct link Reply with quote
 

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
TOPIC STARTER
whitespaces Apr 9, 2010

Laura, I don't know if I do something wrong, but I have no whitespaces or any other values set in the Segmentation rules in Workbench, but it still opens the whole line as one segment.

Direct link Reply with quote
 

Laura Bissio CT  Identity Verified
Uruguay
Local time: 05:00
Member (2008)
English to Spanish
+ ...
sorry Apr 9, 2010

I can't figure out what's wrong then...
in this case, I'd use 'copy source' and edit half of the segment

best regards and good luck!

Laura


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 09:00
English to Czech
+ ...
Tw4winExternal Apr 9, 2010

Hi Tomas,
perhaps you could assign the tw4winExternal or DoNotTranslate style to the untranslatable parts in Word and open the file in TagEditor only then.


Direct link Reply with quote
 

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
TOPIC STARTER
segmentation Apr 9, 2010

Laura, I forgot to define the stop character (only put in = as the name), now it works... Thanks.

Stanislav, I thought of that too, but I still have the same problem - how to make Word think (without chanding the style line by line manually) something before = is one style and after = another? Thank you if there is some automatic process for that.


Direct link Reply with quote
 

Stanislav Pokorny  Identity Verified
Czech Republic
Local time: 09:00
English to Czech
+ ...
Howto Apr 9, 2010

Hi Tomas,
I may have found a way:
1. Open the file in Word
2. Press CTRL+H
3. Enter valuecode.title= in the "Search for" field, click the "More" button, select "Format" > "Style" and select "Normal" from the list
4. Enter valuecode.title= in the "Replace with" field, click the "More" button, select "Format" > "Style" and select "tw4winExternal" from the list
5. Click "Replace All"

That should be it. I hope it will work for you.

[Upraveno: 2010-04-09 17:45 GMT]


Direct link Reply with quote
 

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
TOPIC STARTER
style Apr 9, 2010

Stanislav, the problem is that each line has a different variable
valuecode.TITLE, valuecode.TEXT etc. (as shown in the sample)

So some general rule "hide/ignore everyting up to = on each line" would be required.

(Now I can use the segmentation by =, but that still means some extra work moving thru the nontranslated parts.)


Direct link Reply with quote
 

István Hirsch  Identity Verified
Local time: 09:00
English to Hungarian
Merge the cells Apr 9, 2010

I mean you should take the whole column (B) to Tageditor, translate it, and then the cleaned translated column should be copied and pasted back into the Excel table, so you will have in column A the left side of the phrase (not translated) and in column B the right side of the phrase (translated).

To merge the two sides (and =), after translating and pasting, write in cell C1: =MERGE(A1;"=";B1) then press Enter, move the mouse over the right bottom corner of C1, and when the + sign appears, drag it down along C.


Direct link Reply with quote
 

Tomas Mosler, DipTrans IoLET MCIL MITI  Identity Verified
Czech Republic
Local time: 09:00
Member (2008)
English to Czech
TOPIC STARTER
thank you Apr 9, 2010

Thanks István, I understood the column B action, it was that MERGE "command" I didn't know about.

Direct link Reply with quote
 

Tomasz Kościuczuk  Identity Verified
Poland
Local time: 09:00
English to Polish
+ ...
Same problem - solution not working May 13, 2010

Hello,

My problem is identical to that originally outlined by Tomas.

I am working on a list of resources and would expect Trados Workbench to ignore any string preceding the equation mark. I worked on very similar files before and the settings - as indicated by Laura - worked, i.e. the initial parts of strings were completely ignored during translation and they were not uploaded to the TM.

This does not work with the current file. On the one hand Workbench opens the whole lines, but on the other it seems to ignore the initial strings while prompting TM matches. As a result the initial parts preceding the equation marks are absent from the output text.

I would be seeking a solution within Workbench and would rather not rely on other applications. It must be possible somehow as it did work before.

Thank you for any suggestions which you might have!


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2007 - how to filter out or ignore specific part of each line

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search