Pages in topic:   [1 2] >
How to open Wordfast TXML with Trados Studio?
Thread poster: ITtranslations

ITtranslations
Seychelles
Local time: 00:16
Member (2002)
English to Spanish
+ ...
Apr 23, 2010

Hello, does anyone know a way to open a Wordfast Pro TXML file in Studio 2009 and how to configure the filter type?

Is TXML a kind of XLIFF?


Direct link Reply with quote
 

Piotr Bienkowski  Identity Verified
Poland
Local time: 00:16
Member (2005)
English to Polish
+ ...
Not sure if this helps but... Apr 24, 2010

I know that Swordfish can open TXML files. In Swordfish you can convert a TXML file to XLIFF, and Trados Studio can open XLIFF files.

You can try out Swordfish for free for a month.

HTH

Piotr


Direct link Reply with quote
 

ITtranslations
Seychelles
Local time: 00:16
Member (2002)
English to Spanish
+ ...
TOPIC STARTER
Thank you Apr 26, 2010

Hello, thank you. That's the only solution I've found for the moment. I'll try that although Studio is not really a QA Tool per se.

Direct link Reply with quote
 

Samuel Murray  Identity Verified
Netherlands
Local time: 00:16
Member (2006)
English to Afrikaans
+ ...
Swordfish can TXML May 20, 2010

Piotr Bienkowski wrote:
I know that Swordfish can open TXML files. In Swordfish you can convert a TXML file to XLIFF, and Trados Studio can open XLIFF files.


I just tried the roundtrip TXML > XLIFF > SDLXLIFF > XLIFF > TXML. Swordfish accepts the XLIFF file produced by Trados 2009, but when I try to create the TXML file again, I get an error message with no text on it, and the resultant TXML file is empty.

I'm using Swordfish 2.0-2.


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 00:16
French to Polish
+ ...
General caveats... May 21, 2010

Samuel Murray wrote:

Piotr Bienkowski wrote:
I know that Swordfish can open TXML files. In Swordfish you can convert a TXML file to XLIFF, and Trados Studio can open XLIFF files.


I just tried the roundtrip TXML > XLIFF > SDLXLIFF > XLIFF > TXML. Swordfish accepts the XLIFF file produced by Trados 2009, but when I try to create the TXML file again, I get an error message with no text on it, and the resultant TXML file is empty.


I didn't test it with Swordfish but the general caveat is to don't change the segmentation in the TXML file edited outside Wordfast.
Some tools also need the populated target (undocumented Ctrl+Alt+Ins in Wordfast).

You can also create your XML filter, you use some info from Roberto Savelli's procedure for memoQ:
http://blog.albatrossolutions.com/tent-cat-tools/translating-wordfast-txml-files-in-memoq
The Ctrl+ALt+Ins performs the operation descrived in the section Open the .txml file with an editor and replace some strings.

Cheers
GG


Direct link Reply with quote
 

ITtranslations
Seychelles
Local time: 00:16
Member (2002)
English to Spanish
+ ...
TOPIC STARTER
Thank you May 21, 2010

Yes, I got the same. Thank you. I also tried through Catalyst but I got a similar result.

Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 00:16
French to Polish
+ ...
Creating your own filter... May 21, 2010

Charlotte Urrestarazu wrote:

Yes, I got the same. Thank you. I also tried through Catalyst but I got a similar result.


Well.
It works with memoQ and DVX, the filters were published by fellow translators.

As TXML is a relatively simple XML, T2009 should work too if you are able to find the the new file type wizard using the T2009 help

The easiest aproach will be the populated target.

Cheers
GG


Direct link Reply with quote
 

ITtranslations
Seychelles
Local time: 00:16
Member (2002)
English to Spanish
+ ...
TOPIC STARTER
Good news May 21, 2010

Oh yes? With MemoQ and DVX too? I'll try that as well. Thanks a lot!

Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 00:16
English
Creating the filetype on Studio May 21, 2010

Hi Charlotte,

I thought I'd add to this conversation. The process I have test this morning after Samuel popinted me in the direction of a trial version of Wordfast is this;

  • Open the TXML in Wordfast and copy all source to target as Grzegorz suggested
  • Save and copy the TXML and rename as xml for the time being
  • Open Studio and go to Tools-Options-Filetypes
  • Create a New filetype and select xml
  • In the first window that comes up replace the File Dialogue Wildcard Expression to read *txml instead of *.xml. This way the TXML files will be recognised in the future. You can also change the name of the filetype here too so you can recognise it easily later
  • Click on Next and then select Define settings based on INI, ANL, XML, XSD or ITS rule. Then browse and select the TXML file you renamed as XML earlier
  • This will populate all the relevant fields to start with. Further customisation is possible to make it nicer later on.
  • Now go Next thenNext and Finish
  • You will now have the new filetype showing in your list of filetypes. Select it and then choose Parser Rules.
  • Select all the rules that were brought in on the import and delete them. Now add two XPATH rules as follows
  • //* and set as Not translatable - this will ensure nothing is parsed at all when you open the file
  • //target and set as Always Translatable - this will ensure only the target elements in the TXML are exposed
  • Now open your TXML for translation and when you save as target you will find that the translated TXML should open in Wordfast too


Sounds a little lengthy in words like this but actually it is very quick. I hope this helps, but if you have any questions please let me know.

Regards

Paul


Direct link Reply with quote
 

Axel Pohl  Identity Verified
Germany
Local time: 00:16
English to German
Imported file is empty Sep 1, 2010

Hi Paul,

This looked like something I urgently needed.

So, I followed the setting up of the new file type (adding XPATH items //* and //target) but the import did not show any source nor target segments. What went wrong?

I am using SDL Trados Studio 2009 - SP 2 and WordFast 2.4.0

Thank you


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 00:16
English
Did you copy source to target first? Oct 25, 2010

Axel Pohl wrote:

Hi Paul,

This looked like something I urgently needed.

So, I followed the setting up of the new file type (adding XPATH items //* and //target) but the import did not show any source nor target segments. What went wrong?

I am using SDL Trados Studio 2009 - SP 2 and WordFast 2.4.0

Thank you


Hi Axel,

Apologies for the late response to this. I didn't notice it until I looked for this post today. Are you sure you followed this part?

  • Open the TXML in Wordfast and copy all source to target as Grzegorz suggested

If you don't do this first then the file will be empty when you open it in Studio as we are only taking the TXML and creating an xml from it, but translating the target as it was source.

Regards

Paul


Direct link Reply with quote
 

Urrestarazu  Identity Verified
Spain
Local time: 00:16
Member (2008)
English to French
+ ...
Thanks a lot for the detailed explanation! Oct 25, 2010

Thanks a lot. I'll try it.

Direct link Reply with quote
 

Selcuk Akyuz  Identity Verified
Turkey
Local time: 02:16
Member (2006)
English to Turkish
+ ...
TXML filter available since 2008 Oct 25, 2010

David Turner prepared a TXML filter for DVX in 2008. And we use it successfully for both translation and proofreading.

See: http://tech.groups.yahoo.com/group/dejavu-l/message/92253

And for proofreading TXML files in DVX see:
http://tech.groups.yahoo.com/group/dejavu-l/message/98711


Direct link Reply with quote
 

Karina Garcia Pedroche  Identity Verified
Argentina
Local time: 20:16
English to Spanish
+ ...
"Element cannot contain slashes" Jul 24, 2012

SDL Support wrote:

  • //target and set as Always Translatable - this will ensure only the target elements in the TXML are exposed



  • Hi Paul,

    I am also trying to open a txml file in Trados Studio. I followed your instructions but when I enter the parse rule "//target" a warning message reads "Element name cannot contain slashes". Can you help me, please?

    Regards,

    Karina


    Direct link Reply with quote
     

    SDL Community  Identity Verified
    United Kingdom
    Local time: 00:16
    English
    Adding XPATH rules Jul 25, 2012

    Karina Garcia Pedroche wrote:

    I am also trying to open a txml file in Trados Studio. I followed your instructions but when I enter the parse rule "//target" a warning message reads "Element name cannot contain slashes". Can you help me, please?



    Hi Karina,

    I guess you are typing this in as an element rather than as an XPATH statement? So in here make sure you select XPATH:


    Regards

    Paul


    Direct link Reply with quote
     
    Pages in topic:   [1 2] >


    To report site rules violations or get help, contact a site moderator:


    You can also contact site staff by submitting a support request »

    How to open Wordfast TXML with Trados Studio?

    Advanced search







    WordFinder
    The words you want Anywhere, Anytime

    WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

    More info »
    CafeTran Espresso
    You've never met a CAT tool this clever!

    Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

    More info »



    Forums
    • All of ProZ.com
    • Term search
    • Jobs
    • Forums
    • Multiple search