Trados Studio 2009 won't open/hangs
Thread poster: Strastran (X)

Strastran (X)
France
Local time: 07:45
French to English
+ ...
Apr 28, 2010

Hi

I have a very urgent problem with Trados Studio 2009, namely that it won't open at all.

I've been working with it fine until today, when it began to hang on the splash screen, specifically at 'Loading Editor view...'. It also locks out everything else on my computer so I have to forcefully reboot.

I found another discussion here: http://mlt.proz.com/forum/sdl_trados_support/155192-error:_failed_to_initialize_editor_view.html, followed the instructions and rebooted. Now Trados Studio will open, but hangs after a few seconds. Again, I have to reboot as my computer won't respond to anything.

I've tried to uninstall the software but it hangs on the first screen, 'gathering required information', so I can't even try to reinstall it.

I'm on Windows 7. I'd appreciate any help as I have urgent work to do and am completely stuck!

Thanks in advance.

Patrick


 

Strastran (X)
France
Local time: 07:45
French to English
+ ...
TOPIC STARTER
Solved Apr 29, 2010

I've managed to solve this problem and thought I'd share the details in case anyone else has the same issue.

I decided to launch a System Restore, but my PC advised me that I needed to carry out a Disk Check first, and prompted me to select 'perform disk check on reboot'. I rebooted, and the disk check was carried out - it lasted about 3 hours (!).

During the check the process identified and repaired a file relating to SDL Trados Studio 2009 that had become corrupt.

After another reboot, the problem appears solved and I can work again.


 

Maria Palma  Identity Verified
Austria
German to Spanish
+ ...
Could you be so nice to give more details???? Jun 3, 2010

Hi Patrick

I cannot manage to install Trados Studio on my new laptop with Windows 7. I tried already a bunch of solutions with no resultsicon_frown.gif and I'm still waiting for an answer from the support team.

I read your solution with interest. I think I have as well some corrupt files.... Could you be so nice to explain me with more detail what did you do? For instance, did you proceed to uninstall the Studio before the system restore? How did you choose the restore point?

Thank you in advanced


Maria


 

Maria Palma  Identity Verified
Austria
German to Spanish
+ ...
Already working Jun 10, 2010

The support team contacted me and they found the solution!

 

Michael Kazakov  Identity Verified
Israel
Local time: 08:45
English to Russian
+ ...
Same problem here Sep 3, 2010

Patrick Stenson wrote:
I have a very urgent problem with Trados Studio 2009, namely that it won't open at all.
...
I'm on Windows 7.


I have the same problem: Windows 7, regular user account, Studio 2009 SP1.

Studio will pass the "Initializing Editor view" message in the splash screen, will open its icon on the task bar but will not open the main window at all.

I tried restoring an older restore point, but it didn't work. I upgraded it to SP2 but again no luck, it simply will not open the main window.

What makes it even more weird that it works fine in my main admin account, which is what I am using right now to finish my project.

Are there any clear instructions on what to do in this case? Knowledge base article? Complete reinstall?

Thanks in advance for any tips.icon_smile.gif


 

Michael Kazakov  Identity Verified
Israel
Local time: 08:45
English to Russian
+ ...
Fix for Windows 7 Sep 4, 2010

In case someone else has this problem:
Windows 7, SDL Trados Studio 2009 SP1 and SP2

Symptoms:
the program will open its splash screen,
go through all initialization processes,
open its icon on the start bar
but will not open the main window.

Michael Kazakov wrote:

Are there any clear instructions on what to do in this case?


Solution:
a) enable "show hidden folders" (if hidden)
b) go to C:\Users\[Your_Username]\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0 and delete
BaseSettings.xml
plugincache.xml
UserSettings.xml
c) Open Studio, which will open in new user mode, complete all steps (click "Next").
d) The program will now open fine

That worked in my case.icon_smile.gif


 

Cort Rosebro  Identity Verified
United States
Local time: 01:45
Italian to English
+ ...
Still cannot open mine Dec 29, 2010

I am also having problems opening Studio 2009. I tried the solution that involved deleting the BaseSettings and plugincache xml documents, but I still get the same result:

"Unexpected exception when getting view part instance of view part Translation Results"

Any ideas on what to do here, anyone?


 

Jerzy Czopik  Identity Verified
Germany
Local time: 07:45
Member (2003)
Polish to German
+ ...
Delete those files again Dec 29, 2010

In Windows enter "regedit" in the search field. When the system finds the regedit.exe start the program. Please be aware that you are modifying the registry and thus must be very careful.
When the program starts open the HKEY_CURRENT_USER\Software\SDL\SDL Trados Studio key and right click on it. Select rename, use _SDL Trados Studio as name now.
Do the same with this key HKEY_CURRENT_USER\Software\SDL\Studio1 and rename to _Studio1
Close the registry by closing the regedit program and try to start Studio again.


 

Ted Alkins  Identity Verified
Local time: 07:45
Dutch to English
+ ...
Quicker solution (if you back up properly) Apr 7, 2011

I recently had the problem (again) of Studio not getting beyond the splash screen. It occurred after updating the program.

On a previous occasion, I followed the suggestion about deleting the three files in C:\Users\[Your_Username]\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0 and that worked.

This has the effect, however, of removing all your user settings. Not only is it annoying to have to go through and adjust the screen layouts, font sizes, etc. for the nth time, there is always a danger (given Studio's complexity) of forgetting to adjust some importing setting correctly.

After some experimentation, I found that the problem lies with the usersettings.xml file. I changed the name of that file to usersettings.xml.old and then restored an earlier version of usersettings.xml from my backup program.

That solved the problem without me having to reconfigure all the settings.

Regards,

Ted.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados Studio 2009 won't open/hangs

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search