Trados 2007 Workbench: "Failed to create Java Virtual Machine" (InDesign file)
Thread poster: ViktoriaG

ViktoriaG  Identity Verified
Canada
Local time: 17:08
English to French
+ ...
Apr 30, 2010

Hello all,

I have a problem with an INX file. Workbench refuses to translate it (I am trying to use the Translate function in order to create a TTX file).

The INX file size is 1.5 MB. In Windows, in Add or Remove Programs, all I have for Java is:

- J2SE Runtime Environment 5.0 Update 10
- Java(TM) 6 Update 7

I have tried changing the Java virtual machine size in the Filter Settings application to no avail. The maximum I am allowed is 512 MB, and that is already what it was set to initially. The Filter Settings application says I have 3072 MB available.

The funny thing is, I have checked Talisma and it recommends 2 GB, but the Filter Settings interface says the absolute maximum is 512 MB.

Does anybody have a solution to propose? Also, can anybody tell me why SDL tells me to set the upper limit to 2 GB when their product clearly can't go above 512 MB?

P.S.: Please. don't propose that I switch to Studio. For reasons I will not get into here, I would rather leave Studio where it is--in a box on a shelf in a closet.


 

CLooney
Local time: 22:08
Problem with Latest version of Java May 13, 2010

Hi
We have been seeing this issue with the latest build of Java and Trados 2007 for INX files.

Java builds:
6u14 is OK
6u18 is probably bad
6u20 is Bad

How likely is it that Trados will resolve this?


 

Matthieu Moroni  Identity Verified
France
Local time: 23:08
Member (2008)
German to French
+ ...
My solution Sep 7, 2010

Hello,

I had the same problem with TagEditor and .inx CS3 files.
TagEditor crashes after an error message "Failed to Create java Virtual Machine".

My solution is: I close Trados and Workbench, then I delete as many files as possible in the folder C:\Documents and Settings\Username\Local Settings\Temp.

TagEditor works smooth again when I relauch it.
Hope this helps!


 

Claudio Porcellana (X)  Identity Verified
Italy
another solution Sep 8, 2010

in my case no one fix worked: Talisma, Proz, other forums

finally I clicked on Add/Remove Programs then Custom (Personalizzata in Italian), then I choosed the Microsoft Virtual Machine instead of Java Virtual Machine and it worked !

so I think it is a Java bug, may be added by some recente update

hope it helps in other situations

Claudio


 

Peter Motte  Identity Verified
Belgium
Local time: 23:08
Member (2009)
English to Dutch
+ ...
Memory size for Java Feb 24, 2013

When I tried to open an .inx-file in TagEditor, I got this message:

Error when using plug-in file filters
Failed to create Java Virtual Machine.


I tried using the install/uninstall facility in Software (Configuration screen of Windows), and I also tried this:
- delete the "PluginFileFilterDefinitions.xml" file and then run a repair on
SDL Trados 2007 to replace the file.

Those tricks didn't help.

However, I had read somewhere that comparable problems are sometimes sold by changing the memory size allocated to Java by Trados.

Start -> Programs -> SDL International -> .... -> Filter Settings
And than set the memory size for Java as low as possible.
And that solved the problem.

I use Windows XP SP3
and
Trados 2007/2009 (probably SP3, as I upgraded only past year or so)
and Trados 2011

Unfortunately, in the meantime I had also erased Java 7 (don't know which version actually), but I have the feeling simply changing the memory size allocated to Java by Trados was the solution.
I'm not the first one who was helped by that.


 

Marc Sejourné  Identity Verified
Cambodia
Local time: 05:08
English to French
That solved the problem Mar 19, 2013

Thank you Peter.

I just minimized the size of the JVM (Java Virtual Machine) and the error message is now gone, I can resume working.

Peter Motte wrote:

When I tried to open an .inx-file in TagEditor, I got this message:

Error when using plug-in file filters


Failed to create Java Virtual Machine.


I tried using the install/uninstall facility in Software (Configuration screen of Windows), and I also tried this:
- delete the "PluginFileFilterDefinitions.xml" file and then run a repair on
SDL Trados 2007 to replace the file.

Those tricks didn't help.

However, I had read somewhere that comparable problems are sometimes sold by changing the memory size allocated to Java by Trados.

Start -> Programs -> SDL International -> .... -> Filter Settings
And than set the memory size for Java as low as possible.
And that solved the problem.

I use Windows XP SP3
and
Trados 2007/2009 (probably SP3, as I upgraded only past year or so)
and Trados 2011

Unfortunately, in the meantime I had also erased Java 7 (don't know which version actually), but I have the feeling simply changing the memory size allocated to Java by Trados was the solution.
I'm not the first one who was helped by that.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2007 Workbench: "Failed to create Java Virtual Machine" (InDesign file)

Advanced search







SDL MultiTerm 2019
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2019 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2019 you can automatically create term lists from your existing documentation to save time.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search