How to identify the pre-translated segments?
Thread poster: jimshanks

jimshanks
Local time: 03:49
Dutch to English
May 8, 2010

Hi All,

I often receive ttx files from clients which contain pre-transled segments (100% matches in the TM supplied by the client). The target segments for these 100% matches are in a blue font.

The clients do not want me to touch these 100% match pre-translated segments. This is not a problem in TRADOS 2007, the colours are not affected and I can easily skip over the pre-translated text.

However, if I open the ttx file in Studio 2009 these 100% matches in blue font appear as 100% matches but the font has now been changed to black so I can no longer easily identify the pre-translated segments or distinguish them from my own 100% matches later in the translation process.

Does anyone know how I can retain the blue font of the pre-translated segments while working in Studio 2009 or have some other way of identifying them so that I do not check or change them at a later stage in the translation process? Also, the ttx files produced at the end of the process would have to retain the original 100% match, pre-translated segments in blue so that the client can still see the segments that were pre-translated and which segments I have translated.

If not, is there any way the client could supply ttx (they use TRADOS 2007) that would allow me to work in this way? The original files were xml files.

Thanks


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 04:49
English
Maybe work another way May 8, 2010

Hi Jim,

Maybe you could work another way? If the 100% matches are always sacrosanct then why not start work by using the Filter on 100% pretranslated segments, then lock them all in one go. Now start your translation and these segments will remain untouched. I haven't tested it but I doubt the locked status will be retained in the ttx so you probably wouldn't have to worry about unlocking after you are finished, just Finalise your project when you are done and that's it.

Regards

Paul


Direct link Reply with quote
 

jimshanks
Local time: 03:49
Dutch to English
TOPIC STARTER
Partial solution, but not quite there May 9, 2010

Hi Paul,

I have tried your solution and while it works partly - the pre-translated segments remain untouched - there is a problem.

The client wants to have .ttx files. Saving the final file in .ttx format means that the target text of pre-translated segments, which was in blue in the original .ttx file is still converted to black. Of course, the text in the original XML file is all in black, it is only after pre-translation in .ttx format that the target text is blue.

I wonder if anyone has any further ideas on this? It may be that there is no solution, as the program was not written to work in this way and I will have to find a more devious work-around.

Thank for your help so far Paul, although not a full solution it has presented me with a working method that I can use in other scenarios and which had not occurred to me.

Jim


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 04:49
Member (2003)
Polish to German
+ ...
How do they get the text formatted blue in ttx? May 9, 2010

TTX is xml - so plain text and TagEditor also is a plain text editor, where you neither can format the text blue nor change the colour of already formatted text.
So as far I understand you, thet text must be formatted using some tags. And tags in text remain untouches AFAIK.


Direct link Reply with quote
 

jimshanks
Local time: 03:49
Dutch to English
TOPIC STARTER
Not too sure I am with you May 9, 2010

Hi Jerzy,

many thanks for your comments but I am not too sure I follow you (apart from the fact that you don't think it is possible to achieve my aim).

The process starts with an XML file. This XML file is converted to a .ttx file and pre-translated in TRADOS Workbench (2007). The Translated Text Colour settings in Workbench have been modified to Source Unchanged and Target (100% Match) is Blue. The file is then pre-translated and I receive this pre-translated ttx file with target text in blue - I am not to touch this blue text and the product I am to deliver is a ttx file where these original 100% matches still appear in blue. This is not a problem at all in Tag Editor.

However, I prefer to use STUDIO 2009 for obvious reasons, and this is where the problems are occurring. When I open the ttx file in STUDIO 2009 the text that was previously blue (pre-translated 100% matches) is now black. When I save the translated file back to TRADOS tag format it remains black, which is not what the client wants to receive.

As I said to Paul, there may be no solution for this in STUDIO 2009 and I already have a couple of tentative post-processing solutions which will be applied to the file once it has been saved as a Trados tag file. However, if there is a way to do it without doing post processing it would save a lot of time, but as I said, I fear this may not be possible.

Thanks anyway

Jim


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

How to identify the pre-translated segments?

Advanced search







Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search