"object reference not set to an instance of an object" - saving Excel target file in SDL Studio SP2
Thread poster: Fulvio Giglio

Fulvio Giglio
Italy
Local time: 20:43
Member (2006)
English to Italian
+ ...
May 20, 2010

I was trying to translate an Excel file in SDL Trados Studio 2009 SP2.

I use MS Office 2007 SP2 and SDL Trados Studio 2009 SP2.

After having finished the translation, I was trying to save the translation to the target original Excel format, and I got the message ""object reference not set to an instance of an object". The original file was in the same directory where I was trying to save the translated file. Initially I was renaming the target file, then I also tried to overwrite the original file with the target file, with the same error message.

I exported the SDL Studio TM, imported the tmx into a Trados workbench TM, opened the same Excel file in TagEditor and I managed to save the target (translated) Excel file without problems.

My point is: what's the point in upgrading if an earlier software does the job better than the latest software?

Has anybody encoutered this error before? How was the problem solved?

Thanks for your help

Best regards

Fulvio Giglio MITI - MCIL
Translator/interpreter EN IT
CET working hours
Via IV Novembre 3/6
17011 Albisola Superiore (SV) - ITALY
Ph. +39-019481123 - fax +39-0194501836 (e-mail fax)
Cell. +393311110958 SKYPE : fulviogiglio
E-mail: giglio.bass@iol.it MS Messenger: Fulvio Giglio


Direct link Reply with quote
 

Maria Palma  Identity Verified
Austria
German to Spanish
+ ...
Did you find any solution? Jun 3, 2010

Hi Fulvio,

I got the same message. I bought a new laptop a install Trados Studio 2009, but it doesn't work at all.... I got either this message or worst. For instance when I try just to open a file I get "Sd. TranslationStudio. Api.Editor.IEditorService" could not be started.....
I don't have any PSMA but still I think this is an installation issue. However I'm still waiting for an answer from the support since Monday. (And wasting my time trying to fix the problem by myself) I have the Studio running at a PC but it's old and slow.... that's why a bought a new laptop, a pretty good one with Windows 7 ....
I've just try a bunch of solutions but with no result... If you have any idea....
Thank you

Maria


Direct link Reply with quote
 

Maria Palma  Identity Verified
Austria
German to Spanish
+ ...
the solution that worked for me Jun 10, 2010

Close Studio, then rename the following foders to [originalfoldername]_old:

1. Under Libraries\Documents\My Documents rename the folder "SDL Trados Studio" to "SDL Trados Studio_old"

2. Under C:\ProgramData rename the "SDL" folder to "SDL_old".

3. Under C:\Users\[USERNAME]\AppData\Roaming\ rename the SDL folder to SDL_old.

Then restart Studio


Direct link Reply with quote
 

ChristineSmeets
Netherlands
Local time: 20:43
English to Dutch
+ ...
Problem solved with renaming folders Jul 7, 2010

I had the same problem: new laptop with Win7/64 bits on which I first installed Studio 2009 trial version.

Renaming the folders you mention solved my problem.

Thanks very much.

Christine


Direct link Reply with quote
 

Giffted  Identity Verified
Dominican Republic
Local time: 15:43
English to Spanish
+ ...
Same problem here-solution did not work Aug 17, 2010

Hi,
I am experiencing the same problem when trying to save a translated excel file. I get the same error. Renaming the folders did not work for me. I reverted the changes in the folders (deleted the new ones created by trados and renamed the first ones) and nothing changed.
Any more ideas?


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 20:43
Member (2003)
Polish to German
+ ...
Did you by any chance verify your translation? Aug 17, 2010

It may sound strange, but quite often strange error messages are related to quite simple reasons.
Please verify your translation, if no tags are missing.
If no tags are really missing, you could also try to retranslate the same file, but converted to Excel 2007.
Otherwise I run out of ideas unfortunately (at least for now)...


Direct link Reply with quote
 

Giffted  Identity Verified
Dominican Republic
Local time: 15:43
English to Spanish
+ ...
did not work Aug 17, 2010

Hi Jerzy,
I did a QA Verification for the file and no error was found. It has something to do with saving it. i renamed all folders suggested before, also deleted some xlm files suggested by Paul in another post similar to this one...nothing.
Tried your suggestion this time...nothing....
So far I am copy/pasting the translation into an excel file and formatting it according to the original...pretty sad uh!


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 20:43
French to German
+ ...
Can you preview the source Aug 18, 2010

I am experiencing the same problem when trying to save a translated excel file. I get the same error.


Check if you can preview the source file. If this works, the problem has been introduced by the translation and you need to find out where. If the Verifier does not give any error, then the only way is to start again with an untranslated source, translate to fuzzy stepwise and do a preview after every few segments to locate where the error gets introduced. Tedious, I know, but in such a (rare) case the only way.

If however the source preview already fails, it means that the document will not convert back anyway, which means that the filter has a problem with this special document. You did not mention which version of Office you use. If this Excel has been saved in Excel 2010, this might be the cause, as Office 2010 support is still not final in SP2 and can create such incompatibility problems (especially if you did not overwrite the filetypes). In that case, take the original file (either .XLS or .XLSX but saved in 2007) and try again. If you do not use Excel 2010, try to save the source file in another format (.XLSX if it was .XLS or the other way round).

In any way, you must be able to do a preview of the source (and target) just after having opened the document and even before starting the translation.

Walter


Direct link Reply with quote
 

xxxMarkAlexande
Local time: 20:43
This problem is ongoing... Oct 7, 2010

...and it really pisses me off.

I will now have to go through five normed pages of an Excel document, inserting the content cell-by-cell while referring to the TRADOS Studio document which will not export. There are no tag problems, nothing else is amiss with the translation. The Excel file consists of a single sheet. Nothing complex. But the document will not export. My hope is that I can save the situation by exporting the memory and opening it in memoQ. But there's no guarantee.

It's a hell of a way to spend an evening, after getting screwed by a piece of software you spent several hundred dollars to purchase.


Direct link Reply with quote
 

xxxMarkAlexande
Local time: 20:43
This deserves a postmortem... Oct 8, 2010

so here it is:

The problem in my case seems to have been that the Excel file had "protect personal data" switched on. Once I switched off that option, the file was okay, at least in memoQ. (The option is switched off by clicking on the "Excel Options" button at the bottom of the main Office drop-down, then "Security Center/SecurityCenter Setup/Personal Data Protection" and unchecking the "Remove Personal Information from the File When Saving" box.)

How I got to this is another story and the differences between memoQ and Studio on this point are enlightening. Studio:

a) gave me no indication of problems upon importing the document and allowed me to translate the entire thing without complaint, then

b) upon export, folded its cards while raising the uselessly general exception that the program had tried to reference an object that hadn't been created...

whereas memoQ, by contrast:

a) refused the document upon import, and

b) passed through a very useful error message from Excel that the hangup was personal data protection – and the message gave me explicit instructions how to change that. The document exported fine after making the change.

I say this is enlightening because it's revealing of a stability difference between the two CAT tools. memoQ is rock solid. It's just extremely rare for the thing to throw an exception. In this case, when it did, it did so politely – it didn't invite me to translate the entire document and then play gag-and-choke. Studio, on the other hand, throws exceptions for this or that at least weekly. Honestly, sometimes I feel like the thing is held together by chickenwire.

In spite of that, Studio's interface is more intuitive for me and allows me to see more of the document, and the fuzzy matching capability is a necessity for highly inflecting languages. I just wish it were built on something more solid than what must be a mountain of legacy code.


Direct link Reply with quote
 

Lisa Ritchie  Identity Verified
Germany
Local time: 20:43
Member (2010)
German to English
+ ...
Renaming the files worked for me! Aug 1, 2012

Thanks so much, Maria. You really helped me here.

This is twice in two weeks that I've such problems converting files from Trados and I've been late on deadlines as a result, not to mention the sheer amount of effort that goes into fixing these things (due to time lost today, i'll need to work all night on my next project now). I wonder why this happens. Also, renaming the programme folders seems to be quite extreme to me, but it did work.

Thanks again. I'm hoping that SDL can also provide a response to this.

Lisa



Maria Palma wrote:

Close Studio, then rename the following foders to [originalfoldername]_old:

1. Under Libraries\Documents\My Documents rename the folder "SDL Trados Studio" to "SDL Trados Studio_old"

2. Under C:\ProgramData rename the "SDL" folder to "SDL_old".

3. Under C:\Users\[USERNAME]\AppData\Roaming\ rename the SDL folder to SDL_old.

Then restart Studio


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

"object reference not set to an instance of an object" - saving Excel target file in SDL Studio SP2

Advanced search







memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »
SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search