Pages in topic:   [1 2] >
SDL Trados 2009 - TM segments not updated, but added
Thread poster: Uta Kappler

Uta Kappler  Identity Verified
United States
Local time: 17:46
Member (2008)
English to German
+ ...
Jun 1, 2010

I cannot figure out how to prevent SDL Trados 2009 from adding a new segment to the TM every time I enter a change to a segment that already exists. I need to enter review changes, and instead of updating the segments, Trados just keeps adding additional segments. My client and I do NOT want duplicate source segments in the TM since this creates leverage issues for our projects.

The checkbox "Always add new translation to the translation memory" is NOT selected in the Project Settings. Not sure what this checkbox actually does or is supposed to do.

Can someone please give me a hint what settings I need to change to avoid this behaviour of creating duplicate English segments with different translations in the TM? I have tried to update the project TM and the Master TM seperately, all this to no avail. I just want to overwrite the TM segments with my review changes.

This is urgent, since there is of course a deadline for the job.

Thanks a lot in advance for your help!

Uta


Direct link Reply with quote
 

julienwp
France
Local time: 01:46
English to French
Update to latest build Jun 2, 2010

Hi Uta!

What's your build number? This issue happened quite a lot with pre-SP1 Studio...

Update to the latest version (9.1.1264.0). Your problem should be solved
Regards.

Julien


Direct link Reply with quote
 

Uta Kappler  Identity Verified
United States
Local time: 17:46
Member (2008)
English to German
+ ...
TOPIC STARTER
Build Number Jun 2, 2010

Julien,

Thanks for your response.

I do have the latest build of the Freelance Edition installed, i.e. SP2 Build 9.1.1264.0.
So unfortunately this will not solve the problem on my end.

Uta


Direct link Reply with quote
 

Uta Kappler  Identity Verified
United States
Local time: 17:46
Member (2008)
English to German
+ ...
TOPIC STARTER
Supposed to work as follows per SDL KB article ID 3149, but does not seem to... Jun 2, 2010

Per SDL KnowledgeBase article ID 3149
Updating existing translation units in SDL Trados Studio 2009 as opposed to Translator's Workbench in SDL Trados 2007
http://talisma.sdl.com/article.aspx?article=3149&p=1

overwriting a segment should work as follow:

"[...]
Therefore, updating the master translation memory in SDL Trados Studio usually takes place using the bilingual SDL XLIFF files. In the bilingual files, the originally applied translation unit is tracked. If the translation is changed, and the user does not use the Add New Translation command, updating the master translation memory with that bilingual file (typically by running the Finalize task sequence) will overwrite the existing translation unit in the master translation memory as well. This is possible because the original translation is remembered as well as the fact that the user did not add a new translation. In addition, updating the master translation memory through bilingual files is the only way to also record context information for context matches in the master translation memory."

I have this checkbox deselected, but Trados is still adding new segments instead of updating the existing ones.


Direct link Reply with quote
 

Gilles Bronchart  Identity Verified
Belgium
Local time: 01:46
Member (2008)
Is there any update on this topic? Jun 10, 2010

Hi there,

Does anyone have news regarding the fact that Studio will always add translations to the TM instead of overwriting them when processing a batch task (Update main TM), even if the option "Always add new translation" is NOT checked?

Thanks a lot in advance for your feedback.


Direct link Reply with quote
 
Atso Puronen
Local time: 02:46
English to Finnish
You are not alone Jul 13, 2011

I'm joining your club.

We had a project which was sent out to a freelancer as a Studio project package. It was then reviewed in-house. Most segments received only one edit, while others had to be edited a few times. We used just one main TM.

For some segments, Studio (SP3) decided to add every different version of the edited segments: segment as translated by the freelancer, segment as temporarily edited by the reviewer, and final segment by the same reviewer. Segments that got added as duplicates to main TM were either edited once or multiple times. We haven't recognized a specific time window when this issue occurred so we haven't found a common element.

Translation was done in Translation mode and review in Review mode. Every segment was unique in the project so it wasn't possible that first instance of a segment was fixed while another instance was not fixed.

This kind of behaviour is a great example how SDL has created a CAT tool for professionals which doesn't perform consistently. Consistency is the key driving factor of any translator's work philosophy. Workarounds are not enough.

Would you tell your customer that ”Yeah, the translation I gave you is not in English as requested, but in German instead BUT you can use a dictionary to decipher it yourself! Technically speaking the message is still the same.”


Direct link Reply with quote
 

icylave  Identity Verified
China
Local time: 08:46
Member (2013)
Chinese to English
+ ...
Met the same problem, unresovled yet Apr 2, 2013

Gilles Bronchart wrote:

Hi there,

Does anyone have news regarding the fact that Studio will always add translations to the TM instead of overwriting them when processing a batch task (Update main TM), even if the option "Always add new translation" is NOT checked?

Thanks a lot in advance for your feedback.


That's sad. No solution is found yet.


Direct link Reply with quote
 

Karen Zeng  Identity Verified
China
Local time: 08:46
Member (2014)
English to Chinese
+ ...
I have the same problem Oct 3, 2013

Uta Kappler wrote:

I cannot figure out how to prevent SDL Trados 2009 from adding a new segment to the TM every time I enter a change to a segment that already exists. I need to enter review changes, and instead of updating the segments, Trados just keeps adding additional segments. My client and I do NOT want duplicate source segments in the TM since this creates leverage issues for our projects.

The checkbox "Always add new translation to the translation memory" is NOT selected in the Project Settings. Not sure what this checkbox actually does or is supposed to do.

Can someone please give me a hint what settings I need to change to avoid this behaviour of creating duplicate English segments with different translations in the TM? I have tried to update the project TM and the Master TM seperately, all this to no avail. I just want to overwrite the TM segments with my review changes.

This is urgent, since there is of course a deadline for the job.

Thanks a lot in advance for your help!

Uta


Direct link Reply with quote
 

Uta Kappler  Identity Verified
United States
Local time: 17:46
Member (2008)
English to German
+ ...
TOPIC STARTER
Update Oct 5, 2013

It has been a while, but I noticed a real improvement with the update to SP3 for Studio 2009. However, I have upgraded to 2011 a while ago and use 2009 less often.

The way I "resolved" the issue for the client on my end, if I remember it correctly, was to put in extra work to go through the TM searching for duplicates and deleting the unwanted ones. Not a time saving or safe approach, and I only did this once for this particular client project.

For highly leveraged projects, there is always a chance, that there are segments which have been touched/edited several times and not overwritten, but rather added, and the matching logic might just pull that wrong high fuzzy match for you. I made it a habit to only update the main/master TM file once when I am fully done with all translation/review tasks for one package rather than writing files several times into the main TM.

I know this did/does not solve the issue. But since I was notified about the recent posts, I at least wanted to let you know that -- no -- I have not found the reason/safe 100% solution for this issue yet.


Direct link Reply with quote
 

Karen Zeng  Identity Verified
China
Local time: 08:46
Member (2014)
English to Chinese
+ ...
SDL needs to improve their TM technology! Oct 6, 2013

Uta Kappler wrote:

It has been a while, but I noticed a real improvement with the update to SP3 for Studio 2009. However, I have upgraded to 2011 a while ago and use 2009 less often.

The way I "resolved" the issue for the client on my end, if I remember it correctly, was to put in extra work to go through the TM searching for duplicates and deleting the unwanted ones. Not a time saving or safe approach, and I only did this once for this particular client project.

For highly leveraged projects, there is always a chance, that there are segments which have been touched/edited several times and not overwritten, but rather added, and the matching logic might just pull that wrong high fuzzy match for you. I made it a habit to only update the main/master TM file once when I am fully done with all translation/review tasks for one package rather than writing files several times into the main TM.

I know this did/does not solve the issue. But since I was notified about the recent posts, I at least wanted to let you know that -- no -- I have not found the reason/safe 100% solution for this issue yet.


Got it. Thanks. I use Studio 2011. The problem remains.


Direct link Reply with quote
 

icylave  Identity Verified
China
Local time: 08:46
Member (2013)
Chinese to English
+ ...
I cannot agree with you more! Feb 13, 2014

Karen Zeng wrote:

Uta Kappler wrote:

It has been a while, but I noticed a real improvement with the update to SP3 for Studio 2009. However, I have upgraded to 2011 a while ago and use 2009 less often.

The way I "resolved" the issue for the client on my end, if I remember it correctly, was to put in extra work to go through the TM searching for duplicates and deleting the unwanted ones. Not a time saving or safe approach, and I only did this once for this particular client project.

For highly leveraged projects, there is always a chance, that there are segments which have been touched/edited several times and not overwritten, but rather added, and the matching logic might just pull that wrong high fuzzy match for you. I made it a habit to only update the main/master TM file once when I am fully done with all translation/review tasks for one package rather than writing files several times into the main TM.

I know this did/does not solve the issue. But since I was notified about the recent posts, I at least wanted to let you know that -- no -- I have not found the reason/safe 100% solution for this issue yet.


Got it. Thanks. I use Studio 2011. The problem remains.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 01:46
English
Given you have raised this again... Feb 13, 2014

... perhaps we can have some concrete examples of where the problem lies? I don’t think this just happens, or that the software is doing something here that is out of your control.

I’d be very happy to look at whatever is causing you a problem so we can work on the resolution... whatever that may be.

Regards

Paul


Direct link Reply with quote
 

viking modena  Identity Verified
Italy
Local time: 01:46
Member (2012)
Swedish to Italian
+ ...
Same problem here Feb 13, 2014

Hi
I also noticed the same problem. I checked a file and approved some segments. Then we did more changes. When we at the end made "update main", new segments were added, that DID NOT OVERWRITE the previous ones.
I have done some "cleaning" in memory as I cross through these things.. mainly checking what DAY and HOUR segments were added, so I remove the older one!
I can send some examples when I get to it next time. I've done some checks now and I cannot find any example right now (cleaned too well?)
To whom/what shall I send?

Luca


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 01:46
English
Send it to... Feb 13, 2014

... pfilkin@sdl.com

I won't respond for a while as I just boarded a plane. But I will look at this tomorrow.

Regards

Paul


Direct link Reply with quote
 

Pablo Mones  Identity Verified
Uruguay
Local time: 21:46
Member (2008)
English to Spanish
Same problem Mar 7, 2014

Hi, I am using Studio 2014 and I have the same problem. That's quite troublesome, particularly when you are working with another translator and you have to exchange your TM exports daily.

Hope SDL will solve some day solve this problem.

Best.

Pablo


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

SDL Trados 2009 - TM segments not updated, but added

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search