Unexpected exception -- and Trados won't open
Thread poster: xxxMarkAlexande
xxxMarkAlexande
Local time: 21:59
Jun 14, 2010

Hi --

I'm afraid I'm at a standstill in my work tonight. After changing the background color option a few times using the Options|Colors menu, Trados Studio 2009 showed an error box and refused to change the color. I then closed the program (normally) in real-time, thinking this might cure the problem.

But Trados will no longer re-open at all. Instead, it throws up a notification box which says:

"Unexpected exception when getting view part instance of view part Translation Results". That's it. Nothing further. Obviously, something has gotten corrupted somewhere. If anyone knows how to get the program working again – so I can start working again – I'd be grateful. The full error dump is as follows:

-
Unexpected exception when getting view part instance of view part Translation Results
-
Sdl.Desktop.Platform.StudioException, Sdl.Desktop.Platform, Version=1.1.0.0, Culture=neutral, PublicKeyToken=c28cdb26c445c888

Sdl.Desktop.Platform
-
-

-
System.Reflection.TargetInvocationException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

mscorlib
-
-

-
System.ArgumentException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089


System.Windows.Forms
-
-




-
SDL Trados Studio
9.1.0.0
9.1.1264.0
Microsoft Windows XP Professional
Service Pack 2
1033
1250
WORK\Mark
2.0.50727.3053
WORK
True
2095532 MB



Thanks.

Mark.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 21:59
English
Try this Jun 15, 2010

Hi Mark,

Can you try deleting the following files in C:\Documents and Settings\\Application Data\SDL\SDL Trados Studio\9.1.0.0 and restart. If you are using Vista or W7 it will be C:\Users\\AppData\Roaming\SDL\SDL Trados Studio\9.1.0.0\.

BaseSettings.xml
plugincache.xml
UserSettings.xml

They will be recreated and it may help. There is a KB on this here - http://kb.sdl.com/article.aspx?article=3062&p=1 - and although the error message is not the same this does tend to fix a few sins.

Regards

Paul


Direct link Reply with quote
 
xxxMarkAlexande
Local time: 21:59
TOPIC STARTER
Thanks Paul, I ended up sniffing the files out Jun 15, 2010

...by myself last night. I tried to poke through the XML but...nah. Then just deleted UserSettings.xml and BaseSettings.xml and Studio re-created them, as hoped. I lost my font and color preferences but other than that everything seems to be intact, so not too much blood lost as it turns out.

Thanks for your help.

Mark.


Direct link Reply with quote
 

Malcolm Smith  Identity Verified
Germany
Local time: 21:59
German to English
+ ...
Thanks for this Dec 13, 2010

After updating to SP3, Trados refused to do load - renaming these files did the trick. Thanks

Malcolm


Direct link Reply with quote
 

Shang
China
Local time: 04:59
English to Chinese
I encounter the same problem Mar 7, 2011

I can't open SDL Trados Studio 2009 after upgrading to SP3. This following is the error message:

-
Unexpected exception when getting view part instance of view part Translation Results
-
Sdl.Desktop.Platform.StudioException, Sdl.Desktop.Platform, Version=1.1.0.0, Culture=neutral, PublicKeyToken=c28cdb26c445c888

Sdl.Desktop.Platform
-
-

-
System.Reflection.TargetInvocationException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

mscorlib
-
-

-
System.Runtime.Serialization.SerializationException, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089

System.Runtime.Serialization
-
-




-
SDL Trados Studio
9.1.0.0
9.1.2261.3
Microsoft Windows XP Home Edition
Service Pack 3
2052
936
EDMUNDSHANG\Owner
2.0.50727.3082
EDMUNDSHANG
True
2078756 MB



The following user specific profiles don't exist in C:\Documents and Settings\All Users\Application Data\SDL\SDL Trados Studio\9.1.0.0 folder:

BaseSettings.xml
plugincache.xml
UserSettings.xml

Only LastRunEdition.xml is found:


Freelance

Even if this file is remarked out the application can't start.

Thank you in advance.

Edmund


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 21:59
English
Repair your installation Mar 7, 2011

Dear Shang,

If you do not find these 3 files on your installation, and you are sure they are not hidden (please refer to KB article #3330 - http://kb.sdl.com/article.aspx?article=3330&p=1), then I would advise to run a repair of your installation.

For that, go to Start > Control Panel > Add or Remove Programs > SDL Trados Studio 2009 SP3 > click on the link "Click here for Support information" > click the "Repair" button.

Best regards,
Judith
SDL Support


Direct link Reply with quote
 
Milan Hudecek
Local time: 21:59
English to Slovak
+ ...
Exactly the same here as with Shang... Mar 11, 2011

I tried your advice, Judith, but no success. After "Loading Editor Views", I got the error message mentioned in the first post and there is only LastRunEdition.xml in the 9.1.1.0 directory.
Many thanks in advance for your help...
Milan

[Edited at 2011-03-13 07:26 GMT]


Direct link Reply with quote
 
Sans Frontieres
Japan
Local time: 05:59
I'd also had the same problem, but finally found the three files. Oct 14, 2011

Dear Milan and Shang,

Why don't you go to
C:\Documents and Settings\User Name\Application Data\SDL\SDL Trados Studio\9.1.0.0
instead of
C:\Documents and Settings\All Users\Application Data\SDL\SDL Trados Studio\9.1.0.0
then
I hope you will find the three files (BaseSettings.xml, plugincache.xml, and UserSettings.xml) to delete.

It seems that deleting these files reset the application and put it back to the factory settings.

Tae Miyazaki, Sans Frontieres. Co. Ltd.


Direct link Reply with quote
 

David Goward  Identity Verified
France
Local time: 21:59
French to English
Font tags disappeared Nov 3, 2011

This morning, I experienced the problem discussed here and deleted the three files mentioned earlier in the thread.

Unfortunately, I now have the situation where many of the font tags within the segments have disappeared (they were there yesterday). I have tried reinstalling SP3 and reopening the original project file sent by the customer but to no avail.

FWIW, the file for translation was generated from InDesign.

I'd be most grateful for any suggestions.

Best regards
David


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 21:59
English
Custom settings maybe... Nov 3, 2011

Hi,

When you deleted the three files you may have lost settings that were in place to show or hide certain things. If they were in the file before then they must be there now.

Try pressing Ctrl+Shift +H when you are in the Editor View... could be you just turned this off. This activates the button on the top right next to the four blue diamonds (well, only one is a diamond the rest are hexagons, but they are all blue).

You could also check in Tools - Options - Editor - Formatting Display Style as you may be hiding formatting tags.

Regards

Paul


Direct link Reply with quote
 

AMATraduction
Local time: 21:59
English to French
+ ...
Cannot open SDL Trados Studio 2011 Oct 1, 2013

Hi everyone,

I know this subject is old now, and I use 2011 and not 2009 as the other members, but I have exactly the same problem and the same message. I cannot open Trados.

The thing is, I tried to delete these three files. First, I could not find them under C:\Users\...\AppData\Roaming\SDL\SDL Trados Studio, but under SDL MuliTerm. By the way, I can't open MultiTerm either...

I deleted the files and tried to restart Studio (and MultiTerm), but it does not work.

I was wondering if you know any other solution... I tried to go to the Control Panel to repair the software, but the only option I have is uninstalling it.

I am afraid it might delete all my termbases (stored on a separate folder in My Documents), and I fear facing installation issues (will I be able to reuse my licence activation ID, since it has not been unactivated before the uninstallation??)

I have to precise I did not install anything new on my computer since I last use Trados.

Well, any idea would be welcome here!!

Thanks a lot in advance for your help!

Audrey

(Trados Studio 2011 SP3
Windows 7 64bits)


Direct link Reply with quote
 

Elke Fehling  Identity Verified
Local time: 21:59
English to German
+ ...
Same problem solved Apr 10, 2014

In case that helps:

I had the same problem yesterday with Studio 2011. I tried to find a solution the whole day. I installed and uninstalled Trados 2011 at least 10 times. After a while I found out that Trados kept asking for translation memory I had removed, even though I had installed a completely new version and deleted all unnecessary dlls...

Trados support was non existant. They asked me to upgrade to Studio 2014, that would allow me to buy support. They obviously don't support Studio 2011 anymore. I also didn't find a solution in the knowledge base. Buying 2014 is no option, most of my clients don't even yet work with Studio 2009. Why is that so? They seem to think they have a monopoly (and actually, they do?!, all my clients require me to work with Trados!), so they can afford to simply not support their software (and their clients)...

The solution - after 10 hours of research or so - was easy. I simply deleted the 3 xml files (usercache, basesettings, usersettings) from following directory:
C:\Users\Elkisch\AppData\Roaming\SDL\SDL Trados Studio\10.0.0.0
Trados regenerated the xml files, all that was lost were my preference settings (annoying, but not as annoying as not being able to work).

I tried to find these files on my backup system (just out of pure curiosity), it's a laptop with Windows XP. I couldn't find them. I just hope the problem doesn't occur there.

Elke


Direct link Reply with quote
 
A. R. Raman
Singapore
Member (2008)
German to English
+ ...
Hello Elke Nov 24, 2015

I tried the solution you mention but in my case its not working. I have reinstalled Studio 2014 5-6 times. But still same issue. I even deleted all the trados related folders from Program files and APPData (locak and roaming). Now I also notice whenever I try to open Studio a log is generated in AppData/ Local... saying

"Studio - Checking License Requirements"

I am not sure what this is. I didnt format my PC or touch anything to do with license.

Would appreciate any input on this from anyone.

Regards


Direct link Reply with quote
 
Eva Rodríguez
Local time: 21:59
English to Spanish
+ ...
Cannot open SDL Trados Studio 2015 projects Dec 20, 2016

Hi,

I get the same error message: "Unexpected exception when getting view part instance of view part Translation Results"

I tried to follow these instructions: http://kb.sdl.com/#tab:homeTab:crumb:7:artId:3559

A. I could not find these files:

Sdl.Enterprise.CredentialProvider.xml
Sdl.Enterprise.ServerConnectionManager.xml
Sdl.ProjectApi.CustomCredentialProvider.xml

B. I did find and delete these:
BaseSettings.xml
Plugincache.xml
UserSettings.xml

Error persists. Any suggestions?

Regards,

Eva

[Editado a las 2016-12-20 10:32 GMT]


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Unexpected exception -- and Trados won't open

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search