https://www.proz.com/forum/sdl_trados_support/175496-tm_wont_update_during_translation_studio_2009.html

Pages in topic:   [1 2] >
TM won't update during translation (Studio 2009)
Thread poster: Djamila_Vilcsko

Djamila_Vilcsko  Identity Verified
Germany
Local time: 08:13
Member (2009)
English to German
Jul 13, 2010

Hi,

I tried to find out whether this problem was posted before but I didn't have any success...

My problem is the following:
I work in Studio 2009 (with nice and new TM created) and only the very first version of my translation will be saved to the TM (even the silly suggestions from automatic google translations). I can edit my translation whatever I want, it just won't be saved in the TM and next time, I go through my text, it shows me the old, faulty translatio
... See more
Hi,

I tried to find out whether this problem was posted before but I didn't have any success...

My problem is the following:
I work in Studio 2009 (with nice and new TM created) and only the very first version of my translation will be saved to the TM (even the silly suggestions from automatic google translations). I can edit my translation whatever I want, it just won't be saved in the TM and next time, I go through my text, it shows me the old, faulty translation.
I have checked "update" in the TM options, so what am I still missing?
I have mainly worked with Trados 2007 so far and I have never had this problem there. Studio 2009 seems to have the nicer interface but that's no help to me when my TM isn't updated.

Thanks for your help!

Djamila
Collapse


 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:13
Member (2003)
Polish to German
+ ...
How do you go through your translation? Jul 13, 2010

Do you open the bilingual file again via "Open file" dialog and chose the tm or do you reopen the file from the files view?

 

Djamila_Vilcsko  Identity Verified
Germany
Local time: 08:13
Member (2009)
English to German
TOPIC STARTER
doesn't make a difference Jul 13, 2010

I think so far I always went to the "open file" dialog. Since you asked this question, I figured it might make a difference if I picked the file from the files view.
Doesn't seem to make a difference though. The TM still won't accept my edited translation.

Thanks for your help!


 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:13
Member (2003)
Polish to German
+ ...
Well, it should Jul 13, 2010

because I think you prepared the file with a project translation memory. This would only be available when opening the file as would it be a project, which means always opening from file view. BTW, this is in fact the only proper way to reopen the file which has been already in work, otherwise you are keeping creating projects and will lose track of what has been done where.
Are you really certain, that your translation memory configuration includes the "Update TM" setting for that particu
... See more
because I think you prepared the file with a project translation memory. This would only be available when opening the file as would it be a project, which means always opening from file view. BTW, this is in fact the only proper way to reopen the file which has been already in work, otherwise you are keeping creating projects and will lose track of what has been done where.
Are you really certain, that your translation memory configuration includes the "Update TM" setting for that particular TM you need? Did you try to use the batch task "Update main TM" with the bilingual file?
TBH, I do never use "Open file" for work - I always create projects, even for the smallest file I do have to translate. This way all operations are always the same and I have always a project TM and so on. It makes my life easier and I would recommend this method to everyone using Studio - it allows you to keep track of evertyhing what happens and is more logical to me.
Collapse


 

Djamila_Vilcsko  Identity Verified
Germany
Local time: 08:13
Member (2009)
English to German
TOPIC STARTER
You're right - it works Jul 14, 2010

Hi Jerzy,

I feel a bit like an idiot after I realised what my mistake was...in my defense, I haven't worked much with Studio 2009 yet...

I tried your suggestions and it still didn't update the TM. I then went into the help files to find out what "batch processes" are and discovered rather by accident that only segments with a certain status are updated. All my segments had "draft" status and were therefore not updated at all.

This is completely different co
... See more
Hi Jerzy,

I feel a bit like an idiot after I realised what my mistake was...in my defense, I haven't worked much with Studio 2009 yet...

I tried your suggestions and it still didn't update the TM. I then went into the help files to find out what "batch processes" are and discovered rather by accident that only segments with a certain status are updated. All my segments had "draft" status and were therefore not updated at all.

This is completely different compared to Trados 2007, wordfast or SDLX and I wasn't even aware that one needs to confirm one's own translation before it's included in the TM. It seems very unlogical to me that a suggestion from google translations is included in the TM right away while my alteration (i.e. a definite improvement of the machine translation) is NOT automatically included in the TM. Instead, I need to confirm my own translation so that it finally replaces the AT phrase. Maybe, there is some good reason for doing it this way but it really doesn't make sense at first sight.

Anyway, I know now and I really appreciate your help.

Best,
Djamila
Collapse


 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:13
Member (2003)
Polish to German
+ ...
Remember "Set/close next open get" from T2007? Jul 14, 2010

When you translate "Set/close next open get" you will see, that confirming your translation is not illogical as you say. Not at all - "set" means to save the translation in TM, "close" to close that segment, "next open" opens the next one and "get" reads the translation in TM.
When you work in Studio there is no close and open, but you still need to use "set", while "get" is performed automatically.
The segment status as it is now present in Studio is a huge advantage to what we know
... See more
When you translate "Set/close next open get" you will see, that confirming your translation is not illogical as you say. Not at all - "set" means to save the translation in TM, "close" to close that segment, "next open" opens the next one and "get" reads the translation in TM.
When you work in Studio there is no close and open, but you still need to use "set", while "get" is performed automatically.
The segment status as it is now present in Studio is a huge advantage to what we know from T2007.
BTW, if you would just observe what happens in "Translation results window" when you type your translation (or modify the suggestion) - exactly, NOTHING! How should there be something happening? If the translation memory engine would follow every keystroke you do, you would need not just a CoreQuad processor, but most probably several such and wouldn't be even able to pay for such a computer.
ALL CAT tools I know work like that: you get a no match siutation or a suggestion from the TM, then the user enters the correct translation and informs the TM engine by a certain command, that she/he is ready and the translation is to be stored in TM. Without this command (however you call it) nothing is stored there. As simple as this.
Collapse


 

Djamila_Vilcsko  Identity Verified
Germany
Local time: 08:13
Member (2009)
English to German
TOPIC STARTER
Yes, I remember... Jul 14, 2010

I guess, it just happens so automatically in Trados 2007, I was only half aware I wasn't just giving a command to open the next segment but also to save the current segment in the TM. And when I think about it, there is a special update function in SDLX and one needs to confirm translations...The confirmation just happens so automatically (press enter and go to next segment) that it's easy to take it for granted.

It still doesn't make sense though that AT suggestions are immediately
... See more
I guess, it just happens so automatically in Trados 2007, I was only half aware I wasn't just giving a command to open the next segment but also to save the current segment in the TM. And when I think about it, there is a special update function in SDLX and one needs to confirm translations...The confirmation just happens so automatically (press enter and go to next segment) that it's easy to take it for granted.

It still doesn't make sense though that AT suggestions are immediately stored in the TM and do not need to be confirmed by the translator.
Collapse


 

Emma Goldsmith  Identity Verified
Spain
Local time: 08:13
Member (2010)
Spanish to English
google doesn't go into your TM Jul 14, 2010

Djamila_Vilcsko wrote:

It seems very unlogical to me that a suggestion from google translations is included in the TM right away while my alteration (i.e. a definite improvement of the machine translation) is NOT automatically included in the TM.


Suggestions from Google are not included in your TM right away. In fact they never get added to your TM unless you enter them in a segment and confirm that segment. That's the last thing you would want, isn't it, to have Google's efforts sent to your TM

What you see in the Translation Results window is what Studio has found when it consulted Google Translate (if you have enabled this) and any matches it has found in your TM(s).


 

Djamila_Vilcsko  Identity Verified
Germany
Local time: 08:13
Member (2009)
English to German
TOPIC STARTER
duh! Jul 14, 2010

oh boy, I am really a greenhorn when it comes to Studio 2009!
This makes sense! It's not the TM, it's just the suggestion that shows up automatically...duh!
Thanks for telling me. Obviously couldn't think of it myself.


 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:13
Member (2003)
Polish to German
+ ...
Make your mind free Jul 14, 2010

Observe what happens on your screen, forget the old habits.
Notice the middle column in Side-by-Side Editor and check which status has which symbol. Right click on a segment and chose "Change segment status" - you'll there is much more than just plain translated. And exactly that makes it so powerful.
So again - you did confirm the segment in Trados2007 by ALT+(NUM+) or ALT+* (or cloesd it by ALT+END). In SDLX you had to press Enter (really, I think it was CTRL+ENTER).
In Studi
... See more
Observe what happens on your screen, forget the old habits.
Notice the middle column in Side-by-Side Editor and check which status has which symbol. Right click on a segment and chose "Change segment status" - you'll there is much more than just plain translated. And exactly that makes it so powerful.
So again - you did confirm the segment in Trados2007 by ALT+(NUM+) or ALT+* (or cloesd it by ALT+END). In SDLX you had to press Enter (really, I think it was CTRL+ENTER).
In Studio with default profile you press CTRL+ENTER too, and if you've chosen the SLD Trados profile while installing you press... guess what.... CTRL+(NUM+) - puzzled? But it works like that.

Imagine this: you are a translator who never heard about a CAT tool. But this guy gets an Excel file for translation (or a w Word table, makes no difference). The task is to enter the translation in that empty cells beside the source cells. So he's working. How does he get to the next cell? Well - obviously he needs to press tab, enter or arrow keys, but whatever it would be the only change when you move to Studio is, that you also have to press a certain shortcut to get to the next cell. Instead of pressing something press the one which confirms translation. I think this is the easiest way to explain how Studio works (just in terms of plain translating) - and until now I did not have problems with someone not understanding that during a training. When I compare that to what you call "he confirmation just happens so automatically (press enter and go to next segment) that it's easy to take it for granted." so I must say, that it may appear to be granted to you, but it took me ages to get people to understand that...
Collapse


 

hhl
Local time: 08:13
English to German
TM update, Project TM, Multiple TMs Jul 14, 2010

Just a short reminder, even though it may not hit the point in this case ...

* Studio will not update the Master TM during translation (by confirming a segment), if you use (or allow) Project TMs (i.e. you have automatically created a Project TM during Batch preparation, choosing this Batch option accidentially). In this case only the Project TM in the Project\TM subdirectory will be updated. If you load another translation later, the Master TM won't show you expected matches from y
... See more
Just a short reminder, even though it may not hit the point in this case ...

* Studio will not update the Master TM during translation (by confirming a segment), if you use (or allow) Project TMs (i.e. you have automatically created a Project TM during Batch preparation, choosing this Batch option accidentially). In this case only the Project TM in the Project\TM subdirectory will be updated. If you load another translation later, the Master TM won't show you expected matches from your recent translation.

* When using multiple TMs with one selected for update, others for reference, AND these TMs are defined with not identical "fields", then Studio might have problems with updating the Master TM upon confirming a segment.

[Bearbeitet am 2010-07-14 17:41 GMT]
Collapse


 

Tomi Dobaj  Identity Verified
Slovenia
Local time: 08:13
Member (2007)
English to Slovenian
+ ...
Same problem Sep 20, 2010

I only noticed it now when I am in a huge project, mostly pretranslated by a monkey-filled TM.

I have always confirmed my translations (I open files with Open file...), but the TM doesn't pick them up.

HHL, where exactly are the settings which allow to enable/disable project TMs?

Cheers!


 

Mihai Badea (X)  Identity Verified
Luxembourg
Member (2004)
English to Romanian
+ ...
Project Settings Sep 20, 2010

Hi Tomi,

In order to enable/disable translation memories, you have to go to Project > Project Settings.

Here is a screenshot:



Uploaded with ... See more
Hi Tomi,

In order to enable/disable translation memories, you have to go to Project > Project Settings.

Here is a screenshot:



Uploaded with ImageShack.us
Collapse


 

Tomi Dobaj  Identity Verified
Slovenia
Local time: 08:13
Member (2007)
English to Slovenian
+ ...
Project TM vs Master TM Sep 20, 2010

Thanks for your reply Mihai!

HHL was mentioning something about not enabling (new) project TMs creation, so you could use the master TM directly and update it directly as well.

I cannot find any such options under TM settings, do you know by any chance how to enable direct updating of the master TM (even after overwriting 100% matches)?


Cheers
T.


 

Mihai Badea (X)  Identity Verified
Luxembourg
Member (2004)
English to Romanian
+ ...
Project TM vs Master TM Sep 20, 2010

If you take a look at my screenshot, you'll see two TMs. Let's say the first is the project TM and the second is the master TM. Under the "Update" column you can tick the appropriate box(es) depending on which TM(s) you want to update.

 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

TM won't update during translation (Studio 2009)

Advanced search


Translation news related to SDL Trados





Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
WordFinder Unlimited
For clarity and excellence

WordFinder is the leading dictionary service that gives you the words you want anywhere, anytime. Access 260+ dictionaries from the world's leading dictionary publishers in virtually any device. Find the right word anywhere, anytime - online or offline.

More info »