Pages in topic:   [1 2] >
Trados2009 DragDrop registration did not succeed
Thread poster: Binnur Tuncel van Pomeren

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
Jul 26, 2010

Dear all,

Hello from the trados 2009 error-tired people's platform!!

Some of you may know the problem, you may even know me as this is not the first problem I have had with Trados, and sofar I have unfortunately the feeling this will not be the last time I will seek for an assistance.

My computer runs on Windows XP, with Microsoft 2003 packages.
I have been working lately on a very big xml file. I was about to complete the translation, when the system crashed down.

When I retried to open it:
---------------

Here what showed up: Microsoft. NET framework:
Unhandled exception has occured........
DragDrop registration did not succeed

The AllowDrop property is set to true but the AppartmentState of the current thread does not support drag drop. To enable dragdrop functionality set the 'Allow Drop' property to false. To enable drag drop functuonality you must set the ApartmentState of the thread. This can also be accomplished by puutting the [STAThread] attribute on your 'Main' method.
---
Is there anybody who can uncipher this?

Me not!

And I will appreciate, if any knowledgeable person can assist me!

Best and dearest regards to all!


[Edited at 2010-07-26 21:13 GMT]

[Edited at 2010-07-26 21:13 GMT]

[Edited at 2010-07-27 14:56 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 04:05
English
A suggestion Jul 27, 2010

Hi Binnur,

This is not an error I have seen before, so this may have been corrupted as a result of the crash.

If you were using a Project then you could try copying the untranslated SDLXLIFF file in your source language folder to the target language folder. Then open the file again and run the “Translate” batch task to repopulate the translation.

If you were not using a Project then open the source file for translation again, save it, and then run the "Translate" batch task against the same Translation Memory you were using to repopulate the translation.

Hopefully this will get you up and running where you left off.

Regards

Paul


Direct link Reply with quote
 

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
TOPIC STARTER
Could you please explain it a bit mor clearly Jul 27, 2010

Dear Paul,

Thank you very much for your help.

However, as a result of this crash, I was busy manually putting my TM's from one file to another. (I am still not done with it). The most important, as I have not slept for more than 24 hours now, I would be happy if you could use a flow chart scheme, so that I follow every steps you say.

Is it feasible? Thank you very much then.

I really look forward to your comments!

Best regards,

Binnur

[Edited at 2010-07-27 11:06 GMT]

[Edited at 2010-07-27 11:08 GMT]


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 04:05
English
No problem Jul 27, 2010

Hi Binnur,

Can you tell me how you created your translation in the first place. Did you use Open Document, or did you create a Project?

Then I'll give you some easier (I hope) steps to follow.

Regards

Paul


Direct link Reply with quote
 

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
TOPIC STARTER
In two ways Jul 27, 2010

Hi Paul,

The partial problem has been resolved: I mean, I now have an access to Trados Studio.
But the second problem persists (This is basically, not being able to read the TM I built for a specific project (24000 words and I need it to deliver today!)

The first file, drectly from ttx file (originaly xml). The TM hereof cannot be read by the second file which is freshly prepared by my means from the xml file.

I did not see a way to make my TM work.

Do you have any suggestion?

Best regards,


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 04:05
English
A Project then. Jul 27, 2010

Hi Binnur,

Ok - I think I see what you mean. You created a project with at least 2 files, one ttx and one xml. The ttx is fine (or complete so you don't care) but the xml translation is incomplete and this you cannot open in the Project.

So, here's my suggestion.

Open the Project and go to the files view.

Change the language to your source language using the drop down menu here;


Now select the file you you cannot use (the xml) and delete it.

Now right-click in the area where the file was and select Add Files

Once the file is there right-click on the file and select Batch Tasks - Prepare (you could also use Prepare without Project TM depending on what you did the first time around)


When this is complete switch back to the Target language and open the file for translation. Hopefully it will all be there.

I hope this is clear and that I have interpreted your problem correctly?

Regards

Paul


Direct link Reply with quote
 

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
TOPIC STARTER
Paul! You are great! Jul 27, 2010

Dear Paul,

Thank you very much!

I have been already going around the ''TM repopulate'' in line with your first suggestion, and this suggestion has already created some wonder (yeah, anything after manual work of 6 hours is a small wonder).

I will bear all these suggestions in my mind and -when I am done with the project- in my notebook!

Thank you very much and till our next Trados posts

Binnur


Direct link Reply with quote
 

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
TOPIC STARTER
Resolution Jul 27, 2010

Hello collegues and Trados users,

Before I will close my thread, I wanted to inform you how the error (the core reason why I opened the post) has been resolved.

My real problem was the naughty error message along with Trados Studio. This prevented Trados Studio from being opened.

But, the error message accompanied .NET so, as always, I cleaned higher versions of .NET (from 2 on basically). That meansi, I've doubted that .NET was corrupted. It occurs often and I often think Trados is causing this.

As you may know Trados requires .NET modules to work properly. But during its installation, it is also releasing .NET. So, if you remove .NET and you reinstall your Trados (respectively Freelance 2007, Studio 2009 and then Multiterm), your problem will be solved...

(....temporarily, until another crash. Hopefully not within the same week.)


The second problem was after I was able to reopen the Trados Studio, but thanks to Paul, it is no longer a problem...

Keep well and till other posts...

[Edited at 2010-07-27 11:34 GMT]


Direct link Reply with quote
 
xxxGE1234567

Local time: 04:05
drag drop error, unable to open Studio 2009 Aug 22, 2010

Dear Binnur, dear SDL team,

I have the same problem as you Binnur and thank you very much for your detailed instructions (how to delete .NET and to reinstall Studio)!

However, Studio still refuses to open, with the same error message than before !!!!
(drag drop error, "The AllowDrop property is set to true but the AppartmentState of the current thread does not support drag drop. To enable dragdrop functionality set the 'Allow Drop' property to false. To enable drag drop functuonality you must set the ApartmentState of the thread. This can also be accomplished by puutting the [STAThread] attribute on your 'Main' method.")

I've tried the following, to no avail:
- to repair Studio, Passolo + Multiterm via the regluar Microsoft "delete/repair program" (start > ....)
- to delete .NET Framework 4 client profile + language pack German vie the regular Mircrosoft "delete/repair"
- to delete Studio &co and reinstall it

Nothing has worked so far on my computer (Eee, Windows starter 7, MS .NET Framework 4)

Any ideas how to repare this??

I would be very grateful if anybody could help me with this. It's been 2 weeks now and I cannot work without Studio...

Best regards,

Deike


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 04:05
French to German
+ ...
Looks like you need to call SDL support Aug 22, 2010

I would be very grateful if anybody could help me with this. It's been 2 weeks now and I cannot work without Studio...


Given the fact that the issue dos not seem to be one that can be solved easily without looking at your PC and that you are unable to work, I suggest that you request support from SDL by logging a case. If they cannot solve the problem on the phone, they will access your computer via remote support in order to fix your problem.

In order to do this, you need a support agreement. But if you compare the cost of the support agreement (20 % of the price of the SW) to the money you loose while you cannot use the software, this is absolutely worth it.

Walter


Direct link Reply with quote
 
xxxGE1234567

Local time: 04:05
quick and easy solution would be great (drag dorp error with Studio 2009 unable to open) Aug 22, 2010

Hi Walter,
Yes, I've considered this as well. I have the chance to "squat" a colleague's computer for the moment. But this is not a permanent solution, obviously.

Moreover, this is really the only problem I've ever had with Studio! Totally out of the blue!

As I'm not the only person with this problem, I'm hoping for some quick and more or less easy DIY-help by someone in this forum who is more experienced than I am.

Thank you so much in advance,

Deike


Direct link Reply with quote
 

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
TOPIC STARTER
I may have some answers. Aug 23, 2010

Hi Deike,

It can be useful to know the final error messages you are receiving...

When you will call me tomorrow, we will wipe the slate clean and start from the scratch with this removal and reinstalling before I will suggest another thing.

Best regards,


Direct link Reply with quote
 
xxxGE1234567

Local time: 04:05
drag drop error studio 2009 does not open Aug 23, 2010

Dear Binnur,

I'm very much looking forward to getting this sorted out tomorrow with your help - thank you so much in advance!

kind regards

Deike


Direct link Reply with quote
 
xxxGE1234567

Local time: 04:05
drag drop error studion 2009 freelance sp2 - RESOLVED Aug 28, 2010

After uncounted hours of trying and praying.....


Here is what got it going again for me (many many thanks goes to Binnur for her help!) :

1) uninstall :
- everything related to studio : Studio 2009, Trados 2007, Sdlx, passolo, muliterm
Before you do so, make a save copy of your projetcs, TM, alignments to a secure place like an external disc, but don't keep any parts of the program itself. To fully uninstall with registy entries, use e.g. Ccleaner (freeware : http://www.computerbild.de/download/CCleaner-929470.html). Afterwards do a quick check on your harddrive to find any folders called "SDL" or "Studio" or so and delet them.

- Microsoft .NET 4 (I work on Windows 7 starter edition) or anything higher than version 2. (When reinstalling Studio later, a clean .NET 3.5 sp1 is automatically installed )

- Java RE 6 latest update (When reinstalling Studio later, Java 2 RE 6 update is automatically installed again)

2) prevent updates:
in control panel < system < windows update < settings : "search updates but download + install manually"
I did this to prevent .NET 4 form being automatically installed on my computer as it might be part or source of the error

3)reinstall :
translation tools in this order : 1. Trados 2007 Freelance 2. Synergy 2007 3. SDLX 2007.
After installation, I tested all 3 and they worked fine.
4. Studio 2009 SP2 (which installs Passolo essentials sp9 automatically as well)
When opening Studio, be connected to the internet to get automatically the invitation to update from 1.2.0.0. to 1.2.2.0 and install

Results :
1) Trados 2007 Freelance + Synergy 2007 + SDLX 2007 + passolo : worked fine
2) Studio opened again (hurray!!!),
BUT the editor would not work: 2 error messages "Failed to initialize view 'Editor View'" and 2xml exception parsing XML doc from file [...] framework2 configuration xml"
-> delete BaseSettings.xml, plugincache.xml, UserSettings.xml (did not do the trick)
-> replace folder "type files" : see proz "Studio 2009 error at opening the Editor: "XmlException parsing XML Document from file" -> editor opens again.

Thanks again to Binnur and all others who posted their hints and solutions here!


Direct link Reply with quote
 

Binnur Tuncel van Pomeren  Identity Verified
Germany
Local time: 04:05
Member (2007)
English to Turkish
+ ...
TOPIC STARTER
Well done Deike Sep 10, 2010

Great Deike...

You worked out most of the problem by yourself.... I was not aware of any freeware as Ccleaner.

But I am happy my guidance brought up something...

Best regards and till next time.

Binnur


Direct link Reply with quote
 
Pages in topic:   [1 2] >


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados2009 DragDrop registration did not succeed

Advanced search







PerfectIt consistency checker
Faster Checking, Greater Accuracy

PerfectIt helps deliver error-free documents. It improves consistency, ensures quality and helps to enforce style guides. It’s a powerful tool for pro users, and comes with the assurance of a 30-day money back guarantee.

More info »
WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search