Inactive (grey) Apply Translation Next/Previous match buttons
Thread poster: Jo Macdonald

Jo Macdonald  Identity Verified
Spain
Local time: 18:43
Member (2005)
Italian to English
+ ...
Aug 7, 2010

Hi folks
I’ve just started using Studio and I’m getting inactive (grey) Apply Translation Next/Previous match buttons.

If I click on a translated segment (therefore 100% match in the TM) the translation appears in the TM window but the buttons are grey so it can’t be applied even if I change the target so it’s no longer a confirmed 100% match.
The only way to make the buttons (and keyboard shortcuts) active is to click on the number of the TM entry. This gives me an error message “Unsupported language direction” but then the buttons are active and I can apply the translation in the TM. I’ve tried using default settings – no change.
Any ideas?
Thanks
Jo

I’m using Trados Studio 2009 and Windows 7


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 18:43
French to German
+ ...
These buttons only appear if you have several matches Aug 8, 2010

Which buttons are grayed out? The two buttons "Select previous/next Match' are very often grayed out because they are only used in situations where the 'Translation results' window shows several matches for the current segment. In the case where you have only one match, they are grayed out, simply because there is nothing to select.

The 'Apply translation' button however should always be active. Normally, this button is also used only in situations where you have several matches, because otherwise you don't need it, Studio inserting the first match automatically into your target segment.

Walter


Direct link Reply with quote
 

Jo Macdonald  Identity Verified
Spain
Local time: 18:43
Member (2005)
Italian to English
+ ...
TOPIC STARTER
The 3 buttons Apply Translation, Next match and Previous match are grey. Aug 8, 2010

Hi Walter,
The restore source button is the only one of the four buttons that is active and useable. The only way I can get this to change is by clicking on the number of the match shown in the TM, with the above error message, and this is pretty time consuming compared to just hitting Ctl+T.


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 18:43
French to German
+ ...
'Apply Translation' is only required if the first match is not the right one Aug 8, 2010

The restore source button is the only one of the four buttons that is active and useable.


There is no 'Restore Source' in Studio. The fourth button is for 'Copy Source'.

... and this is pretty time consuming compared to just hitting Ctl+T


When do you need to hit CTRL-T? Only if you have several matches and the one that Studio filled into your target segment is not the one you want. This should not be the case too often. In all other situations you don't need this key (or button).

If the translation inserted into your target segment is the right one, you don't need to hit CTRL-T at all. I think that in the one year I am using Studio nearly daily, I have used CTRL-T only a few times.

So, I am not really sure what you are trying to achieve her.

Walter


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 18:43
Member (2010)
Spanish to English
“Unsupported language direction” Aug 8, 2010

Like Walter, I can't quite understand your problem. Can't you just click on Alt+1 to get the first result in your Translation Results window transferred to your target segment? (And Alt+2 for the second result, etc.)
If you can't, then your “Unsupported language direction” error message may be saying that there is something wrong with your language pairs. Have you checked in Tools-Options-Language Pairs that you have the right pair and the right direction, and that this matches your TM language pair?
(If you have created a project, check in Project settings>language pairs).


Direct link Reply with quote
 

Jo Macdonald  Identity Verified
Spain
Local time: 18:43
Member (2005)
Italian to English
+ ...
TOPIC STARTER
I only work in one language pair and in one direction Ita->Eng Aug 8, 2010

Hi Emma,
That’s the one in the TM and options. Alt+1 or 2 doesn’t change between TM entries. The only way to apply the TM entry to the segment is to click on the entry number, which generates the error message “Unsupported language direction” but after this the Apply Translation button becomes active and not just the 'Copy Source' button (thanks Walter).

I would have thought the Apply translation button would be inactive only if there was no match in the TM. I want to be able to choose and switch between TM entries and apply the most suitable. Haven’t got a way to do this quickly at the mo.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 18:43
Member (2010)
Spanish to English
A couple more questions then. Aug 8, 2010

Has the Translation Results window ever worked since you installed Studio?
Is the problem just with one file or with every file you open?
Are you working on a doc file or another file type?


Direct link Reply with quote
 

Jo Macdonald  Identity Verified
Spain
Local time: 18:43
Member (2005)
Italian to English
+ ...
TOPIC STARTER
I’m working on a Tageditor ttx Aug 8, 2010

Thanks for your help Emma.
Just tried opening a Word doc, same behaviour.
Had active buttons at start just after opening the doc, TM applies its best shot, can’t switch between TM entries with Alt+1/2. If I Copy source there’s no way to Apply Tm translation unless - click on TM entry number - error message etc.

Not sure if it’s always done this. I did change a few settings in Options, but then went back to default to try and sort this - no luck yet.

I might have unchecked the TM enabled boxes and then checked them again at one point to see if this made a difference. These boxes are now checked and in fact the prog does lookup the TM and apply its best match. I would like to be able to choose which to apply though.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 18:43
Member (2010)
Spanish to English
apply best match Aug 8, 2010

OK, one last idea before I give up on this mystery...
Have you tried disabling "apply best match after successful lookup" and then use alt+1/2?
(Options>Editor>Automation).
(If this were Kudoz I'd rate my confidence level at about 1 for this suggestion)


Direct link Reply with quote
 

Jo Macdonald  Identity Verified
Spain
Local time: 18:43
Member (2005)
Italian to English
+ ...
TOPIC STARTER
1 higher than mine at the mo :-) Aug 8, 2010

Tried that – no dice

Direct link Reply with quote
 

Javier Wasserzug  Identity Verified
United States
Local time: 09:43
English to Spanish
+ ...
APPLY TRANSLATION key Feb 13, 2016

Got here for this very same problem. Several matches and "apply translation key" disable or alt+T NOT working.
Restarted program and now is working fine.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Inactive (grey) Apply Translation Next/Previous match buttons

Advanced search







SDL MultiTerm 2017
Guarantee a unified, consistent and high-quality translation with terminology software by the industry leaders.

SDL MultiTerm 2017 allows translators to create one central location to store and manage multilingual terminology, and with SDL MultiTerm Extract 2017 you can automatically create term lists from your existing documentation to save time.

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search