Trados 2009: short and long terms in the active terminology recognition
Thread poster: Vipec

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
Aug 26, 2010

Hello everybody!

I own Studio Trados 2009.

Irrespective that since a couple of hours my active terminology recognition doesn't work at all, it has worked quite properly before but I've always been facing this bug:

1) short words of less than 3 letters (most abbreviations) aren't recognised automatically but if one searches them in the term base search field he finds them

2) long terms composed of more than (3, 4, 5 words?) aren't automatically recognised and you can find them in the termbase only if you insert only a *word* of them composing the saved term.

Is that normal or is my MuktiTerm 2009 not working properly?

Cheers
Vittorio


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 00:24
French to German
+ ...
Do the terms have a translation? Aug 26, 2010

Vipec wrote:
... I've always been facing this bug:

1) short words of less than 3 letters (most abbreviations) aren't recognised automatically but if one searches them in the term base search field he finds them ]


Do these terms have a translation in the target language used for that translation? If not, it is normal that you'll find them only through a search unless you check the option 'Show recognized terms with no available translation' (in Tools - Options - Language pairs - All Language Pairs - Termbases _ Search Settings'.

... long terms composed of more than (3, 4, 5 words?) aren't automatically recognised and you can find them in the termbase only if you insert only a *word* of them composing the saved term.


I have never seen this, but I am not sure I understand correctly what you mean by " if you insert only a *word* of them composing the saved term". Do you mean that you can find the entry only if you search on one single word but not if you type the whole term?

Walter


Direct link Reply with quote
 

PCovs
Denmark
Local time: 00:24
Member (2003)
English to Danish
+ ...
Capital letters and small letters Aug 26, 2010

I don't know if this is what you are experiencing, but recently I discovered that if I have entered a translation of a term with a capital letter (as first letter), this term will not be inserted in the text when writing, unless I capitalize the first letter when writing.

The same thing is true the other way around, and it is indeed a very annoying problem, because you would have to look at the termbase box all the time to see if there is indeed a match there to be inserted.


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 00:24
French to German
+ ...
This is AutoSuggest Aug 27, 2010

PCovs wrote:

I don't know if this is what you are experiencing, but recently I discovered that if I have entered a translation of a term with a capital letter (as first letter), this term will not be inserted in the text when writing, unless I capitalize the first letter when writing.

The same thing is true the other way around, and it is indeed a very annoying problem, because you would have to look at the termbase box all the time to see if there is indeed a match there to be inserted.


As you say "... inserted in the text by writing", I guess that you refer to the AutoSuggest function, which happens to also show recognized termbase entries when configured to do so, but which is a different feature than term recognition. I consider it a good thing that AutoSuggest is case sensitive, so it does not make a lot of inappropriate suggestions.

The red line marking above a term in the source segment should however appear regardless of case, so that you can insert the term using CTRL-SHIFT-L.

Walter


Direct link Reply with quote
 

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
TOPIC STARTER
These words have a translation which I saved in my termbase already Aug 27, 2010

[quote]Walter Blaser wrote:

Vipec wrote:
... I've always been facing this bug:

1) short words of less than 3 letters (most abbreviations) aren't recognised automatically but if one searches them in the term base search field he finds them ]


Do these terms have a translation in the target language used for that translation? If not, it is normal that you'll find them only through a search unless you check the option 'Show recognized terms with no available translation' (in Tools - Options - Language pairs - All Language Pairs - Termbases _ Search Settings'.

[quote]

Hello Walter,

first of all thank you for your patience and helpfulness.
These short words (for example "Abb","AAD", "BA" and so on) have of course a translation which I already added to my termbase. Sometimes I meet such an abbreviation and it's not recognised. I say to myself "you added it already". I search it in the termbase and this abbreviation is there but it wasn't recognised.
I know of course that the abbreviation I've saved has to be written exactly in the dame way in the source text in order to be recognised. For example, if I've saved "Abb" in my termbase, the abbreviation "Abb." in the source text will not be recognised as "Abb" and I get no translation from my active terminology recognition . I have to search the word as *Abb* in the termbase and I'll find it. But, of course, it will be no active terminology recognition at all.

Anyhow, now my whole active terminology recognition isn't working at all and this issue is secondary


Direct link Reply with quote
 

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
TOPIC STARTER
I mean if I search just a word composing the termbase (a termbase consisting of at least 3-4 words) Aug 27, 2010

long terms composed of more than (3, 4, 5 words?) aren't automatically recognised and you can find them in the termbase only if you insert only a *word* of them composing the saved term.


I have never seen this, but I am not sure I understand correctly what you mean by " if you insert only a *word* of them composing the saved term". Do you mean that you can find the entry only if you search on one single word but not if you type the whole term?

Walter[/quote]

For example, the termbase term, made up of 6 words, is: "Bayerisches Staatsministerium für Umwelt und Gesundheit".
Such a long term (typical of the German language) will not automatically recognised. The active term recognition worked never here. I don't know whether it's normal that it doesn't work in Trados and MultiTerm 2009 or there is a problem with my software.


What is more is that I don't find such a term ("Bayerisches Staatsministerium für Umwelt und Gesundheit") in the termbase where I saved it even if I search it and I write it exactly as it is saved in my termbase.
I find it only if I put it in the search field in one of these ways *Bayerisches* or *Staatsministerium* or *Gesundheit* or, maybe, *Bayerisches Staatsministerium*

What I mean is that, in this case of a term consisting of more words (probably more than 3 or 4) the ctive term recognition doesn't work BUT even the MultiTerm search feature doesn't work.


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 00:24
French to German
+ ...
All this works fine here Aug 27, 2010

To be sure, I just tested this with a sample document I created using exactly your Bavarian ministry and everything worked fine.

The term was recognized OK.

Walter


Direct link Reply with quote
 

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
TOPIC STARTER
@ PCovs: I agree but are you talking about autosuggestion? Aug 27, 2010



I don't know if this is what you are experiencing, but recently I discovered that if I have entered a translation of a term with a capital letter (as first letter), this term will not be inserted in the text when writing, unless I capitalize the first letter when writing.

The same thing is true the other way around, and it is indeed a very annoying problem, because you would have to look at the termbase box all the time to see if there is indeed a match there to be inserted.


I think to have faced such bag with active term recognition as - I think but I'm not sure- terms aren't actively recognised whether there's a difference in the initial capital letteral-
Ayhow, I'm not sure whether you're talking about active terminology recognition or Autosuggest function


Direct link Reply with quote
 

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
TOPIC STARTER
There must be a problem with my MultiTerm 2009? Aug 27, 2010

To be sure, I just tested this with a sample document I created using exactly your Bavarian ministry and everything worked fine.
The term was recognized OK.
Walter


Nice to hear that it should work. To tell the truth now my active terminology recognition still doesn't work (I tried to launch the .bat as Admi as well), but the search function works with this example
Yesterday it didn't!


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 00:24
French to Polish
+ ...
Multiterm algorithms Aug 27, 2010

Walter Blaser wrote:

Vipec wrote:
... I've always been facing this bug:


It's not a bug, it's a feature.

1) short words of less than 3 letters (most abbreviations) aren't recognised automatically but if one searches them in the term base search field he finds them ]

Do these terms have a translation in the target language used for that translation? If not, it is normal that you'll find them only through a search unless you check the option 'Show recognized terms with no available translation' (in Tools - Options - Language pairs - All Language Pairs - Termbases _ Search Settings'.


The Multiterm term recognition algorithms need at least 3 letters.
Unlike DVX, memoQ etc. Multiterm will never recognize 2 letters words or abreviations.
Nonetheless, the 3 letter words should work although the fuzzy recognition will be poor (all the 3 letters must match).

... long terms composed of more than (3, 4, 5 words?) aren't automatically recognised and you can find them in the termbase only if you insert only a *word* of them composing the saved term.


I have never seen this, but I am not sure I understand correctly what you mean by " if you insert only a *word* of them composing the saved term". Do you mean that you can find the entry only if you search on one single word but not if you type the whole term?

For this kind of multiword terms, the fuzzy term recognition may easily fail for heavily inflected languages.
You may lower the fuzzy recognition threshold and see if it works.
It should work in most cases but sometimes you'll never receive the expected suggestions.

Although the Muliterm multiword fuzzy matching algorithms were long time the best out of the box (now, Swordfish is also very, very good), they can't be configured and tuned in like the memoQ ones which are the most flexible now (e.g. you can force exact matches, several types of fuzzies, case recogniton at the lemma level).
And it simply works

Cheers
GG


Direct link Reply with quote
 

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
TOPIC STARTER
I had suspected it was a feature...Thank you for your clarification Aug 27, 2010

It's not a bug, it's a feature.


Hello Grzegorz,
Thank you very much for your clarification.
I had suspected it was a feature...

... long terms composed of more than (3, 4, 5 words?) aren't automatically recognised and you can find them in the termbase only if you insert only a *word* of them composing the saved term.



For this kind of multiword terms, the fuzzy term recognition may easily fail for heavily inflected languages.
You may lower the fuzzy recognition threshold and see if it works.
It should work in most cases but sometimes you'll never receive the expected suggestions.

Although the Muliterm multiword fuzzy matching algorithms were long time the best out of the box (now, Swordfish is also very, very good), they can't be configured and tuned in like the memoQ ones which are the most flexible now (e.g. you can force exact matches, several types of fuzzies, case recogniton at the lemma level).
And it simply works
Cheers
GG


I'll try to lower the fuzzy recognition threshold....

Cheers
Vittorio


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:24
Member (2003)
Polish to German
+ ...
For short acronyms/abbreviations use variables list Aug 27, 2010

For acronyms like AEG, IBM, SDL, IT and so on use variables list.
They will be automatically replaced, ie. in the sentence "This is an IT program" IT will be automatically replaced by IBM, whe the source reads "This is an IBM program".
Unfortunately MT will not recognize and help you translate abbreviations like "ie.", it indeed needs 3 letters.


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 00:24
French to Polish
+ ...
Variables feature limitation Aug 27, 2010

Jerzy Czopik wrote:

For acronyms like AEG, IBM, SDL, IT and so on use variables list.
They will be automatically replaced, ie. in the sentence "This is an IT program" IT will be automatically replaced by IBM, whe the source reads "This is an IBM program".
Unfortunately MT will not recognize and help you translate abbreviations like "ie.", it indeed needs 3 letters.

The variables feature make sense only if the source and target abbreviations don't differ.
In a lot of cases, it's not true and the terminology recognition should be used instead.

Cheers
GG


Direct link Reply with quote
 

Vipec  Identity Verified
Germany
Local time: 00:24
German to Italian
+ ...
TOPIC STARTER
Where do I find the variable list? Where do I set this setting? Aug 27, 2010

Jerzy Czopik wrote:

For acronyms like AEG, IBM, SDL, IT and so on use variables list.


Hello Jerzy,

Where do I find the variable list? Where do I set this setting?
Sorry for the silly question variables

thanks in advance
Vittorio


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 00:24
Member (2003)
Polish to German
+ ...
Translation memory view Aug 27, 2010

In the navigation pane you see a list of translation memories.
If there is no one, open the one in question with "Open TM" command.
Now this TM will be opened for review and maintenance.
This in fact not exactly what we need, so close the TM from maintenance.
It will however remain listed in the navigation pane.
Now right click on it, select properties (or settings, I don't remember the English name now).
Go to language resuorces there.
There you will find an abbreviations list and a variables list.
Fill the abbreviations and variables there as needed.
Please remember, that those lists are case sensitive. So if you need to have FIAT and Fiat recognized, both must be enetered in the variables list.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Trados 2009: short and long terms in the active terminology recognition

Advanced search







Wordfast Pro
Translation Memory Software for Any Platform

Exclusive discount for ProZ.com users! Save over 13% when purchasing Wordfast Pro through ProZ.com. Wordfast is the world's #1 provider of platform-independent Translation Memory software. Consistently ranked the most user-friendly and highest value

More info »
TM-Town
Manage your TMs and Terms ... and boost your translation business

Are you ready for something fresh in the industry? TM-Town is a unique new site for you -- the freelance translator -- to store, manage and share translation memories (TMs) and glossaries...and potentially meet new clients on the basis of your prior work.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search