This file contains more than one source and/or target language
Thread poster: Morten Narboe

Morten Narboe  Identity Verified
Local time: 08:45
English to Norwegian
+ ...
Sep 10, 2010

I'll try to be concise about this problem:


I open a file in TagEditor 2007, it opens without any problems. I then save it as TTX.
I open the resulting TTX file in Studio 2009, latest update, translate it, and save it back as TTX.
I open the resulting TTX file again in TagEditor, and get this message:

"This file contains more than one source and/or target language. The languages appearing last in the file will be used. Would you still like to open this file?"

I click Yes, and the file opens, but the problem appears to be that there is no target language at all. The UN flag is placed where my target language flag should be, and when inspecting the TTX file in Notepad, there's no target language. It has the following format:

Source textTarget text

I obviously can't use this file.


So my question is, is it possible to persuade Trados Studio 2009 to save a TTX file that is actually usable by TagEditor? My source and target languages appear correctly in Trados Studio.

For now, I have to ditch Studio yet again and just use TagEditor. I also have to re-do all the work I already did on that file.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 08:45
Member (2003)
Polish to German
+ ...
What was the source of TTX? Sep 10, 2010

This is really very strange...
Do you really save TTX from Studio?
Never have had something similar to that.
So let's start with the source format: what kind of file is it?


Direct link Reply with quote
 

Morten Narboe  Identity Verified
Local time: 08:45
English to Norwegian
+ ...
TOPIC STARTER
ABC Sep 10, 2010

Well, I just found out what was wrong.

This happens already in TagEditor. The problem occurs if I just open the XML file and save it as TTX. What I have to do is open it, then open the first segment, translate it, and THEN save the file as TTX (to get the target language registered). Otherwise Studio will save it back without target language (even though it correctly uses the target langauge itself).

Sorry about the trouble, I wasn't aware of this (or had forgotten) and it wasn't very obvious what had to be done.


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 08:45
French to German
+ ...
Does this happen with all XML files? Sep 12, 2010

Hi Morten

Did you have this problem only with one specific XML file or with different files? I ask because I never experienced this and just ran a test without being able to reproduce the problem.

Walter


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 08:45
French to Polish
+ ...
Bug... presegmenting TTX files... Sep 12, 2010

Walter Blaser wrote:

Did you have this problem only with one specific XML file or with different files?
I ask because I never experienced this and just ran a test without being able to reproduce the problem.

It's a well known Trados bug (or feature, as you like).
As Morten wrote:
when TagEditor generates TTX file, the TargetLanguage statement is empty in the header independently of the target language in the TM.
The target language is determined according to Workbench.
The target language related information is introduced in the file when the first segment is translated.
When you close both Workbench and TagEditor, then open the freshly generated file in TagEditor "stand alone", you'll see it cannot determine the target language itself and the UN flag is displayed if no segment was translated.

Probably Studio behaves in a similar way and is unable to create valid target information for not processed TTX files, at least in some special cases.

In fact, I don't care about this error, I simply "repair" the malformed TTX files using a decent text editor if really necessary (e.g. in some very rare cases, the file may contain multiple target language declarations).
Normally, in my CAT hopping procedures, the problem is solved automatically when I presegment TTX files in Workbench.
Probably Morten should presegment 'em too before importing to Studio

Cheers
GG


Direct link Reply with quote
 

Morten Narboe  Identity Verified
Local time: 08:45
English to Norwegian
+ ...
TOPIC STARTER
New problem... Sep 12, 2010

Thank you for your replies!

Althouth I can save TTX files correctly now, something else has happened. For the first 3 files I translated, term recognition worked just fine, but it has now simply stopped working, and I only get "No results available" every time. Manual termbase search from within Studio still works, and term recognition works in Trados 2007, but it simply won't automatically look up terms for me in Studio 2009. Why did it suddenly stop working? Is there some hotkey combination to turn it off I may have pressed by mistake? The term base is enabled and all settings look fine. I didn't make any changes to it when it decided to stop working anyway.

Restarting the software does nothing, removing and re-adding the term base does nothing.

So... is it back to manual term searches or using Trados 2007 for me? I'm desperately trying to finally squeeze value out of my Studio 2009 investment here (which isn't easy), so a solution would be welcome.


Direct link Reply with quote
 

Grzegorz Gryc  Identity Verified
Local time: 08:45
French to Polish
+ ...
Another well known bug... Sep 12, 2010

Morten Narboe wrote:

Althouth I can save TTX files correctly now, something else has happened.

The life with Trados is not boring

For the first 3 files I translated, term recognition worked just fine, but it has now simply stopped working, and I only get "No results available" every time. Manual termbase search from within Studio still works, and term recognition works in Trados 2007, but it simply won't automatically look up terms for me in Studio 2009. Why did it suddenly stop working?

Probably it's a well known bug.
Ther Studio/Multiterm interoperation is broken when Workbench is launched.
I think it's rather scandalous as behaviour.

So... is it back to manual term searches or using Trados 2007 for me? I'm desperately trying to finally squeeze value out of my Studio 2009 investment here (which isn't easy), so a solution would be welcome.

Go to http://talisma.sdl.com and type launchstudio (one word) in the search box.

Cheers
GG


Direct link Reply with quote
 

Morten Narboe  Identity Verified
Local time: 08:45
English to Norwegian
+ ...
TOPIC STARTER
Thank you Sep 12, 2010

Thank you for taking the time to point this out, Grzegorz.

It looks like this launchstudio thing will clear up the mess that Trados makes and allow me to use term recognition again.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

This file contains more than one source and/or target language

Advanced search







LSP.expert
You’re a freelance translator? LSP.expert helps you manage your daily translation jobs. It’s easy, fast and secure.

How about you start tracking translation jobs and sending invoices in minutes? You can also manage your clients and generate reports about your business activities. So you always keep a clear view on your planning, AND you get a free 30 day trial period!

More info »
BaccS – Business Accounting Software
Modern desktop project management for freelance translators

BaccS makes it easy for translators to manage their projects, schedule tasks, create invoices, and view highly customizable reports. User-friendly, ProZ.com integration, community-driven development – a few reasons BaccS is trusted by translators!

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search