Problem with tags in Trados Studio 2009
Thread poster: Temperance

Temperance
Italy
Local time: 11:57
English to Italian
+ ...
Sep 14, 2010

Hi!
I have a problem with the translation of a PDF document in Trados Studio 2009. It is a PDF document generated from an InDesign file (that I don't have).
I've converted it, but when I've started to translate it I've noticed that there are many tags in each segment. There are two tags (opening and closing) before each word and it's not easy to translate, because I need to change the number of words or the word order in a sentence and with all these tags the translation process will be very very slow.

For example:
I have a problem with SDL Trados.


All tags are similar to this one:
< cf font="Arial" size="10" fontcolour="0x0" spacing="-0.25" > < /cf >
Only spacing changes.

Can someone help me, please?

[Modificato alle 2010-09-14 18:47 GMT]


 

SDL Community  Identity Verified
United Kingdom
Local time: 11:57
English
PDF's Sep 14, 2010

Hi Temperance,

If you can't hide the tags in the view and they are too many to work sensibly with then my advice would be to Save the source as soon as you open it. This will give you a word document in a similar format. Then you tidy up the word document to remove all unwanted tags and then translate the word document instead of the pdf.

This is only one solution if you can't get the InDesign file (INX or IDML) from your client. You could also tackle it with a bespoke pdf tool like Abby Fine Reader or similar. Most Translators have their preference.

Regards

Paul


 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:57
Member (2003)
Polish to German
+ ...
Use a decent PDF converter or better OCR software Sep 14, 2010

like Abbyy Finereader. Let it read the text, but store it as plain text!
Then open in Word and create formatting on your own. Such document will open and translate in Studio as a no-brainer.

PDF conversion is a tough task and until now I did not find a single program doing it right in automated way, so I always convert manually.
Still better is to ask the customer for the editable file.


 

tectranslate ITS GmbH
Local time: 11:57
German
+ ...
Original file? Sep 15, 2010

While most of the time it's certainly desirable to have the original file at your hands, it probably wouldn't be helpful in this particular case. The InDesign file itself is likely full of those tracking changes. I've seen those before!

And in an InDesign file prepared in such a way any attempt at fixing these things will turn out to be extremely laborious - if you have the InDesign program, that is; otherwise you're back at square one anyway!

Therefore, you are probably better off going the Word route, as suggested by Paul and Jerzy instead.

Regards,
Benjamin


 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:57
Member (2003)
Polish to German
+ ...
InDesign filter Sep 15, 2010

Well, while I agree with Benjamin, that InDesign files are full of unnecessary formatting, the current filter in Studio for InDesign CS2-4 and IDML does allow to remove at least kerning and tracking tags from segments.
So in case of Studio the original InDesign would be very helpful.


 

Temperance
Italy
Local time: 11:57
English to Italian
+ ...
TOPIC STARTER
Thank you Sep 15, 2010

Thank you very much for your help! I've just asked for the InDesign file, but it has been made with InDesign CS-5 which it is not compatible with Studio.

I've tried the Word way, but the problem is that some symbols change into characters, so I will need to control and modify the text after the translation.

I am not familiar with InDesign and I don't even have it. Is it possible to save the Indesign file in a format which is compatible with Studio?


 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:57
Member (2003)
Polish to German
+ ...
IDML would be supported Sep 15, 2010

IDML from CS4 is supported already by Studio SP2, and IDML 5 support is either ppossible now or underway - I am not sure for that. But you could simply ask for an IDML 4 file. This would be compatible with Studio.

When you try Word: I am not sure, if I understand you correctly, but if you reformat Word prior to translation (if you used Studio to open PDF, follow Paul's advice, save the untranslated document as target and edit tha Word doc) nothing bad should happen.
If the only problem with Word is character formatting appearing in the middle of words/segments, try "CodeZapper", this was posted somwhere here.
Or try the following:
Open Word, press CTRL+A to select the whole text.
Press CTRL+D to get to character settings. Change to the second tab and set kerning to 0 and scale to 100%. This will remove most unnecessary tags. If you also know, that the document uses just one font, apply that one explicitly to the whole document.


 

SDL Community  Identity Verified
United Kingdom
Local time: 11:57
English
CS5 IDML is supported in SP2 Sep 15, 2010

Jerzy Czopik wrote:

IDML from CS4 is supported already by Studio SP2, and IDML 5 support is either ppossible now or underway - I am not sure for that.


Hi all,

Just to confirm that IDML from CS5 is indeed supported by SP2 as long as you have at least Cumulative Update 5 - see http://talisma.sdl.com/article.aspx?article=3135&p=1 - released in May this year.

Regards

Paul


 

ENteCH  Identity Verified
China
Local time: 17:57
English to Chinese
+ ...
same problem Oct 5, 2010

I have same problem, it is boring, why can not Trados hide those tags?

 

Jerzy Czopik  Identity Verified
Germany
Local time: 11:57
Member (2003)
Polish to German
+ ...
Because your source document is formatted like this Oct 5, 2010

xuanping wrote:

I have same problem, it is boring, why can not Trados hide those tags?


Well, it is really boring - to read all the time all the same moaning.
Would the software produce the target which is formatted differently than the source, you would cry the software is bad, because it cannot keep formatting. Now it tries to keep the formatting and you cry it shouldn't. Sorry, but please try to understand how documents are formatted. It is the nature of formatting, that it produces tags. otherwise Word (or Quark, InDesign, whatever) would not know how to format text. Now if the text is formatted properly you have just the necessary tags there. If your source is however poorly formatted you can either correct the formatting upfront or live with that in tagged format. The software cannot really tell, which formatting is necessary and which not. Removing formatting may lead to a target differing from the source and certainly to even more user claiming the software is not working right.


 
Try Code Zapper Oct 6, 2010

xuanping wrote:

I have same problem, it is boring, why can not Trados hide those tags?


http://www.proz.com/forum/memoq_support/170527-how_to_identify_tags_in_memoq-page2.html#1543391



Code Zapper will clean up a lot of the collateral damage from trying to translate a converted pdf file.


 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Problem with tags in Trados Studio 2009

Advanced search







CafeTran Espresso
You've never met a CAT tool this clever!

Translate faster & easier, using a sophisticated CAT tool built by a translator / developer. Accept jobs from clients who use SDL Trados, MemoQ, Wordfast & major CAT tools. Download and start using CafeTran Espresso -- for free

More info »
Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search