Studio: Why is the font size sometimes smaller in target segment than in source segment?
Thread poster: Fredrik Pettersson

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
Sep 18, 2010

SDL Studio 2009: Why is the font size sometimes smaller in target segment than in source segment?

For some target segments, the font becomes smaller compared to the font in corresponding source segment when I place the cursor in the beginning of the target segment and begin to type my translation. Why?

The only solution I have now is to copy source text into target segment and change some of it. But I can only change inside the copied source text in order to keep the original source font size.


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 15:27
Member (2010)
Spanish to English
change the font size Sep 18, 2010

Go to Tools>options>editor>font adaptation and choose the size of source and target font you want.

Direct link Reply with quote
 

JaneD  Identity Verified
Sweden
Local time: 15:27
Member (2009)
Swedish to English
+ ...
I'd love to know how to fix this, too! Sep 18, 2010

Emma - sadly your suggestion of changing the font size isn't addressing this particular problem. This is when the font size in a single target segment is incorrect compared to the source segment. Or when, as a more obvious example, the target isn't bold when it ought to be, although that's easy to fix with Ctrl-B.

I too have this issue - though more often with Trados 2007 than with Studio 2009 - and the only solution I have found is to copy and paste and then type in the middle of the pasted section, just like Fredrik. If it was even possible to copy and paste from the source and then just overtype the existing text from the start of the pasted section it wouldn't be so bad!

It is very annoying, and I'd love to know how to fix it.


Direct link Reply with quote
 

Jerzy Czopik  Identity Verified
Germany
Local time: 15:27
Member (2003)
Polish to German
+ ...
This is not an issue! Sep 18, 2010

You need to understand the principle of any CAT tool.
You do not work on original text, but on tagged text, even if you do not see tags.
Please imagine the following (this symbol | represents the cursor):

You see text in bold in Word.

The above sentence is exactly as you see it. But for Word it looks (simplified) like this:

You see text in bold in Word.

Now let us insert the cursor at the beginning of this sentence.

You |see text in bold in Word.

When you now move the cursor to the right using arrow keys and observe the button for "Bold" formatting on Word tool bar you will see, that this button is still off, when the cursor is here:

You see text in |bold in Word.

This is because:

You see text in |bold in Word.

The cursor is befoire the tag. Now move the cursor to the end of the bold word:

You see text in bold| in Word.
You see text in bold| in Word.

Now the bold button is on.

When you move the cursor further to the right, the bold button will be off again.

Now move the cursor to the left with the arrow key pointing left and stop here:

You see text in bold| in Word.

The bold button will be off, and when the cursor stand at the beginning of the word, the button will be on! Exactly the opposite situation to when you came from left!

But if you look here everything is clear:

You see text in bold| in Word.

and

You see text in |bold in Word.


Same happens in Studio. There are tags in your segments, and you start type before the tag is inserted. Show tags and formatting or even better only tags and no formatting and you will never have any problems like this.

[Edited at 2010-09-18 08:56 GMT]


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 15:27
Member (2010)
Spanish to English
copy all source to target Sep 18, 2010

Jerzy is right of course about the use of tags.
And, Janed, if you want to copy all source to target, simply go to Translation>copy all source to target, or use the shortcut Alt+shift+ins.


Direct link Reply with quote
 

Peter Nicholson  Identity Verified
Poland
Local time: 15:27
Polish to English
Only copy the tags Sep 18, 2010

Fredrik and Janed, until recently I faced the same problem, so I know how you feel.

Jerzy is right to say you need to pay attention to hidden tags in the source segment.

When this problem occurs, it means there are some tags in the source segment which you cannot, as yet, see. To make them visible, the easiest way is to use the keyboard shortcut Ctrl + Shift + H. After doing this there are several different ways of displaying the tags. These options are found in: Format (uppermost toolbar) - Tag Display Mode. You can also select these options using icons in one of the other toolbars, and no doubt there are keyboard shortcuts, too. For the present purpose, it doesn't matter which mode you select, as long as you can see the tags.

When you can see the tags, you no longer need to copy the entire segment - it is easier to copy only the tags, not forgetting that tags always come in pairs - an opening and a closing tag.

To do this, first position the cursor where you want the tags to appear in the target segment. This may simply be at the beginning of a new, empty segment. Leave the cursor there. Then press Ctrl and keep it pressed. Next, move the mouse pointer over one of the pair (doesn't matter which one) which you want to copy and click on it. This will copy both tags to the target segment. Then you only have to reposition the cursor so that it is in between the opening and the closing tag. I find it easiest to do this by using the left and right keyboard arrows.

A more advanced way of achieving the same is to use the keyboard shortcut Ctrl + , (that's a comma). Place the cursor where you want the opening tag to appear. Again, this may simply be at the beginning of a new, empty segment. Then press Ctrl + , . This will copy the tags for you, although if there are several pairs of tags in the source segment you will have to select the correct tag from a drop-down menu, using the down arrow and enter. This will copy the pair of tags, and the cursor will automatically be in the right place, i.e. in between the opening and closing tags. Using this method, you have to remember to confirm the position of the closing tag at the right moment, again using Ctrl + , and selecting the < /cf> tag.

Hth


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio: Why is the font size sometimes smaller in target segment than in source segment?

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
Déjà Vu X3
Try it, Love it

Find out why Déjà Vu is today the most flexible, customizable and user-friendly tool on the market. See the brand new features in action: *Completely redesigned user interface *Live Preview *Inline spell checking *Inline

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search