Why don't my AutoSuggest dictionary and TM work even though they are activated in project settings?
Thread poster: Fredrik Pettersson

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
Sep 25, 2010

Why don't my AutoSuggest dictionary and TM work even though they are activated
in project settings?

I added a folder with one translateable Word-document and a reference file
(I changed file type to reference after having added it) to an already existing
project, prepared this Word-document and opened it to begin translate. At this
point, I receive this error message:

"Value cannot be null. Parameter name: setup.LanguageDirection.TargetCulture"

Does it have anything to do with that I've selected not to populate target
segments with source segments?

When I then begin to translate, the Autosuggest dictionary and TM don't work
("No open translation memories..."), even though when I check project settings
they are activated for this particular project!

I have a job I must finish before noon Monday 27th September (Chinese time) so I
have to get this to work as soon as possible!


Direct link Reply with quote
 

Astrid Elke Witte  Identity Verified
Germany
Local time: 19:48
Member (2002)
German to English
+ ...
Are they for a different variant of the target language? Sep 25, 2010

They have to exactly match the language variant chosen.

Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 19:48
French to German
+ ...
You need to switch back to target language Sep 25, 2010

Fredrik

In order to add a file to a project, you had to switch to the source folder. Then, once you have added the new files, you need to run the batch task 'Prepare' for each of the newly added files before you can work on them (otherwise you will not have any bilingual SDLXLIFF version of the documents). I hope you have done this.

Once you have created the bilingual files, you then need to switch back to the target folder (select the target language in the drop-down field in the left-hand navigation pane of the 'Files' view) in order to open the newly created bilingual file in the target language folder.

The error message you mentioned shows up if you double-click on a file in the source language folder. The only thing you need to do therefore is to switch to the target language folder before you double.click on the file name.

Walter


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
After following your advice Walter, now the autopropagation from TM works but not AutoSuggest Sep 26, 2010

After following your advice Walter, now the autopropagation from TM works but not AutoSuggest.

The AutoSuggest dictionary is activated in Tools/Options as well as in Project settings when I check, but for some reason I get no autosuggests at all when I type.


Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 19:48
English
Languages we can't tokenize Sep 26, 2010

Hi Fredrik,

Apologies I didn't notice your language pairs earlier. AutoSuggest doesn't work for languages which we can't tokenize (i.e. break into words), such as Japanese, Chinese, and Thai. This is not a restriction on a language being "Asian" or not since we can tokenize Vietnamese and Korean for example and it should work for these.

Note: AutoSuggest from a Termbase should be ok, but AutoSuggest from the TM through a generated AutoSuggest Dictionary is not.

Regards

Paul


[Edited at 2010-09-26 12:50 GMT]


Direct link Reply with quote
 

Fredrik Pettersson  Identity Verified
Hong Kong
Member (2009)
English to Swedish
+ ...
TOPIC STARTER
Actually this is English-Swedish translation, although for a Chinese company Sep 26, 2010

Actually this is English-Swedish translation, although for a Chinese company. So the AutoSuggest dictionary should work, but it doesn't for some reason. The autopropagation works, but I think I set the match level to low (75 %) so I get too weak matches.

Direct link Reply with quote
 

SDL Community  Identity Verified
United Kingdom
Local time: 19:48
English
This is what should be activated Sep 26, 2010

Fredrik Pettersson wrote:

Actually this is English-Swedish translation, although for a Chinese company. So the AutoSuggest dictionary should work, but it doesn't for some reason. The autopropagation works, but I think I set the match level to low (75 %) so I get too weak matches.


Hi Fredrik,

Can you check that you have AutoSuggest Options set in these locations? In Tools - Options you have these settings;



You need to enable it, and then check which information you would like to see presented from the AutoSuggest (Termbases, AutoSuggest Dictionaries, AutoText). You also have a couple of options for refining the information that might be worth considering if you still don't get any results after checking this.

Then, in Tools - Options (and also Project Settings if you have a Project set up without Tools Options being refined first) you need to ensure that the specific language pair actually has an AutoSuggest Dictionary added;



Can you confirm you are set up in this way?

Regards

Paul


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Why don't my AutoSuggest dictionary and TM work even though they are activated in project settings?

Advanced search







WordFinder
The words you want Anywhere, Anytime

WordFinder is the market's fastest and easiest way of finding the right word, term, translation or synonym in one or more dictionaries. In our assortment you can choose among more than 120 dictionaries in 15 languages from leading publishers.

More info »
memoQ translator pro
Kilgray's memoQ is the world's fastest developing integrated localization & translation environment rendering you more productive and efficient.

With our advanced file filters, unlimited language and advanced file support, memoQ translator pro has been designed for translators and reviewers who work on their own, with other translators or in team-based translation projects.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search