Tageditor problem: DTD settings don't match
Thread poster: Robin Song

Robin Song  Identity Verified
Local time: 01:36
English to Chinese
+ ...
Oct 2, 2010

My customer provides me a correct DTD settings file. Each time when I open a translation file with this .ini file, I am asked to locate the correct DTD settings file, and then the message "The name of the settings used in the document and the currently selected DTD settings file do not match" appears. After clicking Yes I can translate the file correctly. Now the problem is, I have hundreds of files to translate, and I want to open several files at once, because quite a lot of files are with 0 or few words. I just want Tageditor to ignore the non-match issue and open the files without prompting a message. Could anybody provide a solution for this issue? Many thanks!

 

Piotr Bienkowski  Identity Verified
Poland
Local time: 19:36
Member (2005)
English to Polish
+ ...
Glue? Oct 2, 2010

Robin Song wrote:

My customer provides me a correct DTD settings file. Each time when I open a translation file with this .ini file, I am asked to locate the correct DTD settings file, and then the message "The name of the settings used in the document and the currently selected DTD settings file do not match" appears. After clicking Yes I can translate the file correctly. Now the problem is, I have hundreds of files to translate, and I want to open several files at once, because quite a lot of files are with 0 or few words. I just want Tageditor to ignore the non-match issue and open the files without prompting a message. Could anybody provide a solution for this issue? Many thanks!


Maybe you could use the SDL Trados Glue Utility to glue all or several small files into one for translation, and then use the same utility to unglue them.

Hopefully the annoying message won't appear when you open the glued file.

HTH

Piotr


 

Robin Song  Identity Verified
Local time: 01:36
English to Chinese
+ ...
TOPIC STARTER
Thanks for help Oct 2, 2010

Hi Piotr,

Thanks for the helpful information. I never tried this utility before, but I think it is the best solution for this issue.

Kind regards
Robin


 

Michal Glowacki  Identity Verified
Poland
Local time: 19:36
Member (2010)
English to Polish
+ ...
double message Oct 2, 2010

double message - sorry

[Edited at 2010-10-02 19:21 GMT]


 

Michal Glowacki  Identity Verified
Poland
Local time: 19:36
Member (2010)
English to Polish
+ ...
To surpress the message... Oct 2, 2010

..you can also try making sure that the settings name file matches the one in the file, to check that you need to open the settings file in notepad (e.g. notepad++) and open the source file in notepad (is it XML or TTX?) and make sure the names match. If not - you can change the name inside the ini file. TO make sure it's all ok also amend the actual file name. Had a similar problem with XML files and a DTD file for them. Once the names match everything is fine. Let me know if that helps.

Thanks,
Michal


 

Robin Song  Identity Verified
Local time: 01:36
English to Chinese
+ ...
TOPIC STARTER
Thanks Michal Oct 3, 2010

Michal Glowacki wrote:

..you can also try making sure that the settings name file matches the one in the file, to check that you need to open the settings file in notepad (e.g. notepad++) and open the source file in notepad (is it XML or TTX?) and make sure the names match. If not - you can change the name inside the ini file. TO make sure it's all ok also amend the actual file name. Had a similar problem with XML files and a DTD file for them. Once the names match everything is fine. Let me know if that helps.

Thanks,
Michal


Hi Michal,

I opened the source file in notepad and found the ini filename in it didn't match the existing ini filename. I renamed the existing ini filename, but it couldn't solve the problem. Then my client provided me with another ini file which had the matching filename and different size, now the annoying message doesn't appear. So I think the original ini file is not appropriate although it allows me to head on.

Thanks for providing another clue for solution!

Kind regards
Robin


 

Michal Glowacki  Identity Verified
Poland
Local time: 19:36
Member (2010)
English to Polish
+ ...
happy to help Oct 3, 2010

No problemicon_smile.gif Glad I could help.

 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Tageditor problem: DTD settings don't match

Advanced search







SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »
Protemos translation business management system
Create your account in minutes, and start working! 3-month trial for agencies, and free for freelancers!

The system lets you keep client/vendor database, with contacts and rates, manage projects and assign jobs to vendors, issue invoices, track payments, store and manage project files, generate business reports on turnover profit per client/manager etc.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search