Studio 2009 - how to deactivate double-click shortcut in editor
Thread poster: Kerstin Green

Kerstin Green  Identity Verified
United Kingdom
Local time: 08:44
English to German
+ ...
Oct 5, 2010

Hi everyone

I have a rather trivial problem, but is annyoing me no end and I just can't find how to fix it.

In Studio 2009, in the Editor, when I double-click in a segment in the target column, it automatically inserts the source segment. I hate that, because from all other applications I am used to double-clicking on a word to select it. So when I want to quickly select a word (for deleting/changing/formatting), I instead end up with losing my already typed target text and get the source text.

And I cannot see how I could 'unlearn' this use of the double-click after countless years of using it in that way?!

Is there any way to change this feature?

Thanks!
Kerstin


Direct link Reply with quote
 

Laura Bissio CT  Identity Verified
Uruguay
Local time: 04:44
Member (2008)
English to Spanish
+ ...
try this Oct 5, 2010

hi,
you should try this, go to: Tools - Options - Keyboard shortcuts - Editor (my Trados is in Spanish, but I think these names are right)
there you'll find all the shortcuts and you can change them.

Hope it helps.

Good luck!


Direct link Reply with quote
 

Kerstin Green  Identity Verified
United Kingdom
Local time: 08:44
English to German
+ ...
TOPIC STARTER
Not on the keyboard... Oct 5, 2010

Laura Bissio CT wrote:

hi,
you should try this, go to: Tools - Options - Keyboard shortcuts - Editor (my Trados is in Spanish, but I think these names are right)
there you'll find all the shortcuts and you can change them.

Hope it helps.

Good luck!


Thanks Laura

I had already looked there, but it seems to be only keyboard shortcuts, and this is a mouse-action...

Or am I blind?

[Edited at 2010-10-05 12:09 GMT]


Direct link Reply with quote
 

Emma Goldsmith  Identity Verified
Spain
Local time: 09:44
Member (2010)
Spanish to English
forum topics Oct 5, 2010

There are other forums on double-click issues
http://www.proz.com/forum/sdl_trados_support/161321-cant_format_the_target_segments_in_trados_2009_sp2.html#1357360
http://www.proz.com/forum/sdl_trados_support/148240-insert_overwrite_problem_in_editor_mode.html#1239350
HTH


Direct link Reply with quote
 

Lutz Molderings  Identity Verified
Germany
Local time: 09:44
Member (2007)
German to English
+ ...
not for me Oct 5, 2010

Kerstin Buessenschuett wrote:

In Studio 2009, in the Editor, when I double-click in a segment in the target column, it automatically inserts the source segment.


Strange, Studio doesn't behave like this for me.
If I double-click on a word in the target column it simply highlights the word as in any other application.
Sorry, can't help ..


Direct link Reply with quote
 

hhl
Local time: 09:44
English to German
Mouse Driver? Oct 5, 2010

You might still change the shortcut, as Laura advised and look what happens. If the source text is no longer copied then, when you double-click, then your double-click might just create the code that you previously had in the shortcut table. Try it out.
Remember that mouse behaviour might be programmable if a specific mouse driver is installed. Who knows?


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 09:44
French to German
+ ...
This is not standard behaviour Oct 5, 2010

Kerstin Buessenschuett wrote:

Hi everyone

I have a rather trivial problem, but is annyoing me no end and I just can't find how to fix it.

In Studio 2009, in the Editor, when I double-click in a segment in the target column, it automatically inserts the source segment. ...


Hi Kerstin

Just want to confirm that this behavior is not standard in Studio. If you get this, it must be something specifically related to your configuration (mouse driver, etc.) but it is not definitely not configurable in Studio.

Walter


Direct link Reply with quote
 

Nick Quaintmere  Identity Verified
Germany
Local time: 09:44
German to English
External interference Oct 9, 2010

I think Walter may be right on this issue. I have had the same problem. First it was there, then it was gone and then suddenly with SP3 it was back again (coincidence, it actually had nothing to do with the update).

The Keyboard shortcuts are not the answer, as this has nothing to do with mouse behaviour. Mouse drivers are also unlikely as the culprit.

However, after checking Emma's link I found that we both had had the same problem. In our case Oxford Dictionary software. This can be set up to automatically look up words when you double click. It does this by automatically copying them to the clipboard. While this may be useful to some users, I have found it can cause all sorts of unexpected problems. As soon as I unchecked the "Look up words from other applications" option the problem was gone.

Check to see if you have any similar program that may be acting on Trados in this way.


Direct link Reply with quote
 

Walter Blaser  Identity Verified
Switzerland
Local time: 09:44
French to German
+ ...
Other applications should not interfere Oct 9, 2010

First, it is good to hear that you have been able to find the culprit and managed to solve your problem.

On the other hand, let me point out that this indicates a problem with your Oxford Dictionary application. It should be programmed in a way that lets you choose which source applications should react on such a double-click. Obviously, if the double -click is intercepted from all applications, it puts you in trouble.
I have a similar situation with the Langenscheidt dictionaries, which also offer a option to customize keyboard shortcuts for word capturing, but they are restricted to well-defined applications such as Word or other editors.

Walter


Direct link Reply with quote
 

Kerstin Green  Identity Verified
United Kingdom
Local time: 08:44
English to German
+ ...
TOPIC STARTER
Eureka! Oct 10, 2010

Yes, that is it! Thanks so much to Emma and Nick for putting me on the right track there, I don't think I would have ever found it...

I did not work with Studio for a few days after I posted this problem (no problems like this in my beloved Across...), and when I worked with it again yesterday the problem was gone. But I did not have any dictionaries open, so there you go.

I unchecked the option in my SOED program and all seems fine now.

That was just one of those things where you have so many factors that it becomes nearly impossible to figure out who the culprit is...

So, thanks again!

Kerstin


Direct link Reply with quote
 

Z Hann Cifuentes  Identity Verified
United States
Local time: 03:44
Member (2008)
English to Spanish
+ ...
The same problem Feb 2, 2012

Hello.

I have the same problem. I have tried installing Studio 2009 and 2011 different computers with Widows Vista - Windows 7 and have the same problematic issue with all of them . When I double click in the editor window the source text is copied to the target and it activates the "insert" mode automatically. This does not happen with any other program. I use Trados suite 2007 and WordFast and do not experience the same issue wit the latter. I do not have Oxford Dictionary installed, so I am not clear on how some people here were able to solve the problem. Please explain in detail what steps need to be taken. I also checked the suggested links and could not find any specific solutions. Thanks.


Direct link Reply with quote
 

Miguel Armentia
Spain
Local time: 09:44
English to Spanish
+ ...
Babylon 8 was to blame in my case Jul 15, 2013

I found very useful this KB Trados article:

http://kb.sdl.com/?portalid=23&articleid=2746#tab:homeTab:crumb:7:artId:2746

I hope you can solve your problem as I did.

Best,


Direct link Reply with quote
 

Lito Christoforidou  Identity Verified
Greece
Local time: 10:44
English to Greek
+ ...
Thank you! Nov 12, 2013

Thank you (Emma, Nick and all others contributing) so-so much for offering the solution to this annoying problem! I work with Trados 2014 and it was Oxford Dictionary that caused the malfunction, for me too.

I know it's been quite some time since the first posts in this discussion, yet I thought I should pay my respects anyway.


Direct link Reply with quote
 


To report site rules violations or get help, contact a site moderator:


You can also contact site staff by submitting a support request »

Studio 2009 - how to deactivate double-click shortcut in editor

Advanced search







Anycount & Translation Office 3000
Translation Office 3000

Translation Office 3000 is an advanced accounting tool for freelance translators and small agencies. TO3000 easily and seamlessly integrates with the business life of professional freelance translators.

More info »
SDL Trados Studio 2017 Freelance
The leading translation software used by over 250,000 translators.

SDL Trados Studio 2017 helps translators increase translation productivity whilst ensuring quality. Combining translation memory, terminology management and machine translation in one simple and easy-to-use environment.

More info »



Forums
  • All of ProZ.com
  • Term search
  • Jobs
  • Forums
  • Multiple search